LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-07-2009, 11:21 AM   #1
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 498

Rep: Reputation: 35
openoffice: file not found


Hi.
There's a small problem. There are some doc and xls files that openoffice can't open, not when you double-click in the filemanager neither when you try to open from the OOO open dialog. It says "file not found". The files are in the home folder. The interesting part is that it seems quite random which files are opened or not. OOO3 is used and Mepis8 (KDE) in this case. The file permissions were also checked and they were fine. Any ideas?
Thanks.
 
Old 08-07-2009, 01:03 PM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Do the files appear when you navigate to the correct folder in the openoffice "Open" dialogue window? Does the file appear in the "File Name" bar when you click on the file?
cheers,
jdk
 
Old 08-07-2009, 02:04 PM   #3
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 498

Original Poster
Rep: Reputation: 35
It does appear, otherwise it wouldn't be possible to select it, an click open and get the message "file not found".
 
Old 08-07-2009, 02:18 PM   #4
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,572

Rep: Reputation: 209Reputation: 209Reputation: 209
It might be an idea to check the properties of these files. Try using the file manager to right-click on these files that OOo3 can't open, select properties, and see what the reading is of the files. Sometimes gremlins just create files that actually are zero bytes, and are simply an empty void with a name.

If there is substance to the files, can you open them with another word processor? Like KWord, Abiword, or Ted?
 
Old 08-07-2009, 02:42 PM   #5
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
@mark_alfred What's strange is that I can't replicate the problem. I click on all kinds of inappropriate files and OOo will try to open them. libraries, binary executables, whatever. OOo never says it can't find the file. The filter is set to "all files".

@pusrob Can you post the output of ls -l + the file name of one of your misbehaving files. What version of Openoffice are you running?
jdk

Last edited by jdkaye; 08-07-2009 at 02:43 PM.
 
Old 08-07-2009, 03:16 PM   #6
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,572

Rep: Reputation: 209Reputation: 209Reputation: 209
Quote:
Originally Posted by jdkaye View Post
@mark_alfred What's strange is that I can't replicate the problem. I click on all kinds of inappropriate files and OOo will try to open them. libraries, binary executables, whatever. OOo never says it can't find the file. The filter is set to "all files".
Likewise, I too am not sure what the problem could be. Still, I think it's a good idea to try opening the problematic files with another word processor and/or text editor. This way, he/she can see if the issue lies with the files, or with OOo.

Last edited by mark_alfred; 08-07-2009 at 03:19 PM.
 
Old 08-08-2009, 06:51 AM   #7
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 498

Original Poster
Rep: Reputation: 35
OOO 3.1 is used. The problematic files are not 0 byte files. The ls -l will show you the permissions, right? Well, I already checked them, and they were fine. Some of these files have accented letters like á or é in their names but renaming them to not accented names doesn't help. Abiword will be tried then... Let's see if it can open those problematic files...
 
Old 08-08-2009, 06:16 PM   #8
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 498

Original Poster
Rep: Reputation: 35
Hi.
I found out what was the problem. The path folders also had some accented letters, and after I renamed them to non-accented, the problem disappeared. This is very annoying that OpenOffice can't handle accented paths and filenames. This shouldn't be a problem nowdays .
 
Old 08-09-2009, 12:54 AM   #9
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by pusrob View Post
Hi.
I found out what was the problem. The path folders also had some accented letters, and after I renamed them to non-accented, the problem disappeared. This is very annoying that OpenOffice can't handle accented paths and filenames. This shouldn't be a problem nowdays .
Hi Pusrob,
Sorry, I was unable to replicate your problem. I created a folder called "élève" and copied a bunch of .odt files into it. Then I opened Openoffice and navigated to that folder. I saw all the files I had copied and selected one and tried opening it. It opened with no problem and the same was true for all the other files in that folder. I don't think you should be annoyed at Openoffice. OOo seems perfectly capable of opening files from folders with accents in their names. The problem seems to be limited to your system. You can always repeat my experiment and see if suddenly the files can no longer be opened.

I tried the same experiment calling the folder "tegeződés" and still no problem.

Cheers,
jdk

Last edited by jdkaye; 08-09-2009 at 01:03 AM.
 
Old 08-09-2009, 03:25 AM   #10
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,572

Rep: Reputation: 209Reputation: 209Reputation: 209
When I created a directory, and then file, with the name tegeződés (the file called tegeződés.odt), I will say that openoffice.org did struggle more with it than it did with a file without the foreign accents. However, after asking me what character set (or font) should be applied, it did open the file. So, it likely has to do with whether certain font packages are installed, or something.
 
Old 08-09-2009, 07:05 AM   #11
pusrob
Member
 
Registered: Jan 2006
Distribution: Gentoo
Posts: 498

Original Poster
Rep: Reputation: 35
Quote:
Originally Posted by jdkaye
Sorry, I was unable to replicate your problem.
No problem at all.
Quote:
Originally Posted by jdkaye
I created a folder called "élève" and copied a bunch of .odt files into it. Then I opened Openoffice and navigated to that folder. I saw all the files I had copied and selected one and tried opening it.
It worked for me too, until this part. OOO did see the files in the open dialog, but when selected a file and clicked open, the "file not found" message came.
Quote:
Originally Posted by jdkaye
The problem seems to be limited to your system.
Files created on my system do seem to open, but those created on Windows by MS-Word don't. Is it possible that Windows uses a kind of different character encoding that causes the problem? I know it shouldn't be the case but who knows...

Oh, one more thing. Did you try to open .doc files (created on a windows) with accented path and filenames? Maybe a different filter is used inside OOO that cannot handle accented names yet. This is only a speculation though.

Last edited by pusrob; 08-09-2009 at 07:08 AM.
 
Old 08-09-2009, 11:05 AM   #12
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,465

Rep: Reputation: Disabled
Quote:
Originally Posted by pusrob View Post
No problem at all.
It worked for me too, until this part. OOO did see the files in the open dialog, but when selected a file and clicked open, the "file not found" message came.
Files created on my system do seem to open, but those created on Windows by MS-Word don't. Is it possible that Windows uses a kind of different character encoding that causes the problem? I know it shouldn't be the case but who knows...

Oh, one more thing. Did you try to open .doc files (created on a windows) with accented path and filenames? Maybe a different filter is used inside OOO that cannot handle accented names yet. This is only a speculation though.
Now I've tried it with .doc files and as before, they load with no problems, not even the problems that Mark mentioned. So I still think the problem is on your system somehow.
cheers,
jdk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to execute a script file? Have file/directory not found error sirius57 Linux - Software 2 11-22-2007 12:43 AM
OpenOffice install query: no such "soffice" found ic_torres Linux - Software 4 08-13-2007 06:46 AM
snmpd installed, see file, but get error file not found PCHelper Slackware 0 11-06-2003 01:44 PM
OpenOffice tells me GPC files not found. rising_sun Linux - General 3 07-08-2002 08:26 PM
OpenOffice and Print to File my1wong Linux - Software 1 06-26-2002 01:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration