LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   openoffice and base won't work because of jre problems (https://www.linuxquestions.org/questions/linux-software-2/openoffice-and-base-wont-work-because-of-jre-problems-646712/)

tethysgods 06-03-2008 01:12 PM

openoffice and base won't work because of jre problems
 
I have installed openoffice 2.4.0, and it seems to want jre-1.6.

However, as others have found, you go to tools->options->java
and it sees jre-1.4 which isn't there. If you go to "add" and put in the location of jre-1.6 it won't recognise it at all. I also
tried adding to PATH and CLASS_PATH, but still nothing. Not only that, I tried adding the pathe to where jre-1.4.2 actually is, but it ignores that too (/usr/local/lib/jvm or /usr/local/lib/jvm/jre-1.4.2) Neither work.

However, I do see gcj-1.4. Now my gcc version is gcc-4.1.1, and I I suppose the jre-1.4 files I have were unpacked with gcc?. (Yes I have loads of jre-1.4.1 files ... I have no idea where they came from really. Also, jre-1.4.2 is at its "end of life transition" according to Sun so 1.6 seems a better idea)


So I really have two questions.

Did my gcc unpack the gcj-1.4.2 files, If so, should I install the latest gcc which (might) unpack gcj-1.6? (Or is the gcj bit a complete red-herring?)

And why won't "Add" in office/java/options add anything, even if it is there?

markkie 06-03-2008 04:42 PM

Hi, I also had this problem I found the solution on http://ubuntuforums.org/archive/index.php/t-678751.html

Hope this helps.....look towards the bottom.... OpenOffice works fine after removing $HOME/.openoffice.org2/user/config/javasettings_Linux_x86.xml file

knudfl 06-03-2008 05:17 PM

Mandriva 2007 ??
Suggest : Uninstall all gcj-4.xx, java-1.x.x-gcj and java-1.x.x-icedtea (if there)
(and if you can (dependency concern)) Then install genuine 'sun-java-1.5 (or 1.6)
from http://www.java.com/en/download/linux_manual.jsp
This 'sun-java' will work with all applications, 'gcj' will not.
To know your installed packages, run command 'rpm -qa | sort > package-list.txt'
making a textfile in /home with all 'rpm' stuff.
By the way : gcc makes no java, gcj etc. are seperate packages.

Regards and good luck!
Edit: Sorry double answer, thought I lost it by editing.

tethysgods 06-06-2008 12:44 PM

I thought that using the latest openoffice would be a good idea (with new features and so on).
However on Mandriva 2007.0 at least, there is now way it will pick up the jre.

The problem (seems to me at least) is either with openoffice 2.4 itself or the way that the
rpm installs it. I did read somewhere today that some people have just gone back to version 2.3, and I decided to do so.

The thing is, though I downloaded 2.3 from openoffice, I recalled that 2.3 came bundled with the Mandriva 2007.0, and I installed it that way after uninstalling 2.4. So, I can't tell anyone if 2.3 works if you have to download it directly from openoffice.

Nevertheless, for me, the 2.3 version picks up the latest jre from Sun no problem. Now to learn this stuff! (All I have donw so far is to find that it locates all the jre versions I have...

Hope this helps someone...

Chris


All times are GMT -5. The time now is 07:51 PM.