-   Linux - Software (
-   -   openldap in solaris 8 boxes how to. (

sasibagavathsingh 01-19-2009 08:53 AM

openldap in solaris 8 boxes how to.

I have configured openldap in EL4 and configured clients on redhat 6.2, EL4 servers. it is working fine.

I am new to solaris OS. I do not know how to configure solaris as a client of openldap server.

I tried some links from net but helpless.:-(

Please help me on this /refer a good article to configure solaris as ldap client.

thanks in advance.

bathory 01-19-2009 10:03 AM

Hi and welcome to LQ

You might take a look at this, or this howto (written for Solaris 10).


sasibagavathsingh 01-20-2009 05:37 AM

Thanks dude...

i have looked into this wiki page.
here, they have described for solaris 10 mine solaris 8.

when i run a command
"ldapclient -v -P Solaris -D cn=proxyagent,ou=Profile,dc=example,dc=com -d -w secret"

getting following error message. Please help me on this.

Arguments parsed:
proxyDN: cn=proxyagent,ou=Profile,dc=example,dc=com
profileName: Solaris
proxyPassword: secret
Handling init option
About to configure machine by downloading a profile
findBaseDN: begins
findBaseDN: ldap not running
findBaseDN: calling __ns_ldap_default_config()
__ns_ldap_list return NULL resultp
findBaseDN: Err exit
Failed to find defaultSearchBase for domain

it would be good if there is any document for solaris 8. i can feel lots of diff between 10 and 8 configuration like ldif format and ldapclient command syntax.


bathory 01-20-2009 06:57 AM


findBaseDN: ldap not running
It seems that somehow the client cannot find the server, or the server is not running. Check to see what is wrong.
The ldapclient command is indeed different from Sol8 to Sol10. Try the first link I gave you from the beginning, or use this blueprint to configure your system from scratch to use (open)ldap.

sasibagavathsingh 01-22-2009 06:14 AM

Thanks buddy,

i ran a command in my solaris 8 box
ldapclient -i -w secret -D cn=Manager,dc=example,dc=com -d -r true -b defaultSearchBase=dc=example,dc=com -S "passwd:ou=People,dc=example,dc=com" -S "shadow:ou=People,dc=example,dc=com" -S "group:ou=Group,dc=example,dc=com" -s one

command did not give any error msg and got msg as "System successfully configured" once i disabled the ACL in my ldap server ( openldap ) which is in Linux EL 4.

Now i can able to get list by command getent passwd, ldaplist passwd , ldaplist passwd < >, id < U.Name >, su <U.Name >.

where, my problem is
1.getent passwd command gives only few entry amoung around 800 entries.
but id command shows rest of the user's list.
2.i can not ssh to this machine by ldap user.
3.from root i can able to su to another user who is located in ldap database.
4.From one ldap user to another ldap does not allow to login. which means when i give password, it says "password: Sorry".
Its mean user name resolving from ldap database but password does not allow?

can you help me on this please?

thanks in advance .....

sasibagavathsingh 02-19-2009 12:59 AM

It is working fine. My problem was in my rootdn password at my slapd.conf file.

My password was containing "$" symbols so it could not resolve by solaris boxes.

thanks whoever helped on this.

All times are GMT -5. The time now is 04:56 AM.