LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-21-2010, 09:12 PM   #1
chinho
Member
 
Registered: Dec 2010
Distribution: fedora, openSUSE
Posts: 49

Rep: Reputation: 1
Openldap does not start ./slapd does nothing


Hi guys,

I was trying to run openldap in /usr/local/libexec on ./slapd command.

As usual, it doesn't respond anything which is normal (side qns: can anyone tell me why ./slapd doesn't even return me a status message?)

Then I went on to check ps -ef | grep slapd, but found that the ./slapd was not in process at all (means its not running). If it ran successfully, it should be in my process.

What is wrong? it was still ok yesterday though.

Thanks in advance!
Chinho
 
Old 12-21-2010, 09:13 PM   #2
chinho
Member
 
Registered: Dec 2010
Distribution: fedora, openSUSE
Posts: 49

Original Poster
Rep: Reputation: 1
Ok, I had 2 pcs having this same problem. I solved it on 1 of my pc.

you need to login as root via "su" to run the ./slapd process.

Now its in my process list. Cheers.

But, the problem still remains in my other pc. HELP! Thanks in advance again.

Last edited by chinho; 12-21-2010 at 09:17 PM.
 
Old 12-28-2010, 12:43 AM   #3
chinho
Member
 
Registered: Dec 2010
Distribution: fedora, openSUSE
Posts: 49

Original Poster
Rep: Reputation: 1
Any help??
 
Old 01-05-2011, 05:52 AM   #4
chinho
Member
 
Registered: Dec 2010
Distribution: fedora, openSUSE
Posts: 49

Original Poster
Rep: Reputation: 1
YES, i finally solved it.

After some research, there are 2 ways which I had googled that can solve this prob.

Reason 1
slapd did not start because bdb (Berkeley DB) was corrupted
Solution: Hence, run the slapd_db_recover or db_recover in your ldap database folder. If you do not know where is your database folder, lookup your slapd.conf it should tell you where.

Reason 2
slapd did not start because of invalid paths specified in your slapd.conf
Solution: What I mean is, open up your slapd.conf file. Inside, look out for all the config parameter that is pointing to certain directory or file path.
For eg:
pidfile /usr/local/var/slapd.pid
Please make sure this path is a legal and existing path in your filesystem.


BTW, reason 2 was causing my problem though. After rectifying the paths, everything seems OK.

Hope it helps!
Chinho
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ldap cannot carry slapd.conf changes or did not use /etc/openldap/slapd.conf joel_saul Linux - Server 6 08-21-2010 05:53 AM
openldap (slapd) - authentication using simple name eantoranz Linux - Software 1 08-08-2010 04:19 AM
OpenLDAP slapd.conf corrupted RobTrmr Linux - Software 1 10-14-2009 05:40 AM
OpenLDAP (no slapd.conf) britchaz Linux - Networking 1 05-05-2009 04:29 PM
LXer: OpenLDAP Quick Tips: Using syslog or syslog-ng with slapd for OpenLDAP logging LXer Syndicated Linux News 0 11-14-2008 09:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration