LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   opening MPLAB with java (https://www.linuxquestions.org/questions/linux-software-2/opening-mplab-with-java-4175417818/)

alex321 07-20-2012 11:27 AM

opening MPLAB with java
 
hi I am trying to download MPLAB X v1.30. Once i downloaded it and unpackaged it, an error came up that said

"The installer could not find a version of Java(tm) which could be used for MPLAB X.
Install Java 6 (JRE 1.6.n) from Oracle. (This version of MPLAB X requires Java 6.)"

So I downloaded java jre-7u5.
I am not sure if this is the right version of java?
And also do I have to connect java to mplab

Thanks

knudfl 07-20-2012 02:05 PM

Which version of Ubuntu are you using ? ?

Ubuntu 12.04 ?

alex321 07-20-2012 02:22 PM

I am not sure it is a loner computer i got from school.
Is they a way i can find out?

knudfl 07-20-2012 03:29 PM

This command will reply with Ubuntu version :

cat /etc/issue

alex321 07-23-2012 10:20 AM

it says there is no such file or directory... and by the way i dont believe i have the newest version of linux, i believe its an older version

knudfl 07-23-2012 11:45 AM

An older version ? Then jre-7u5 may not work.

Please use jre-6u31-linux-i586.bin ( If it's a 32bits OS )
http://www.oracle.com/technetwork/ja...d-1501637.html

Install example ...
1) cd Downloads/ ( Or wherever the downloaded jre is kept )
2) chmod +x jre-6u31-linux-i586.bin
3) cd /usr/
4) sudo <path-to-Downloads>/jre-6u31-linux-i586.bin
.. ( My example : sudo /home/knudfl/Downloads/jre-6u31-linux-i586.bin )
5) cd /usr/bin/ && sudo ln -s /usr/jre1.6.0_31/bin/java
... Now you have 'java' in your PATH, and the application can use it.

.

alex321 07-23-2012 01:41 PM

alright i got to step five and when i type in cd /distruser/bin
it says no such file or directory..did i do something wrong with that??

alex321 07-23-2012 01:52 PM

i am not sure what my username is.....well it is distruser but in the terminal it says distruser@pepe because pepe is the root, but im not sure what usr i should use :/

alex321 07-23-2012 02:21 PM

nevermind i figured it out thank you so much i really appreciate your help


All times are GMT -5. The time now is 12:13 AM.