-   Linux - Software (
-   -   OpenGL not working in FC19 due to Catalyst DRI initialization failure (

sabresong 07-31-2013 05:37 PM

OpenGL not working in FC19 due to Catalyst DRI initialization failure
1 Attachment(s)
I recently upgraded my Fedora to FC 19. A little more than a week later, after several updates, I noticed my desktop effects weren't working. When I tried to run a game under Wine, it crashed. After some digging, I found that both issues were related to openGL. About that same time, Thunderbird also started crashing. I'm not sure if that's related or not.

When I run glxinfo, I get the following message:


[mouser@orpheus ~]$ glxinfo
name of display: :0
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  154 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

I'm running FC19 with akmod-catalyst video drivers. I tried replacing the drivers with kmod-catalyst and with the Catalyst drivers available from the AMD site, all with the same result.

I've attached my Xorg.0.log to this post. About 3/4 of the way down, it says:


[    53.532] (EE) fglrx(0): atiddxDriScreenInit failed. Probably kernel module missing or incompatible.
[    53.533] (WW) fglrx(0): ***********************************************************
[    53.533] (WW) fglrx(0): * DRI initialization failed                              *
[    53.533] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[    53.533] (WW) fglrx(0): * 2D and 3D acceleration disabled                        *
[    53.533] (WW) fglrx(0): ***********************************************************

So I think there's a problem with a kernel module. But how to fix it?

sabresong 07-31-2013 09:43 PM

No group X Window System?
In working on this, one suggestion I found was to reinstall xserver. The only way I know to do that is to remove it and then install it. But when I try to remove it, it returns:


[mouser@orpheus ~]$ sudo yum groupremove "X Window System"
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
There is no installed groups file.
No environment named X Window System exists
No group named X Window System exists
No packages to remove from groups

Entering yum grouplist shows X Window System as an available group.

Trying to install the X Window System group tells me


Warning: Group x11 does not have any packages to install.
No packages in any requested group available to install or update

sabresong 08-01-2013 11:04 AM

I was able to get this sorted out. It seems to be a problem with fglrx and the 3.10 kernel. Here are the steps I took:

1. Made sure that kmod-catalyst and akmod-catalyst were removed using yum.

2. Used aticonfig --uninstall=force to completely remove all traces of AMD proprietary driver.

3. Rebooted to kernel 3.9 in terminal.

4. Forced install of AMD Catalyst proprietary driver.

5. Rebooted to kernel 3.10 ---- could not load initramfs.

6. Rebooted to kernel 3.9, removed kernel 3.10.

These steps solved the problem for me. I did reinstall kernel 3.10 to see what would happen. That returned an error building fglrx for kernel 3.10. So I'm going to blacklist kernel 3.10 and report the whole thing as a bug against the kernel.

All times are GMT -5. The time now is 06:00 AM.