-   Linux - Software (
-   -   openchrome installed, X+via blank, X+vesa okay (

Shadow_7 06-06-2007 08:18 AM

openchrome installed, X+via blank, X+vesa okay
I believe I have openchrome installed correctly. But I'm having trouble getting X to play nice with it. When starting X with the via driver I get a blank screen. And it stays blank when I Cntrl+Alt+Backspace out of X.

Normally if it was just blank while in X it would be the monitor refresh rates. But it doesn't appear to be that. When it stays blank afterwords, that's normally an issue with the via driver itself. Which can sometimes be overcome by putting some magic words into your X configuration. Like Option "XAANoSolidRectFill" "on" (or something similar) that I had to do for an i845G chipset.

I've tried several magic words but have not appeased the X gods. To include the following:

Option "PciRetry" "true"
Option "VBEModes" "true"
Option "EnableAGPDMA" "true"
Option "DisableIRQ" "true"
Option "SWCursor" "true"

I've set it up pretty much word for word from this documentation.

And everything appears to be a go, except for not being able to get it in a useable state. Using the VBEModes option seems to lock up the keyboard, although not consistently.

01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 Unichrome] Integrated Video (rev 01)

lspci -n:
01:00.0 0300: 1106:7205 (rev 01)

It's a [KM400/A] VT8378 type host board.
cpu - AMD Athlon(tm) XP 3000+
bogomips - 4203.01
ram - 512MB

I've tried various BIOS/CMOS changes like setting video ram to 64MB and from PCI to AGP/Onboard. But that hasn't helped either. The same xorg.conf works fine when using the vesa driver. I'm trying to overcome another issue by using the via driver so just using vesa isn't ideal at this time.

Shadow_7 06-06-2007 09:34 AM

The /var/log/Xorg.0.log with no extra options.

Shadow_7 06-06-2007 11:13 AM

I should add that using Driver "via" with Load "dri" and Load "glx" commented out and Option "NoAccel" "true" active does start X with the via driver. But without DRI.

Shadow_7 06-06-2007 05:43 PM

I upgraded to the experimental branch of openchrome. And now X starts with dri options in the xorg.conf. But I have yet to get dri working. Although I do get some decent fps's without it. 750fps versus the 200 or 500 I was previously seeing in glxgears. Adding in a Section "DRI" seems to impair that though.

Shadow_7 06-06-2007 08:16 PM

I've got DRI working by hacking around in the legacy /usr/X11R6/lib/module area. A few strategic ln -s 's to libdrm, via_drv, unichrome_dri makes dri work and Openchrome show in glxinfo. I guess I have other issues on this box that I need to address.

Shadow_7 06-11-2007 11:03 AM

I eventually whiped the install and did a fresh one. Somehow things got too messed up over the two or so years it was in use. I had originally cloned it off of the router(pre X, pre mozilla). And through the upgrade process it might have gotten hosed. There were issues when X moved from /usr/X11R6/lib/ to /usr/lib/xorg/ in the upgrade process. And probably several other artifacts.

I was doing a debian install on my old 3.1r3 discs (less than one year old). But that proved to be too tedious, so I installed knoppix on it. With a custom kernel to get ndiswrapper working. However this install lacks sufficient compile tools to install the openchrome drivers. But the default via setup works nicely with DRI under

Eventually I'll get around to upgrading it to debian etch, but initial indications are that that will require 400+MB of updates I previously hadn't gotten. So no hurry of spending two or more days of dedicated downloads on that at the moment. As it is now, I have DRI and I don't have a mozilla or firefox race conditions. Which is what I was trying to achieve.

All times are GMT -5. The time now is 03:46 AM.