LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-11-2013, 03:23 AM   #1
WalhallaManny
LQ Newbie
 
Registered: Jul 2013
Posts: 2

Rep: Reputation: Disabled
Question OpenCA Problem


Hey everybody,

i got a problem to install the software http://www.openca.org/ . I got the OS CentOS 5.9 x86_64 (final) on a virtual machine.

I try to install all Packages and now i got the problem, if i do

openca start

so i got this error: Can't locate X500/DN.pm in @INC

After a little bit time, i found this package: http://mirror2.hs-esslingen.de/ftp.o...1.1.x86_64.rpm

If I try to install this package, i got the error:
Fehler: Fehlgeschlagende Abhängigkeiten:
perl-Parse-RecDescent wird benötigt von perl-X500-DN-0.29-100.1.1.x86_64
rpmlib(PayloadIsLzma) <= 4.4.6-1 wird benötigt von perl-X500-DN-0.29-100.1.1.x86_64

My issus is, that i read in another posting, that i have to do that to solve the error. http://my.opera.com/ruario/blog/2012...-older-distros

But i can't install the rpmrebuild package. Can anybody help me, please?

Greetz
Manny
 
Old 07-11-2013, 08:00 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,680

Rep: Reputation: Disabled
Have you tried installing the X500::DN Perl module using CPAN?
Code:
~$ sudo perl -MCPAN -e shell

[--- will trigger the CPAN setup wizard if you haven't used CPAN before ---]

cpan[1]> install X500::DN

[--- CPAN will download and compile the module and any dependencies ---]

cpan[2]> exit
You can test the availability of the module with:
Code:
perl -e "use X500::DN;"
If the installation was successful, the command above should run without any errors or messages.
 
Old 07-12-2013, 03:11 AM   #3
WalhallaManny
LQ Newbie
 
Registered: Jul 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thank you. Now it's working.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenCA authentication with LDAP server invader7 Linux - Software 0 06-10-2013 01:44 AM
OpenCA and various distros jdpond LinuxQuestions.org Member Intro 0 08-07-2011 10:07 PM
openca and openocsp gadtzucky Linux - General 1 03-30-2011 07:38 PM
How to install OpenCA and it's requirements on Ubuntu Hafedh Linux - Newbie 3 01-26-2010 06:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration