-   Linux - Software (
-   -   Open source logistics software (

rajnikhil 02-14-2012 08:06 AM

Open source logistics software
I'm looking for an open source logistics software for my company and after some searching I've come across 3 apparently viable softwares i.e. Overactive, OSLA and Venture Logistics. These softwares however don't have much written about them on the net pertaining to their installation and usage.

If any of you could guide me with the installation and usage of Overactive and OSLA I'd be really grateful.

I'm going to install and test it on Ubuntu 10.04

Thanks in advance!!!

sag47 02-14-2012 11:46 PM

  1. Download the latest overactive core.
  2. Extract the archive
  3. Read the README file for installation steps and software requirements.

That should be it. It's pretty straight forward and you deploy the ear file in JBoss. Personally I would not use alpha software for anything personal let alone for a company. As far as usage you'll have to figure it out as I've never used it.

OSLA is pretty straight forward to install as well if you understand web technologies. After downloading OSLA do the following.
  1. Create a MySQL user
  2. Create a MySQL database called "osla" and give the MySQL user full permissions on the database.
  3. Import the mysqldump.sql file into MySQL.
  4. Install and configure Apache.
  5. Move all of the files to /var/www/html which is the "install".
  6. Edit file with settings for your mysql user, password, and database.
  7. Visit the server at it's website.

You just need to download the packages and read them a bit. Most open source packages come with readme instructions as part of the package. You should have prior knowledge of Apache (OSLA), JBoss (Overactive), MySQL, and how to deploy the web files. If not don't sweat just google topics for them as there's tons of material on the net.

Hope that helps,

rajnikhil 02-16-2012 08:26 AM

Thanks sag47, I tried getting the OSLA working. I granted all the permissions to the mysql user, created a database "osla" and imported the database dump to the newly created "osla" database form the mysqldump.sql and then extracted the zip file in /var/www/ (no /html as I have no such folder) and updated the username, password and database name in the db.nic in the extracted file. I then accessed the setup by typing http://localhost/osla. I got the log-in page but when I type the mysql username and password and hit enter/login button I return back to the same login page.

Can you help me out here!

Thanks in advance.

sag47 02-16-2012 08:42 AM

When dealing with web technologies the credentials for logging into a web interface aren't usually the same or even close to the database user/password. In the case of this php application it is likely that it is authenticating against the MySQL database since you didn't have to set up LDAP or anything. That being the case you would check the mysqldump.sql file for the username and password you should use on the first run. Now review the following statement I found.


-- Table structure for table 'loginaccount'

DROP TABLE IF EXISTS loginaccount;
CREATE TABLE loginaccount (
  id int(11) NOT NULL auto_increment,
  lastinsert datetime default '0000-00-00 00:00:00',
  lastupdate datetime default '0000-00-00 00:00:00',
  username varchar(64) NOT NULL default '',
  password varchar(64) NOT NULL default '',
  PRIMARY KEY  (id),
  UNIQUE KEY username (username)

-- Dumping data for table 'loginaccount'

INSERT INTO loginaccount VALUES (1,'0000-00-00 00:00:00','2005-05-10 21:46:49','admin','');

Or more importantly...


INSERT INTO loginaccount VALUES (1,'0000-00-00 00:00:00','2005-05-10 21:46:49','admin','');
That means the username is admin and the password is blank. So try that.

rajnikhil 02-17-2012 07:26 AM

No change, it still keeps returning to the login page whether I use the mysql username and password or admin and leave password blank. The part of the code you posted in thread looks the same in mysqldump.sql in my system. I also updated the username and blank password to mysql username and password in mysqldump.sql before doing restoring the osla database using using mysqldump.sql and still no change :-(

btesec 12-27-2012 11:46 AM

Hello Everyone,

Has anybody managed to successfully install and run Overactive Logistics.

Please let me know, I am kind of struglling with it.

Any help or comment is appreciated.



sag47 12-31-2012 09:58 AM

In the bottom mysql line of this post give the admin user a password. Apart from that, I'd suggest enabling more verbose logging in attempt to figure out what is going on.


INSERT INTO loginaccount VALUES (1,'0000-00-00 00:00:00','2005-05-10 21:46:49','admin','admin');
Change the mysql.dmp file and import it again. Now use the username admin and password admin to log in. If you require more assistance you'll need to post the logs of the web servers so we can figure out what is going wrong. Do not change the username because the application likely depends on there being an admin user.

Again, as I said before the use of alpha software in a production environment is not recommended.

All times are GMT -5. The time now is 06:57 PM.