-   Linux - Software (
-   -   open and firefox dont start -running suse 10.0 with security updates (

Andrew Sorensen 06-08-2006 06:53 PM

open and firefox dont start -running suse 10.0 with security updates
Im a suse linux user and whenever I try to open it never comes up the same happens with firefox im completly patched.

soulxcavtor 06-08-2006 07:03 PM

It could be that they were installed incorrectly. Try rebooting and restarting the program.

IF that doesnt work redownload the pages and reinstall them.

Mojojo 06-08-2006 07:18 PM

Have you tried starting them from the console? If so also try as root it may be sommething as simple as the theme you are using.

Andrew Sorensen 06-08-2006 09:23 PM

No trying to run the programs from the console just hangs the console
most of the programs i have problems with are office programs and internet applications its really weird but I really don't want to have to re-install SuSE linux again.

Mojojo 06-08-2006 09:42 PM

Have you tried running them as root?

HellSpawn 06-08-2006 09:42 PM

Try runing it with strace:


$strace <program>

$strace firefox

$strace oowriter
When you do this, a bunch of stuff will appear in the console... post the las 10 or so lines to see if somepeople can tell what's going on

Your console doesn't hang... you can stop the "running program in console" with Ctrl+C, or you can run programs in the background just putting and "&" after the command:


$firefox &

Andrew Sorensen 06-09-2006 11:57 AM

Yes I have tried running them as root - nothing happens
and strace does nothing no output ever appears both under my user account and as root.

HellSpawn 06-09-2006 10:16 PM

Try uninstalling with Yast and reinstalling... (delete any cached packages)
.... or ... if you lost any hope ...try to upgrade to SuSE 10.1

soulxcavtor 06-09-2006 10:43 PM

Do what I said in the 2nd post of the forum.. It would have got you farther then all the other things you tried... Lol!

gkiagia 06-10-2006 08:23 AM

Sounds like a hardware problem to me. I have similar problems running wine and yast when there is no cd/dvd in my dvd drive during boot. Sounds strange but if there is no cd/dvd to mount at boot, the kernel detects the dvd as busy and any program that tries to use it becomes a zombie process!

Firefox and ooo do not use the dvd of course but there could be a similar hardware problem. See the kernel message log with yast and track down any errors.

All times are GMT -5. The time now is 06:05 AM.