-   Linux - Software (
-   -   open office "input/output error" saving to smb share (

PK2K 03-01-2005 08:03 PM

open office "input/output error" saving to smb share
Hi All

Not sure if this is an open office or a samba problem

We have an e-smith server and have been testing and installed a K12LTSP v 4.2 server on which we have migrated a single client. The users home is on the K12 server and we have mounts to the E-smith I-bays.

when we first attempted to mount the i-bays by going to "Network and right clicking on the i-bays and clicking "mount" they would only mount read only, so we installed Linneighbourhood and mounted the shares through that.

Now after opening an open office document and attempt to save we get a "general input output error" and open office stalls for about 15 seconds, the file is eventually saved but the lag and error are driving us nuts.

Kwrite and other apps have no problem, and if we copy a file to home on the terminal server it opens and saves with no problem. We can also then copy it back to the I-bay with no error??

Any suggestions would be much appreciated, we have tried nearly everthing we can think of, including installing the latest OO version.

Matir 03-01-2005 08:44 PM

That's really odd. There are no problems writing or saving with any other software? Have you got any other machines with OO trying to save to the same SAMBA shares? If so, do they experience this problem?

Also, what version of OO are you running?

PK2K 03-01-2005 09:17 PM

We havent seen the same problem with any other apps, we saved with Mozilla and Kwrite with no errors. And we have other users (both linux and windows) logged in to the esmith box who are having no problems.

at first we thought it was a problem with OO trying to delete the temp files but we changed the temp path to the users home folder, and it made no difference.

Also tried mounting as root and chmod and chowned the folder 1777 in desperation, This one has me stumped.

OO is 1.1.2 we also tried 1.1.4 but got the same error

jiml8 03-01-2005 09:43 PM

Time to pull out ethereal.

PK2K 03-01-2005 10:08 PM

I havent used this before would I run it from the K12LTSP server as I saved data?

If you know which switches to use, it would be helpful for me

jiml8 03-02-2005 11:07 PM


I havent used this before would I run it from the K12LTSP server as I saved data?
You mean ethereal?

You would run it on your linux server, yes. As for switches, it is complicated but intuitive. Just play with it; you'll figure it out.

PK2K 03-09-2005 01:30 AM

Hi Guys

I thought i would close this off as I found a resolution. I ran a full apt-get upgrade on the K12LTSP.

The problem was then resolved.

There were a lot of upgraded files including the kernel so I am unsure which resolved the error. but it wasnt the included upgrade to Open Office 1.1.3 as I tryed this on another build seperately and the problem still existed.

I would like to isolate the cause perhaps with time permitting I'l track it down, although for the sake of a 380Mb download it turned out to be an easy fix

All times are GMT -5. The time now is 03:44 PM.