-   Linux - Software (
-   -   open office doesn't work and gives me the Filter Selection box on starting (

chadwick 06-18-2009 04:22 PM

open office doesn't work and gives me the Filter Selection box on starting

I installed the en-gb dictionaries for Open Office. I originally had the US English dictionaries on there, but was hoping to install the British version as well so that I could have both. Maybe this was a bad idea, but I had oowriter open at the time.

I did the following:

sudo apt-get update
sudo apt-get install myspell-en-gb
sudo apt-get install
sudo apt-get install
sudo apt-get install

from here:
and I think it was at the very last one where it crashed. I should have just left everything with myspell-en-gb. That probably would have been enough.

oowriter crashed and told me it would recover the file it had open the next time I opened it.
Now when I try to open any .odt file whatsoever, oowriter won't work.

At first, if I tried to open a .odt file that is not corrupted (since I can transfer it to another computer and view it there using oowriter), then right after the Open Office splash screen it would pop up a "Filter Selection" box where it seems it is asking me to choose a file type. Now, instead of the "Filter Selection" box it pops up an ASCII Filter Options window. But it does not work. The window pops up, but no margins are shown on the white page part of the window where you're supposed to be able to type your stuff. If you click on it to try to insert a cursor, nothing happens.

Also, seemingly randomly, but it's only happened twice, when I call oowriter from the command line, it prints the following:

I18N: Operating system doesn't support locale "en_US"
I am using debian testing. I can't seem to see what version of Open Office it is because if I type

oowriter --version
then it doesn't tell me anything. Instead oowriter just opens and does its problematic stuff. So I'm not sure how you're supposed to check the version number.

I have tried reinstalling the openoffice packages using the --reinstall packages of apt-get. I've also tried purging the whole thing and installing over again, but the error still occurs.

Did I screw up my language settings? The en_US error is the only lead I've got it seems. Is there somewhere else I can look for errors?

chadwick 06-18-2009 04:33 PM

I just noticed that if I do

apt-get --purge remove
then it tells me

Reading package lists... Done
Building dependency tree     
Reading state information... Done
Note, selecting instead of
The following packages will be REMOVED:*
0 upgraded, 0 newly installed, 1 to remove and 379 not upgraded.
After this operation, 21.7MB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 177914 files and directories currently installed.)
Removing ...
Purging configuration files for ...

So it refuses to remove the gb version and removes the us version instead. At least prior to this problem, I was using american English on my computer. But I'm not so sure what it actually is any more.

chadwick 06-18-2009 04:49 PM

Okay I tried uninstalling all the gb stuff mentioned in the first thread as well as the package and then installing the package over again.

Now an error dialog box opens and it says:


var/spool/openoffice/uno_packages/cache/uno_packages/L1SznQ_/writer2latex.oxt does not exist.

(typed by hand)

I also figured out it's 3.0 since that's what appears in the titlebar of the error window.

Then after clicking on the error box to make it go away, I come back to the Filter Selection screen. This selection screen presents a really disordered list of options, and to be honest, I can't figure out which one I should select. If for the hell of it I choose 1.0 Text Document, then it tells me that the file is corrupt and asks me if it should try to repair the file. On choosing yes, it just says it couldn't be repaired, and then that's the end of it. I'm sure I'm choosing the wrong file type, but I don't see any others that would make sense. I know for a fact that it is a .odt file that is not corrupt.

Does anyone have any idea what's going on?

chadwick 06-18-2009 06:09 PM

Okay, I removed all those en-gb packages that I had installed in the first post.
Then I did:

aptitude update
aptitude dist-upgrade

Now everything's working again.

Afterwards I even got the british english spelling dictionary by just installing the myspell-en-gb package on its own.

All times are GMT -5. The time now is 01:21 PM.