-   Linux - Software (
-   -   OOo, yum, rpms....uninstall, reinstall, failed dependencies....HELP!!! (

kalico 07-10-2006 12:55 AM

OOo, yum, rpms....uninstall, reinstall, failed dependencies....HELP!!!
This is really ugly. I have been at this for two days straight, and I'm no better off than before. I hope someone can help me! I'm rather new to linux, but not a total idiot. I am good at troubleshooting and researching answers. I usually find what I need eventually, but this is a long time to be looking without getting any closer to the answer.

Ok, end of sob story, on to the facts.....

I installed 2.0.3 on my FC3 machine, which already had 1.3 on it, from the rpms on the OOo website. Why RPM instead of yum? Well I tried yum and it said there was nothing to update, and I read that yum still had 1.3, so I went with RPM. (More on that later.)

It seemed fine at first. But after running the Web Page wizard a few times, I got an error message that said "Files required are not available. Run OOo Setup and choose 'Repair'." Well there is no such animal, so I decided to unistall and reinstall. That's where things got ugly.

I can't remember all the things I've done, but I've uninstalled and reinstalled several times, or tried to, with rpm and with yum (now that I've learned how to get 2.0.3 with yum -- gee I wish I'd known THAT in the beginning!).

Where things stand now:

- OOo 2.0.3 opens and runs fine, EXCEPT the Web Page wizard, which says some files are missing. This is the main thing I need in 2.0.3, so having it functioning is crucial (for batch processing .doc to html/pdf).

- I have most recently yum installed openoffice (after uninstalling via rpm), which added quite a few things that weren't there with the rpm install -- but since the important wizard files are still missing, I am guessing somehow, between rpm and yum, I've lost something important.

- my next plan was to yum remove openoffice* but that gets me "No Packages marked for removal"

- rpm -e <long list of files to rm> gets me a zillion error messages about files that are needed by OOo 1.3 (installed -- so thinks rpm), which I uninstalled early on in this process.

- Just a point of information -- some of what I've read on OOo's website indicates that Java is involved in making the Wizards work. I have run various tests to prove that the jre is installed and working, and I have added the following two lines to my user's .bash_profile:

export JAVA_HOME=/usr/java/jre1.5.0_06
export PATH=$PATH:$JAVA_HOME/bin

- It seems like, in an ideal situation, I'd want to completely uninstall EVERYTHING related to OOo of any version, and then install from scratch with yum. But getting there seems to be quite a challenge. How do I track down everything to remove, between yum and rpm?

Phew!! I think that is all...I can't think of anything else that is relevant, but I'm sure I've left something out. I'll be up late tonight (west coast) so if I can add any more helpful information, please ask. I'm really desperate for this. If this fails, I will have to go run 2.0.3 on my windoze laptop, where the wizard works but can only handle processing about 9 files at a time, and after three runs has to be completely shut down and reloaded. I'm beginning to feel like my beloved linux box caught a windoze bug!

I have posted three different (related) messages on the OOo forum this weekend, and got nowhere. I'm hoping there are some kind Linux gurus who can help me figure this out -- it's obviously not a OOo problem, but MY problem.

Thanks in advance.... :)

spooon 07-10-2006 04:20 AM

You shouldn't use RPMs from random sites if possible, and use the packages from Fedora Core instead. FC3 doesn't have updated software because it's been discontinued for a while. Upgrade to FC5 or something and it will have newest OOo and everything else.

noranthon 07-10-2006 07:18 AM

I beg to disagree with the previous post. The OOo rpms include desktop integration and work perfectly well. I've seen quite a number of complaints (a disproportionate number) from users who suffer problems caused by versions messed up by their distros. Installing OO is one of the simplest things I've had to do and I've had no installation issues with any version I've installed.

To activate JRE in OOo, use Tools >Options >OOo >Java.

If the Web Page wizard still does not work, there may be a bug. It works in 2.0.2.

BTW, I saw your post in the OOforum. Your post here is clearer. :Pengy:

kalico 07-10-2006 12:55 PM


Thanks for the advice. I'm a little nervous to upgrade to FC5 since I'm just getting used to FC3....and I have a few tweaks that I don't want to lose! But I'll think about it...still, even in FC3 why can't I get yum to give me 2.0.3 -- I tried last night, and all I could get is 1.3, after having gotten 2.0.3 somehow yesterday. I'm really confused!

What version of OOo does FC5 have? Why am I not getting the current version from yum when I update? The reason I ask is that my primary concern is OOo. I desperately need it running. But I don't want to break my current working system to do it (kinda defeats the purpose, kwim? :)). I am new to linux, and it took several weeks to get my wlan working, and even booting from the wrong FC3 kernel eliminates all that hard work, so going to FC5 just raises all sorts of questions and red flags.


You know, when I saw that Java option in OOo, it was already activated. I imagine it was there by default, and that the wizard might not have worked at all without that box checked. But I tried de-activating it (why? who knows....I experiment) and it locked up everything!! As I recall, I ended up rebooting....but that might be b/c I dont' know enough to recover from a single program with a glitch, and keep everything else running.

That was part of what clued me in to the idea of a Java problem. That, and some posts on OOo about similar issues and reinstalling java stuff from the OOo source (but no instructions on how, so I didn't...yet!) But how can I tell if Java is working correctly, apart from encountering that little adventure again?

And about my post on OOo....yeah, that was less clear (and it took three separate posts!) because I was in the process of figuring things out. I didn't know enough to be clear, I was trying to get some direction. But I was still troubleshooting on my own and finally figured out enough to post clearly here. I thought about posting on OOo again, but (understandably) the folks there are mostly OOo users rather than Linux users, and I think this is a linux issue. But then again, from what you've said....maybe not.

So now, my new questions:

If it turns out to be a 2.0.3 bug, how do I get 2.0.2?

Can I yum for either of them with FC3, or do I have to use RPMs? ("have to" b/c I'm in a time crunch -- I can't wait for 2.x to come to yum, if it's not there now. I'll resort to windoze...ugh!)

And how in the world do I get rid of what's on my system now?? I can't seem to do enough to make it all go away. Every time I try to install from yum I get messages saying it's all there already. I've uninstalled *something* using yum, but obviously not enough. Which might be due to the fact that it was installed by rpm???

Thanks for the help and advice. :)

noranthon 07-10-2006 06:22 PM

FWIW, I do not use Mandriva's package manager or software installation manager to install OOo, firefox or thunderbird. They are all so straightforward, it's seems to me to be complicating matters to do other than use the command line. There's a setup guide for OOo.

If you run the 2.0.3 installer again, you could add the switch --replacepkgs to the command. First, cd to the folder containing the rpms (I believe you can move the desktop integration rpm for Fedora to the same folder as the other rpms), then:
rpm -Uvh --replacepkgs *rpm

OOo 2.0.2 is still available from mirrors. You would need, I suspect, to finish uninstalling 2.0.3. (I seriously doubt that 2.0.3 has such a bug as that suggested.) There is another switch you could add: --replacefiles

You can check the JRE by visiting sun and using the verify installation button. I get Java from there rather than OOo.

EDIT: The Mandriva software manager and Yast (SuSE) can each uninstall anything added by rpm because the managers also use rpm. Yum, I hope (because I'm about to install Fedora 5), should be able to do the same. It should not matter unduly if you use one or both of the replace switches.

EDIT: The Setup Guide has a section on removal.

kalico 07-10-2006 08:23 PM

Thanks noranthon!! I am itching to try all that you've suggested, but I have to feed my family first. I'll be back later. :)

EDIT: i just couldn't help trying the java test again...I've done it before and it's never "passed". But I thought it was just not working on FF.... so my question to you is, if I fail the test in the browser, does that mean it's not working anywhere else either?

I know it's not installed in the browser...I have never been able to figure it out, and haven't bothered to troubleshoot it.

kalico 07-10-2006 09:22 PM

Well the one important fact I learned from the set up manual is this:


Warning: Using rpm -e\* does not work. under FC3 or Suse 9.3 and possibly other distributions.
So where does that leave me??

lostn1slinux 07-10-2006 09:50 PM

I would upgrade from FC3 to FC 4 or 5 seeing that FC3 updates have been discontinued.

kalico 07-10-2006 09:58 PM

Thanks for your input, lostn1slinux. :)

Ah, the ominous "upgrade" word again....yikes. OK, so that leads to another question (should I start another thread elsewhere, or just tag this one?):

How do I upgrade to FC5 w/o losing certain tweaks I have made to enable my wireless PCI card (a type which is really tough to configure w/Linux) and network printer (over a windows wireless network)?

Or (wouldn't this be a dream....) maybe FC5 will handle both of those activities better?

noranthon 07-10-2006 10:45 PM


if I fail the test in the browser, does that mean it's not working anywhere else either?
You probably do not have the JRE enabled for your browser. Go to your firefox programme directory and then into /plugins. It's easier to do this if you use Midnight Commander.

You need the plugin file. Here you will have options. The path to the appropriate plugin on my system is /usr/java/jre1.5.0_06/plugin/i386/ns7
The options are in the last two subfolders. The file name is Symlink that file to the firefox /plugins folder. With Midnight Commander, you should have the two plugins folders open in the opposing windows and, with the java file selected, select the MC menu File >Symlink. Drop dead easy. I forget the command line method.

You can check your browser plugins by opening a tab in firefox and typing about:plugins in the location bar then ENTER.

If the remove option does not work, reinstall using the replacepkgs option. It's so simple, you should not have problems, even using an older version of FC. I believe your problems arise from trying to use yum. I had similar problems with Yast on SuSE.

I doubt that any distro is good enough to allow trouble-free upgrading. My guess is that you really need a fresh install of FC 5 - i.e. completely overwriting FC 3. I certainly do not trust Mandriva to upgrade the OS any more than I trust them to tweak OOo without breaking it.

EDIT: There should be a colon, not a smiley, between about and plugins. I had to edit to get the option to disable smileys.

kalico 07-11-2006 03:03 AM

Ok...I started with a new install of Java, direct of the Sun website -- it's 1.5.07. I removed 1.5.06. Changed the lines in my .bash_profile to match. It doesn't work with Firefox (or I'm doing something wrong) but that might be b/c my FF version is pretty old. Trying to fix that now, but is really slow.

I ran the OOo rpms again, this time with --replacepkgs. Sweet. I went to the web wizard and it doesn't work yet...but at least this time I got a useful error message! It told me my current Java is not working right, and I should go to Options >> Java and change it or install a new one. So I headed for the Java option, and it's got an X in the "use JRE" box, but there is nothing in the list of installed Java. So I clicked on Add... and it locked up OOo. Same problem as before. I'd think it was my removal of .06, but when I checked OOo's Java option before, that list was just as blank as it is now.

So.....any thoughts??? What would cause OOo to bork over java?

noranthon 07-11-2006 07:00 AM

I've found it "borks" (and I wish that worked in Thunderbird) when you try to define the location too narrowly. Mine is happy with /usr/java/jre1.5.0_06

So there's an 07 now? Concerning firefox, you may be linking it to the wrong plugin. What do you get in about:plugins? I've just discovered on re-reading the Moz instructions that you must use a symlink, NOT copy the file.

I bypass the Moz website and go straight to the ftp site. That way I can use d4x to download instead of the browser.

BTW, your post in the other forum has a reply regarding command line removal using yum. It seems that SuSE and Fedora have broken rpm. I did not hit it off with SuSE at all. I hope Fedora isn't going to be a waste of time.

EDIT: Reading this while waiting on something else, I realise "borks" meant locked up. That's new to me. Did you check the md5sum of your download? I am not familiar with the procedure you mention of including the JRE in your bash profile file. Is that a Fedora thing? I think it may be running interference.

kalico 07-11-2006 12:47 PM

noranthon, you've been so kind to help me through this. I just read on the OOo forum another post about problems with Java-based features, very similar to mine. It seems not to be related to the OS, but something else. I've seen both windows and linux users report issues, similiar but not identical, but all related to java.

I've tried removing the info from the .bash_profile and starting a new session without it, but still the same result. I'm not sure if that's a fedora thing...I did read someone with a very similar problem, who was told to add that info and it worked for him. But it's not making a difference for me either way.

I'm becoming more convinced that I need to try 2.0.2. I just hope I can remove 2.0.3 successfully.

As for Moz, I followed those instructions as well as the ones on the java site. It's a little confusing, b/c they don't have instructions for FF itself, only Mozilla and Netscape, and the paths are I probably have the symlink in the wrong place. And I do have a symlink, not the copied file. I'll keep working on it....I'm sure it is something goofy I've done.

EDIT:I just noticed you asked what I'm getting in about: plugins - three plugins are listed there, none of them are Java. Even after following the directions to install and enable it, nothing shows there.

kalico 07-11-2006 03:50 PM

Actually, I have one more question -- a point of clarification -- you said:


OOo 2.0.2 is still available from mirrors. You would need, I suspect, to finish uninstalling 2.0.3. (I seriously doubt that 2.0.3 has such a bug as that suggested.) There is another switch you could add: --replacefiles
Under what circumstances would one use --replacefiles instead of --replacepkgs?

noranthon 07-11-2006 07:12 PM

Last night I downloaded what turned out to be a Red Hat guide (551 pages). It says this about those switches:

Package Already Installed
If the package is already installed, you will see:
# rpm -ivh foo-1.0-1.i386.rpm
foo package foo-1.0-1 is already installed
error: foo-1.0-1.i386.rpm cannot be installed
If you really want to install the package anyway, you can use --replacepkgs on
the command line, which tells RPM to ignore the error:
# rpm -ivh --replacepkgs foo-1.0-1.i386.rpm
foo ####################################
Conflicting Files
If you attempt to install a package that contains a file which has already been installed
by another package, you’ll see:
# rpm -ivh foo-1.0-1.i386.rpm
foo /usr/bin/foo conflicts with file from bar-1.0-1
error: foo-1.0-1.i386.rpm cannot be installed
To cause RPM to ignore that error, use --replacefiles on the command line:
# rpm -ivh --replacefiles foo-1.0-1.i386.rpm
I've now downloaded and installed 2.0.3 because I wanted to check that wizard. I've only started the wizard (have not pressed 'Next') and it starts without a problem. I've also got Java enabled in OOo (/usr/java/jre1.5.0_07) and Firefox. I had forgotten that Firefox gives you the option to enable java: Edit >Preferences : Content : Enable Java.

I'm coming around to the view that perhaps rpm does not work properly in FC, which is ironic, considering that rpm is a creation of Red Hat. I noticed that ahz replied on the other forum and mentioned that he's an FC user. He, from memory, is using 2.0.3. Before backtracking to 2.0.2, which is more likely than not to present the same problem, I'd swap notes with him. :confused: I'll have to install FC 5 on the weekend and see how I fare. :scratch:

EDIT: oops! ahz did reply to one of your threads but contemporaneously I've been reading his answers to another. It may help to update the most relevant thread there.

All times are GMT -5. The time now is 09:54 PM.