-   Linux - Software (
-   -   Online resize2fs: Operation not permitted While trying to add group #14080 (

JubJub 08-22-2010 05:27 PM

Online resize2fs: Operation not permitted While trying to add group #14080
Hello All,

I am running Oracle Enterprise Linux x64 5.5 on an HP Proliant DL380 G6 attached to various SAN's via fibre channel. I have setup multipath, edited multipath.conf, lvm.conf, and after some trial and error, everything behaves and looks as it should in regard to multipath.

However, when I try to resize a multipath ext3 lvm filesystem, The operation runs for a while, but then dies and I get the above error. I then see this error in /var/log/messages:

EXT3-fs warning (device dm-9): ext3_group_add: No reserved GDT blocks, can't resize

-I am only using the /dev/mapper/ paths to the filesystem (ie, resize2fs /dev/mapper/testvol-lvol1 128G)
-if I unmount the filesystem, resize2fs works fine
-Have tried removing and re-adding journal file via tune2fs with no luck
-The VG has plenty of room in it and is composed of a 100GB and 200GB partition.
-Inode resize is on in the filesystem

I am wondering if online resize2fs is only for small filesystems or not recommended as a best practice or just not generally done??? As I mentioned, the operation works fine offline if I unmount the filesystem, but this won't be an option once system is in production.

Any ideas? Thanks in advance!

AlucardZero 08-22-2010 06:38 PM


tune2fs -l /dev/mapper/testvol-lvol1 | grep features
Does "resize_inode" appear? If no, your filesystem does not support online resizing. When was it created? New enough versions of mkfs (e2fsprogs 1.39) will include that by default.

JubJub 08-22-2010 08:40 PM

Thanks for the reply!

I meant to say that inode resize was on in original post, not resize inode.


tune2fs -l /dev/mapper/testvol-lvol1 | grep features

Filesystem features: has_journal resize_inode dir_index filetype needs_recovery sparse_super

I just created FS today as I am testing, so it is an EXT3 filesystem. I just recreated a new FS from scratch from command line and same results. Started with a 400mb filesystem size and it died at 45GB with same error. I am wondering if online resize2fs only works with smaller filesystems less than 50GB...?

very strange...

JubJub 08-30-2010 09:23 AM

Any ideas on this?


All times are GMT -5. The time now is 09:06 AM.