-   Linux - Software (
-   -   One user's cron jobs not running (

dcroxton 03-06-2006 08:14 AM

One user's cron jobs not running
I run a cron job that downloads my Yahoo mail every hour from 8 a.m. to 10 p.m. via the fetchyahoo program. This has been running without problems for over a year now, but suddenly in the past few days it has stopped. I was getting emailed reports each time it ran; now I get nothing. Other cron jobs continue to execute normally (root jobs, mailman). There is no record of errors in any of the cron logs (actually, all of them are empty except for one of them, I think I tried changing the user's crontab file and saving it, but, even though it said it was reloading it, nothing changed.

Can anyone give me an idea of how to debug this problem? Where can I look to find out why the cron job is not running?

satinet 03-06-2006 08:21 AM

my 1st step would be to set up a new cron job for that user that does something like email your root user or create a file every minute - this way you can verify whether cron is your problem...

dcroxton 03-06-2006 09:13 AM

Thanks for your quick response. It turned out that cron was not running. I'm not sure how this was possible, since jobs in cron.daily were still getting processed; but when I ran /etc/init.d/cron start, it didn't tell me that it was already running, and now the job is working again. I'm also not sure how it ever got stopped, but that's less of a concern.

satinet 03-06-2006 09:29 AM

have you done any upgrade's recently??
i don't know Xandros, but i would suggest, checking your /etc/rc2.d (rc3.d etc) for a link to wherever xandros' init.d is....

do you not normally reboot?

dcroxton 03-06-2006 12:02 PM

This computer has been up for over 200 days straight now -- something of an accomplishment for me, who am not a Linux guru by any means. I recently installed Asterisk, and I have been playing around with it, so perhaps I screwed something up in the process.

satinet 03-06-2006 03:33 PM

hmmm. sounds like the cron deamon was killed for some reason.... maybe you issued and errant kill command or asterix did something unexpected...:confused:

All times are GMT -5. The time now is 08:00 AM.