LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-14-2008, 07:53 PM   #1
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Rep: Reputation: 0
nxserver login problems


Hello folks, hopefully someone has a solution to this problem because I haven't been able to find one. I've been using centos 5.2 and have it setup as a router and dhcp server. I had nxserver running and working in it up until now. I was able to remote into, now all of a sudden it won't connect anymore. Now it connects, then gets stuck at "negotiating link parameters" then times out after a few minutes, this is the log description.

Info: Display running with pid '6108' and handler '0x1d05f4'.

NXPROXY - Version 3.3.0

Copyright (C) 2001, 2007 NoMachine.
See http://www.nomachine.com/ for more information.

Info: Proxy running in client mode with pid '5988'.
Session: Starting session at 'Sun Dec 14 20:49:07 2008'.
Info: Aborting the procedure due to signal '15'.
Session: Session terminated at 'Sun Dec 14 20:50:08 2008'.

Anyone have any ideas? I haven't changed anything server side and it was working. It has just stopped for no reason, I've tried re-installing nxserver, client and node and re-installing ssh as well. Right now I'm stumped.
 
Old 12-15-2008, 09:00 PM   #2
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Update, well still haven't got it working, however I did try to use vnc with the server and it won't connect either. The only things I can think of is that I did change the host name, but I changed it back after nxclient wouldn't connect. The other thing I think it might be is denyhosts. I installed it but couldn't figure out how to configure it so I uninstalled it, it may still be installed somewhere. Anyone have any ideas given this new info?
 
Old 12-15-2008, 09:31 PM   #3
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Update #2, well I got vnc to work for remote access by opening the port on the firewall. However the ssh port 22 is already open and I didn't change any firewall settings previously and nxserver was working. Not using ssh for vnc though. Perhaps it could be an ssh problem? Any ideas on how to troubleshoot ssh with nxserver?
 
Old 12-15-2008, 09:39 PM   #4
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
nxserver logs to the /var/log/messages file on my box. Is there anything being written there on your server? You could try setting the LogLevel to one of VERBOSE, DEBUG, DEBUG1, DEBUG2 or DEBUG3 in the nx user's ~/.ssh/sshconfig file - it should also be set in your user account's sshconfig file.
 
Old 12-16-2008, 07:32 AM   #5
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gilead View Post
nxserver logs to the /var/log/messages file on my box. Is there anything being written there on your server? You could try setting the LogLevel to one of VERBOSE, DEBUG, DEBUG1, DEBUG2 or DEBUG3 in the nx user's ~/.ssh/sshconfig file - it should also be set in your user account's sshconfig file.
Thanks, I was wondering where the log files were kept, I'll have a look at it when I get home from work, since I can't remote into the stupid box lol.
 
Old 12-16-2008, 04:41 PM   #6
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Here's the message from the log file, can't make much sense of it myself (kind of new to linux) anyone have any ideas? There are some ssh errors.

Dec 16 17:34:42 localhost NXSERVER-3.3.0-8[5943]: Session '848A320E73B8BC557FCE69DC2660FF16' started by user 'xxxx'. 'NXShell::handler_session_start'
Dec 16 17:34:42 localhost NXSERVER-3.3.0-8[5943]: User 'xxx' from '192.168.1.120' logged out. 'NXLogin::reset'
Dec 16 17:34:43 localhost NXSERVER-3.3.0-8[5943]: ERROR: nxssh process exit with exit status: 255 and flag connected set to: [0] 'NXShell::handler_bye'
Dec 16 17:34:43 localhost NXSERVER-3.3.0-8[5943]: ERROR: Cannot establish ssh tunnel between nxserver and nxnode 'NXShell::handler_bye'
Dec 16 17:34:43 localhost NXSERVER-3.3.0-8[5943]: ERROR: Please check permissions of user's home directory on the 'NXShell::handler_bye'
Dec 16 17:34:43 localhost NXSERVER-3.3.0-8[5943]: ERROR: node host and file name for authorized keys set in the NX 'NXShell::handler_bye'
Dec 16 17:34:43 localhost NXSERVER-3.3.0-8[5943]: ERROR: node and SSHD configurations. 'NXShell::handler_bye'
Dec 16 17:34:43 localhost NXNODE-3.3.0-3[5977]: Using port '1020' on node 'localhost.localdomain' for session 'unix-gnome'. Logger::log nxnode 6062
Dec 16 17:34:43 localhost NXNODE-3.3.0-3[5977]: Using host from available host list: '111.111.111.111'. Logger::log nxnode 6063
Dec 16 17:35:42 localhost NXNODE-3.3.0-3[5977]: ERROR: run command: process: 6141 finished with: 1 Logger::log nxnode 3851
Dec 16 17:35:42 localhost NXNODE-3.3.0-3[6192]: ERROR: Error when monitoring session: Unable to open display 'nx/nx,options=/home/xxxx/.nx/C-localhost.localdomain-1020-848A320E73B8BC557FCE69DC2660FF16/options:1020' 'NXSessionMonitor::__setSessionStatus'
Dec 16 17:35:43 localhost NXNODE-3.3.0-3[6192]: Directory '/home/xxxx/.nx/C-localhost.localdomain-1020-848A320E73B8BC557FCE69DC2660FF16' renamed into '/home/xxxx/.nx/F-C-localhost.localdomain-1020-848A320E73B8BC557FCE69DC2660FF16' for further investigation Logger::log nxnode 6242
Dec 16 17:35:44 localhost NXNODE-3.3.0-3[5977]: Session 'unix-gnome' on port '1020' failed. Logger::log nxnode 6323
Dec 16 17:35:50 localhost NXSERVER-3.3.0-8[6143]: ERROR: NXNodeExec: Cannot kill nxssh process: No such process 'NXNodeExec::exec'
Dec 16 17:35:50 localhost NXSERVER-3.3.0-8[6143]: User 'xxxx' from '192.168.1.120' logged out. 'NXLogin::reset'
Dec 16 17:35:57 localhost gconfd (root-6238): starting (version 2.14.0), pid 6238 user 'root'
Dec 16 17:35:57 localhost gconfd (root-6238): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Dec 16 17:35:57 localhost gconfd (root-6238): Resolved address "xml:readwrite:/root/.gconf" to a writable configuration source at position 1
Dec 16 17:35:57 localhost gconfd (root-6238): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2

Last edited by dmanocn; 12-17-2008 at 04:10 PM.
 
Old 12-16-2008, 06:04 PM   #7
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gilead View Post
nxserver logs to the /var/log/messages file on my box. Is there anything being written there on your server? You could try setting the LogLevel to one of VERBOSE, DEBUG, DEBUG1, DEBUG2 or DEBUG3 in the nx user's ~/.ssh/sshconfig file - it should also be set in your user account's sshconfig file.
The only file I could find called ssh_config was in /etc/ssh, there was no config file in any of the users ~/.ssh dir, just a text file called known_hosts.
 
Old 12-16-2008, 09:17 PM   #8
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,141

Rep: Reputation: 168Reputation: 168
For the error message "ERROR: Please check permissions of user's home directory on the 'NXShell::handler_bye'":
Can you check the permissions on /usr/NX/home/nx/.ssh as well as the .ssh directory in your home directory. On my box, both are set to 0700 (drwx------). In those directories the files are all 0600 (it doesn't matter what any symlinks are set to).
For the home directories themselves, I use 0750 for my home directories and don't get any permission errors.
 
Old 12-17-2008, 07:41 AM   #9
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by gilead View Post
For the error message "ERROR: Please check permissions of user's home directory on the 'NXShell::handler_bye'":
Can you check the permissions on /usr/NX/home/nx/.ssh as well as the .ssh directory in your home directory. On my box, both are set to 0700 (drwx------). In those directories the files are all 0600 (it doesn't matter what any symlinks are set to).
For the home directories themselves, I use 0750 for my home directories and don't get any permission errors.
Alright thanks again, I'll give that a try when I get home from work again.
 
Old 12-18-2008, 12:26 PM   #10
dmanocn
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
I gave up and just re-installed everything, I think the problem stemmed from DenyHosts, but who knows. Thanks for your help though.
 
Old 01-14-2009, 04:02 PM   #11
tintin75
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
hi,

I had the same problem after changing the hostname of the server.

The local host name wasn't recognised because it has been deleted from the /etc/hosts file.
So I added the following :
127.0.0.1 Linux001.domain.com linux001 localhost.localdomain localhost

where linux001 is the host name and domain.com is the domain name.

It works now !

I hope it may help.

Last edited by tintin75; 01-14-2009 at 05:34 PM.
 
Old 02-15-2009, 10:30 PM   #12
midgard23
LQ Newbie
 
Registered: Dec 2006
Posts: 1

Rep: Reputation: 0
Just racked my brains over this and found out what the issue was.
First off follow the instructions in the HOWTOS CentOS wiki page.
Now the area that becomes confusing is the last line before getting to troubleshooting.

"<!> Don't forget to add this new user on the AllowUsers line in the sshd_config file and then reload sshd (service sshd reload)."

You need to edit the file in /etc/ssh/sshd_config
Get to your "text editor" and go to the line for "AllowUsers nx"
According to the documentation you are supposed to add your username to the "AllowUsers" line.
I went to the man pages to look this up but to give it to you quickly the line should look like: AllowUsers nx myuser
and the "myuser" would be the name you added when you added the user name to:

nxserver --adduser myuser
NX> 100 NXSERVER - Version 1.5.0-60 OS (GPL)
NX> 1000 NXNODE - Version 1.5.0-60 OS (GPL)
NX> 716 Public key added to: /home/myuser/.ssh/authorized_keys2
NX> 1001 Bye.
NX> 999 Bye

and then restart the ssh service, done.
 
Old 02-20-2009, 06:31 PM   #13
omarr
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
thanks

Quote:
Originally Posted by tintin75 View Post
hi,

I had the same problem after changing the hostname of the server.

The local host name wasn't recognised because it has been deleted from the /etc/hosts file.
So I added the following :
127.0.0.1 Linux001.domain.com linux001 localhost.localdomain localhost

where linux001 is the host name and domain.com is the domain name.

It works now !

I hope it may help.
It worked for me too!!!
 
Old 03-04-2009, 12:40 AM   #14
dhansen
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Rep: Reputation: 0
Same Problem!

I've been having the same issue when attempting to install NX Server 3.3.0-15 on CentOS 5.2 (both 32 and 64 bit versions). Unfortunately, I am still seeing the same error in the servers logs.

I've started with a fresh CentOS install, then installed nxclient, nxnode and nxserver. I then tried to connect using the user/pass that I created during CentOS setup. I get the same error:

Code:
ERROR: Cannot establish ssh tunnel between nxserver and nxnode
The error mentions to take a look at permissions, which I have and nothing seems out of the ordinary. I've tried generating a new key on the server and no success either! I've also tried (as mentioned in the the forum) uninstalling/reinstalling the packages, as well as looking into my hosts file, which currently reads:
Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               NXServer-Test localhost.localdomain localhost
::1             localhost6.localdomain6 localhost6
I've also tried fiddling with the hosts file to map the machine IP to the host name and I haven't had any problems. One last thing to note is I'm using NX Server via NAT on some remote servers, however as it runs through SSH I wouldn't think this would affect it at all.

Any input/tips would be appreciated, thanks!
 
Old 03-04-2009, 12:52 PM   #15
dhansen
LQ Newbie
 
Registered: Mar 2009
Posts: 2

Rep: Reputation: 0
Solved!

So, I solved this issue by restarting SSHD after the NX installation was complete. Interesting...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NXServer and Mandriva 2008.1 81bones Mandriva 13 11-11-2009 12:45 AM
NXserver and NXclient to remote desktop Linux after login, I get a blank screen poeta_boy Ubuntu 0 12-07-2008 11:24 PM
Problems installing nxserver on Fedora TNeloms Linux - Software 1 09-15-2008 12:39 AM
Problems installing nxserver on Fedora TNeloms Linux - Newbie 1 09-12-2008 09:10 PM
NXserver problems mickeyboa Fedora 0 09-07-2006 02:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration