LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-06-2013, 07:12 AM   #1
beliya
LQ Newbie
 
Registered: Feb 2011
Posts: 20

Rep: Reputation: 0
Question NUT wont work with Siemens Masterguard A1000 UPS


Hello.

I've got Siemens Masterguard A1000 UPS connected via USB to Raspberry Pi with Raspbian. The UPS is listed in lsusb as:

Bus 001 Device 008: ID 06da:0002 Phoenixtec Power Co., Ltd UPS

I've installed NUT and put the following ups.conf file

Code:
[masterguard]
        driver = bcmxcp_usb
        port = auto
I checked with NUT's compatibility list and see that the driver I'm supposed to use is masterguard but it's written for serial connections only. I found on the net that I may use either the bcmxcp_usb or the blazer_usb drivers, but I have troubles with both.

When I use the bcmxcp_usb driver, I've got the following error when I run upsdrvctl start:

Code:
Network UPS Tools - UPS driver controller 2.6.4
Network UPS Tools - BCMXCP UPS driver 0.26 (2.6.4)
USB communication subdriver 0.21
Communications with UPS lost: Error executing command
Could not communicate with the ups: Operation not permitted
CLOSING

Driver failed to start (exit status=1)
And when I use the blazer_usb driver, I get the following error:

Code:
Network UPS Tools - UPS driver controller 2.6.4
Network UPS Tools - Megatec/Q1 protocol USB driver 0.08 (2.6.4)
Can't claim USB device [06da:0002]: could not detach kernel driver from interface 0: Operation not permitted
Driver failed to start (exit status=1)
I tried to see what's going on when the host tries to communicate with the UPS using the following command: /lib/nut/blazer_usb -DDDD -a masterguard -u root and I see the following:


Code:
Network UPS Tools - Megatec/Q1 protocol USB driver 0.08 (2.6.4)
   0.000000     debug level is '4'
   0.009369     Checking device (06DA/0002) (001/008)
   0.017375     - VendorID: 06da
   0.019672     - ProductID: 0002
   0.022135     - Manufacturer: Phoenixtec Power
   0.022986     - Product: USB Cable (V2.00)
   0.023804     - Serial Number: unknown
   0.024177     - Bus: 001
   0.024867     Trying to match device
   0.025725     Device matches
   0.027096     Trying megatec protocol...
   0.029076     send: Q1
   0.039570     read: timeout
   0.040379     blazer_status: short reply
   0.040609     Status read 1 failed
   0.041990     send: Q1
   0.051575     read: timeout
   0.051858     blazer_status: short reply
   0.052069     Status read 2 failed
   0.054852     send: Q1
   0.063567     read: timeout
   0.063850     blazer_status: short reply
   0.064065     Status read 3 failed
   0.064261     Trying mustek protocol...
   0.066601     send: error sending control message: Broken pipe
   0.067532     Stall condition cleared
   0.067777     blazer_status: short reply
   0.067983     Status read 1 failed
   0.068859     send: QS
   0.079578     read: timeout
   0.079927     blazer_status: short reply
   0.080144     Status read 2 failed
   0.081964     send: QS
   0.091582     read: timeout
   0.091861     blazer_status: short reply
   0.092072     Status read 3 failed
   0.092270     Trying megatec/old protocol...
   0.094501     send: error sending control message: Broken pipe
   0.095392     Stall condition cleared
   0.095641     blazer_status: short reply
   0.095844     Status read 1 failed
   0.096862     send: D
   1.098000     read: error sending control message: Broken pipe
   1.100439     blazer_status: short reply
   1.102845     Status read 2 failed
   1.105936     send: D
   2.107224     read: error sending control message: Broken pipe
   2.109433     blazer_status: short reply
   2.111899     Status read 3 failed
   2.114247     Trying zinto protocol...
   2.116178     send: Q1
   2.121821     read: timeout
   2.122100     blazer_status: short reply
   2.122311     Status read 1 failed
   2.124739     send: error sending control message: Broken pipe
   2.390573     blazer_status: short reply
   2.396126     Status read 2 failed
And with the bcmxcp_usb:

Code:
/lib/nut/bcmxcp_usb -DDDD -a masterguard -u root
Network UPS Tools - BCMXCP UPS driver 0.26 (2.6.4)
USB communication subdriver 0.21
   0.000000     debug level is '4'
   0.007531     entering nutusb_open()
   0.011965     device 009 opened successfully
   0.015156     send_read_command: (4 bytes) => ab 01 31 23
   0.018204     entering get_answer(31)
   5.021580     send_read_command: (4 bytes) => ab 01 31 23
   5.024561     entering get_answer(31)
  10.027925     send_read_command: (4 bytes) => ab 01 31 23
  10.031001     entering get_answer(31)
  15.034528     send_read_command: (4 bytes) => ab 01 31 23
  15.037650     entering get_answer(31)
  20.041252     send_read_command: (4 bytes) => ab 01 31 23
  20.044250     entering get_answer(31)

  This goes on and on..
I am really confused. Does anyone around here have any idea on how to proceed?

Thank you in advance for your help, it's much appreciated.

Beliya
 
Old 07-07-2013, 12:30 PM   #2
beliya
LQ Newbie
 
Registered: Feb 2011
Posts: 20

Original Poster
Rep: Reputation: 0
Angry blazer_usb is definitely not the driver

I did some more research and found out how to solve the permission problems when using the blazer_usb driver.

Code:
Bus 001 Device 010: ID 06da:0002 Phoenixtec Power Co., Ltd UPS
Code:
chmod 0666 /dev/bus/usb/001/010
Code:
root@raspberrypi:/# ls -la /dev/bus/usb/001/010
crw-rw-r-T 1 root root 189, 9 Jul  7 17:21 /dev/bus/usb/001/010
And now I definitely know that blazer_usb is not the driver I need.

Code:
root@raspberrypi:/# upsdrvctl start
Network UPS Tools - UPS driver controller 2.6.4
Network UPS Tools - Megatec/Q1 protocol USB driver 0.08 (2.6.4)
No supported UPS detected
Driver failed to start (exit status=1)
I'm still struggling over here. Anyone? Anyone at all?

Last edited by beliya; 07-07-2013 at 12:32 PM.
 
  


Reply

Tags
ups


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NUT - UPS failed driver not connected davidcollins001 Linux - Software 4 09-18-2017 09:11 PM
CyberPower CP1500C UPS and USB with NUT problem 81bones Linux - Hardware 4 09-23-2011 10:01 AM
UPS NUT install problem tramni1980 Slackware 0 08-14-2006 06:05 AM
Questions about nut..finding ups dev address creedog Linux - Software 7 03-01-2006 08:39 AM
Ups & Nut Denis Basta Linux - Software 1 09-27-2005 07:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration