LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-01-2009, 07:52 AM   #1
UltraSoul
Member
 
Registered: Dec 2004
Location: Japan
Distribution: REDHAT9.0, Mandrake10.1
Posts: 404

Rep: Reputation: 31
ntpd frequency error


Hi, I have RHEL AS4 Update4 installed on VMESX3.02. I got the following error from ntpd daemon repeatedly.

Jan 1 22:01:12 RHEL4-001 ntpd[3066]: frequency error -504 PPM exceeds tolerance 500 PPM.
....

I got the error in the last two weeks and occured again today. Is it related VMware. Any idea about how to get the ntpd error disappeared, Please help.

Last edited by UltraSoul; 01-01-2009 at 07:53 AM.
 
Old 01-01-2009, 09:18 PM   #2
JeffSilverman
LQ Newbie
 
Registered: May 2007
Location: Seattle, Washington, USA
Distribution: Redhat Fedora Core
Posts: 7

Rep: Reputation: 1
I don't know why, but ntpd just doesn't work well under VMWare. I suspect the problem is that the guest machines don't have the privs to modify the clock in the hypervisor. The hypervisor is getting the interrupts from the clock, and ntpd modifies the kernel's estimate of the clock frequency to make it more accurate.

I think the solution is to get an NTP daemon that runs directly under the hypervisor. I have never heard of such a thing, but I don't see why it couldn't be written.


Jeff Silverman
 
Old 01-01-2009, 11:46 PM   #3
avalonit
Member
 
Registered: Jun 2008
Posts: 81

Rep: Reputation: 19
There are a couple of options you can try. There are described in vmware and Red Hat's knowledge bases.

What I found to work almost fine is setting clock=pit, disabling ntp on the guest, and enabling time sync with the host (vmware tools).

Sorry for not providing you with links
 
Old 01-04-2009, 04:53 AM   #4
UltraSoul
Member
 
Registered: Dec 2004
Location: Japan
Distribution: REDHAT9.0, Mandrake10.1
Posts: 404

Original Poster
Rep: Reputation: 31
To JeffSilverman
==>
I confirmed my vmware hypervisor also has NTP daemon enabled and ntpq -p
shows me that vmware hypervisor is synchronized with NTP server. It means
VM guest OS and hypervisor should has same clock.However, It still has ntpd frequency error.

To avalonit
==>
We tried to stop ntpd service on guest OS and sync time by using vmware-tool. But We found that OS systime will become inaccuracy.
I wonder what the meaning of clock=pit is?
 
Old 01-05-2009, 12:52 AM   #5
avalonit
Member
 
Registered: Jun 2008
Posts: 81

Rep: Reputation: 19
Quote:
Originally Posted by UltraSoul View Post
To avalonit
==>
We tried to stop ntpd service on guest OS and sync time by using vmware-tool. But We found that OS systime will become inaccuracy.
I wonder what the meaning of clock=pit is?
How much inaccurate? Did the time go forward?

The kernel option tells kernel what timer source to use to timekeeping.


http://communities.vmware.com/thread/61253

You need both measures. clock=pit and disable ntp on guest + enable time sync through vmware-tools
 
Old 01-05-2009, 02:58 AM   #6
UltraSoul
Member
 
Registered: Dec 2004
Location: Japan
Distribution: REDHAT9.0, Mandrake10.1
Posts: 404

Original Poster
Rep: Reputation: 31
Hi, avalonit

Thanks for giving the vmware KB link. I want to try to add the following boot options for preventing clock running slowly and quickly. I will update the result after OS next time reboot.

clock=pit nosmp noapic nolapic

And Yesterday I also got the same ntpd frequency error from one physical server running oracle service.

Jan 5 17:28:22 DB001 ntpd[13228]: frequency error -504 PPM exceeds tolerance 500 PPM
Jan 5 17:29:27 DB001 ntpd[13228]: frequency error -504 PPM exceeds tolerance 500 PPM
Jan 5 17:31:35 DB001 ntpd[13228]: frequency error -504 PPM exceeds tolerance 500 PPM

==> I found the difference between OS time and hardware clock always be 5s.
# date;clock
Mon Jan 5 17:44:01 JST 2009
Mon Jan 5 17:43:56 2009 -0.644794 seconds

I wonder whether [hwclock --systohc] can disappear the error as above.
If not, what should I do For example, restart ntpd service after [OS=>HW_Clock] sync.

I also worry that whether hw clock modification will cause oracle service down if I make
hw clock 5 second quickly.

If you have any idea, pls help me.

Thank you.
 
Old 01-06-2009, 12:50 AM   #7
avalonit
Member
 
Registered: Jun 2008
Posts: 81

Rep: Reputation: 19
Quote:
Originally Posted by UltraSoul View Post
...
And Yesterday I also got the same ntpd frequency error from one physical server running oracle service.

Jan 5 17:28:22 DB001 ntpd[13228]: frequency error -504 PPM exceeds tolerance 500 PPM
Jan 5 17:29:27 DB001 ntpd[13228]: frequency error -504 PPM exceeds tolerance 500 PPM
Jan 5 17:31:35 DB001 ntpd[13228]: frequency error -504 PPM exceeds tolerance 500 PPM
I see some pointers http://www.ece.udel.edu/~mills/ntp/html/debug.html

Quote:
Originally Posted by UltraSoul View Post
==> I found the difference between OS time and hardware clock always be 5s.
# date;clock
Mon Jan 5 17:44:01 JST 2009
Mon Jan 5 17:43:56 2009 -0.644794 seconds

I wonder whether [hwclock --systohc] can disappear the error as above.
If not, what should I do For example, restart ntpd service after [OS=>HW_Clock] sync.
I don't *think* you should worry about that. But you should check if the hw clock is ever synced. On my laptop it was not and I found that by looking at the info displayed during shutdown. So I ended up setting the hwclock option --directisa. You could check if hwclock works without a reboot using your command from above.

As well you could check which timer source is your kernel using and possibly force another one.

Quote:
Originally Posted by UltraSoul View Post
I also worry that whether hw clock modification will cause oracle service down if I make
hw clock 5 second quickly.
I *think* changing *hw clock* should not cause any harm to oracle. But I can expect anything from it .
btw changing *system* time forward is much safer than backwards.
 
Old 01-10-2009, 12:50 AM   #8
avalonit
Member
 
Registered: Jun 2008
Posts: 81

Rep: Reputation: 19
UPDATE:

http://kb.vmware.com/selfservice/mic...rnalId=1006427
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Solaris 10 - Out of range frequency error ddaas Solaris / OpenSolaris 5 12-11-2010 02:49 AM
HV Frequency out of Range error? dolphans1 Mandriva 7 08-12-2010 10:40 PM
Linux makes monitor give frequency out of range error kendall14 Linux - General 2 11-26-2008 08:05 PM
ntpd and frequency daihard Linux - Software 4 11-21-2007 03:48 PM
changing the screen frequency - big error bnj Linux - Hardware 2 05-18-2005 05:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration