LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ntp off by one hour (https://www.linuxquestions.org/questions/linux-software-2/ntp-off-by-one-hour-806711/)

1veedo 05-08-2010 07:51 PM

ntp off by one hour
 
Hey there are other threads that address this but none of them fix my problem. I know it's an issue with daylight savings time but my time is exactly one hour behind. I've tried changing timezones to -4 and even -3 instead of -5 but it always syncs to exactly the same time no matter aht timezone I change to. I've also tried several different servers. Maybe there's a way to just bump your time by one hour or something -- like outside of ntp.

blackhole54 05-08-2010 08:08 PM

The system clock in all *nix systems, including Linux, uses UTC internally. The time zone is only used to present the time to humans. Try running

Code:

date -u
and see if it displays the correct UTC time.

It also might be useful to let us know what distro you are using.

jefro 05-08-2010 10:14 PM

Any setting for follow/use daylight savings time?

Shadow_7 05-08-2010 11:37 PM

apt-get install tzconfig

or old-school it.

/etc/timezone
/etc/localtime
/usr/share/zoneinfo/*

1veedo 05-09-2010 01:42 PM

UTC time is correct. I'm using gentoo. I even tried setting my timezone to Japan/Tokyo and my clock still remains at exactly the same time. If I never run ntp my clock is off by a lot but that's cause my motherboard clock is wrong... It's like ntp is ignoring my timezone. What other options are there?

1veedo 05-09-2010 02:27 PM

Ah /etc/localtime needs to be correct as well. It was just generic EST somehow. tzconfig doesn't configure that file btw, I was doing it both ways each time to see if anything different would happen.


All times are GMT -5. The time now is 04:46 PM.