LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-21-2016, 09:34 AM   #76
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,709

Rep: Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940

Quote:
Originally Posted by bellaSophia View Post
Hello sir, I have a problem with evalvid installation. can you please show me or give me any tutorial that step by step for me to install evalvid successfully. Please sir because I am working alone and I don't have anyone that can help me on this. I had try so many times with the installation but I got an error.
...and....
Quote:
Originally Posted by bellaSophia
Hi ! can anyone help me with the error of ./validate of ns2 ? need urgent.. I am doing this alone and please help me.
First, this is NOT URGENT FOR ANYONE HERE. We volunteer our time...asking for/expecting 'urgent' help with your homework is plain rude. Secondly, you ignored the LQ Rules, and hijacked a thread with your own, different, off-topic question, AND reopened an old thread. Neither is a good thing.

Open your own thread with your own question. Provide details, and show us what YOU have done/tried. We are not going to look things up for you, hand you links, or type up a step-by-step guide. You can find THOUSANDS of hits and docs with a brief Google search. Show effort of your own....read the "Question Guidelines" link in my posting signature.
 
Old 09-22-2016, 12:36 PM   #77
vivekanandagn
LQ Newbie
 
Registered: Sep 2016
Posts: 4

Rep: Reputation: Disabled
Exclamation NS2 simulation error, please help in this issue

Quote:
Originally Posted by suneel23 View Post
I want to build evalvid ns2 virtual box image (ubuntu 12.04) ready to use for my friends who are struggling like me
Sir, when i try to simulate ns2, i am facing following error. Ns2 version i am using is Ns2.34 in Ubuntu 12.04 , 32 bit machine. Please anybody solve this issue.

g++ -c -Wall -Wno-write-strings -DTCP_DELAY_BIND_ALL -DNO_TK -DTCLCL_CLASSINSTVAR -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL -DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H -DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H -DHAVE_CONFIG_H -DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE -Drng_test -I. -I. -I/home/osboxes/ns-allinone-2.34/tclcl-1.19 -I/home/osboxes/ns-allinone-2.34/otcl-1.13 -I/home/osboxes/ns-allinone-2.34/include -I/home/osboxes/ns-allinone-2.34/include -I/home/osboxes/ns-allinone-2.34/include -I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc -I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier -I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr -I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv -I./satellite -I./wpan -o mympeg/myudp.o mympeg/myudp.cc
mympeg/myudp.cc: In constructor ‘myUdpAgent::myUdpAgent()’:
mympeg/myudp.cc:19:21: error: cannot call constructor ‘myUdpAgent::UdpAgent’ directly [-fpermissive]
mympeg/myudp.cc:19:21: error: for a function-style cast, remove the redundant ‘::UdpAgent’ [-fpermissive]
make: *** [mympeg/myudp.o] Error 1
Ns make failed!
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
osboxes@osboxes:~/ns-allinone-2.34$


Thank you.
 
Old 09-22-2016, 12:42 PM   #78
vivekanandagn
LQ Newbie
 
Registered: Sep 2016
Posts: 4

Rep: Reputation: Disabled
Exclamation NS2 simulation error, please help in this issue

Quote:
Originally Posted by knudfl View Post
Ref. post #13 :
I managed to build the "mympeg" files : With g++ version 3.4.6 .
The patches mympeg and myevalvid conflict, two separate ns-2.28 were used.

Now two binary packages are available : mympeg-ns-2.28-ubuntu10_i386.deb
https://docs.google.com/file/d/0B7S2...1fUWsybEU/edit
And : myevalvid-ns-2.28-ubuntu10_i386.deb
https://docs.google.com/file/d/0B7S2...1GS1ZCdFk/edit

You can install the packages with : sudo dpkg -i \
mympeg-ns-2.28-ubuntu10_i386.deb myevalvid-ns-2.28-ubuntu10_i386.deb

Providing /usr/local/bin/ ns-mympeg ns-myevalvid
Meaning : You do not have to build anything ..
So now it's up to you to find out how to use the ns-*** with the available files.

-
Sir, when i try to simulate ns2, i am facing following error. Ns2 version i am using is Ns2.34 in Ubuntu 12.04 , 32 bit machine. Please anybody solve this issue.

g++ -c -Wall -Wno-write-strings -DTCP_DELAY_BIND_ALL -DNO_TK -DTCLCL_CLASSINSTVAR -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL -DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H -DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H -DHAVE_CONFIG_H -DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE -Drng_test -I. -I. -I/home/osboxes/ns-allinone-2.34/tclcl-1.19 -I/home/osboxes/ns-allinone-2.34/otcl-1.13 -I/home/osboxes/ns-allinone-2.34/include -I/home/osboxes/ns-allinone-2.34/include -I/home/osboxes/ns-allinone-2.34/include -I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc -I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier -I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr -I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv -I./satellite -I./wpan -o mympeg/myudp.o mympeg/myudp.cc
mympeg/myudp.cc: In constructor ‘myUdpAgent::myUdpAgent()’:
mympeg/myudp.cc:19:21: error: cannot call constructor ‘myUdpAgent::UdpAgent’ directly [-fpermissive]
mympeg/myudp.cc:19:21: error: for a function-style cast, remove the redundant ‘::UdpAgent’ [-fpermissive]
make: *** [mympeg/myudp.o] Error 1
Ns make failed!
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
osboxes@osboxes:~/ns-allinone-2.34$


Thank you.
 
Old 09-22-2016, 01:59 PM   #79
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,709

Rep: Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940
Quote:
Originally Posted by vivekanandagn View Post
Sir, when i try to simulate ns2, i am facing following error. Ns2 version i am using is Ns2.34 in Ubuntu 12.04 , 32 bit machine. Please anybody solve this issue.

g++ -c -Wall -Wno-write-strings -DTCP_DELAY_BIND_ALL -DNO_TK -DTCLCL_CLASSINSTVAR -DNDEBUG -DLINUX_TCP_HEADER -DUSE_SHM -DHAVE_LIBTCLCL -DHAVE_TCLCL_H -DHAVE_LIBOTCL1_13 -DHAVE_OTCL_H -DHAVE_LIBTK8_4 -DHAVE_TK_H -DHAVE_LIBTCL8_4 -DHAVE_TCLINT_H -DHAVE_TCL_H -DHAVE_CONFIG_H -DNS_DIFFUSION -DSMAC_NO_SYNC -DCPP_NAMESPACE=std -DUSE_SINGLE_ADDRESS_SPACE -Drng_test -I. -I. -I/home/osboxes/ns-allinone-2.34/tclcl-1.19 -I/home/osboxes/ns-allinone-2.34/otcl-1.13 -I/home/osboxes/ns-allinone-2.34/include -I/home/osboxes/ns-allinone-2.34/include -I/home/osboxes/ns-allinone-2.34/include -I/usr/include/pcap -I./tcp -I./sctp -I./common -I./link -I./queue -I./adc -I./apps -I./mac -I./mobile -I./trace -I./routing -I./tools -I./classifier -I./mcast -I./diffusion3/lib/main -I./diffusion3/lib -I./diffusion3/lib/nr -I./diffusion3/ns -I./diffusion3/filter_core -I./asim/ -I./qs -I./diffserv -I./satellite -I./wpan -o mympeg/myudp.o mympeg/myudp.cc
mympeg/myudp.cc: In constructor ‘myUdpAgent::myUdpAgent()’:
mympeg/myudp.cc:19:21: error: cannot call constructor ‘myUdpAgent::UdpAgent’ directly [-fpermissive]
mympeg/myudp.cc:19:21: error: for a function-style cast, remove the redundant ‘::UdpAgent’ [-fpermissive]
make: *** [mympeg/myudp.o] Error 1
Ns make failed!
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems
osboxes@osboxes:~/ns-allinone-2.34$


Thank you.
First, there are NOT JUST 'SIRS' on this site. Secondly, you need to read the LQ Rules, and "Question Guidelines".

You hijacked someone elses thread, and posted the same question THREE TIMES, none of which are good. Go back to the one thread you have opened, and please don't do these things.
 
Old 09-22-2016, 11:02 PM   #80
vivekanandagn
LQ Newbie
 
Registered: Sep 2016
Posts: 4

Rep: Reputation: Disabled
Dear TBone, as already the persons i quoted solved similar issues in thread, I thought my issue can be cleared by them. Kindly if any body know how to resolve this issue. Please guide me.
 
Old 09-23-2016, 08:39 AM   #81
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 23,709

Rep: Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940Reputation: 6940
Quote:
Originally Posted by vivekanandagn View Post
Dear TBone, as already the persons i quoted solved similar issues in thread, I thought my issue can be cleared by them. Kindly if any body know how to resolve this issue. Please guide me.
An NS2 question isn't 'similar'. You're asking about a specific module that IS NOT covered in this thread. Further, you IGNORED THE LQ RULES, and posted the same question THREE TIMES, and hijacked someone elses thread to do it.

DO NOT DO THIS. Open your own thread for your own question, period...if that is too difficult to understand, I'm not sure how else it could be explained more simply. We did 'guide you' to open your own thread, and to not post the same question more than once, and you're now arguing about it.
 
  


Reply

Tags
myevalvid, myevalvid2, mympeg, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
calculate power transmission and define wireless parameter for zigbee with NS2 barthunder52 Linux - Networking 0 12-27-2012 06:44 AM
ns2 2.33 with lte patch transmission problem greg1 Linux - Newbie 0 08-14-2012 05:43 AM
No transmission circlesdisplayed for wirless transmission in ns2 susanthomas Linux - Newbie 2 05-23-2012 01:14 AM
Audio Video Transmission Thewyzewun Linux - Hardware 0 08-23-2004 06:04 PM
Want To Only Recive Video Transmission In Gnomemeeting ROORTOKES Linux - Software 3 08-09-2003 11:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration