LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ns2 installation problem in FC5 (https://www.linuxquestions.org/questions/linux-software-2/ns2-installation-problem-in-fc5-467975/)

deep_jyotsingh 07-26-2006 04:03 PM

ns2 installation problem in FC5
 
i am trying to install ns2.29 allinone to my fc5 machine but i am unable to install it due to following reasons:-
1.when i do ./configure in the ns-2.29 i get the following output
[root@Deep ns-2.29]# ./configure
No .configure file found in current directory
Continuing with default options...
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for string.h... (cached) yes
checking for main in -lXbsd... no
checking for socket in -lsocket... no
checking for gethostbyname in -lnsl... yes
checking for dcgettext in -lintl... no
checking for getnodebyname in -ldnet_stub... no
checking that g++ can handle -O2... no
checking if C++ libraries work without any namespace... no
checking if C++ libraries work with namespace std... yes
checking if STL works without any namespace... no
checking if STL works with namespace std... yes
checking should use STL... yes
checking for tcl.h... -I/usr/local/include
checking for libtcl8.4... -L/usr/local/lib -ltcl8.4
checking for init.tcl... /usr/lib/tcl8.4
checking for tclsh8.4.11... no
checking for tclsh8.4... /usr/local/bin/tclsh8.4
checking for tk.h... no
checking for libtk8.4... no
checking for tk.tcl... no
checking for otcl.h... no
checking for libotcl1.11... no
configure: error: otcl is required but could not be completely found.
Please correct the problem by telling configure where otcl is
using the argument --with-otcl=/path/to/package,
or the package is not required, disable it with --with-otcl=no.


2. now when i install or configure otcl1.11 i get following output
[root@Deep otcl-1.11]# ./configure
No .configure file found in current directory
Continuing with default options...
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking for string.h... (cached) yes
checking for main in -lXbsd... no
checking for socket in -lsocket... no
checking for gethostbyname in -lnsl... yes
checking for dcgettext in -lintl... no
checking for getnodebyname in -ldnet_stub... no
checking that g++ can handle -O2... no
checking standard STL is available... no
checking for tcl.h... -I/usr/local/include
checking for tclInt.h... no
checking for libtcl8.4... -L/usr/local/lib -ltcl8.4
checking for init.tcl... /usr/lib/tcl8.4
checking for http.tcl... /usr/lib/tcl8.4/http1.0
checking Tcl http.tcl library... yes
checking for tclsh8.4.11... no
checking for tclsh8.4... /usr/local/bin/tclsh8.4
configure: error: Installation of tcl seems incomplete or can't be found automatically.
Please correct the problem by telling configure where tcl is
using the argument --with-tcl=/path/to/package
(perhaps after installing it),
or the package is not required, disable it with --with-tcl=no.


3.when i have succesfully installed tcl8.4.13 then also it shows the following errors.

can anybody help me with this i need help need to do a project using ns-2

sn68 09-04-2006 11:28 AM

ns2 installation problem in FC5
 
I have recently installed ns-allinone-2.29.tar.gz in FC5
However I didn't need to do the ./configure thing
the steps are
tar zxf ns-allinone-2.29.tar.gz
cd ns-allinone-2.29
./install

Thereafter set the PATH, LD_LIBRARY_PATH, & TCL_LIBRARY as per the message generated by the install script
Once the above steps are over, the package is fully setup and can be used.

Evato 10-01-2006 05:46 AM

Quote:

Originally Posted by sn68
I have recently installed ns-allinone-2.29.tar.gz in FC5
However I didn't need to do the ./configure thing
the steps are
tar zxf ns-allinone-2.29.tar.gz
cd ns-allinone-2.29
./install

Thereafter set the PATH, LD_LIBRARY_PATH, & TCL_LIBRARY as per the message generated by the install script
Once the above steps are over, the package is fully setup and can be used.






Can you Please explain step-by-step how to set the PATH , LD_LIBRARY_PATH, & TCL_LIBRARY
I have no idea how to do it.


thank you

sn68 10-01-2006 07:17 AM

The PATH, LD_LIBRARY_PATH and TCL_LIBRARY can be set in .bashrc file
open terminal
>gedit .bashrc
(add following lines to it suitably modifying the path as in your case, I am posting what I had to add)
PATH=$PATH:$HOME/ns-allinone-2.29/bin
export PATH
PATH=$PATH:$HOME/ns-allinone-2.29/tcl8.4.11/unix
export PATH
PATH=$PATH:$HOME/ns-allinone-2.29/tk8.4.11/unix
export PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/sn68/ns-allinone-2.29/otcl-1.11
export LD_LIBRARY_PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/sn68/ns-allinone-2.29/lib
export LD_LIBRARY_PATH
TCL_LIBRARY=$TCL_LIBRARY:/home/sn68/ns-allinone-2.29/tcl8.4.11/library
export TCL_LIBRARY

Evato 10-01-2006 06:17 PM

Quote:

Originally Posted by sn68
The PATH, LD_LIBRARY_PATH and TCL_LIBRARY can be set in .bashrc file
open terminal
>gedit .bashrc
(add following lines to it suitably modifying the path as in your case, I am posting what I had to add)
PATH=$PATH:$HOME/ns-allinone-2.29/bin
export PATH
PATH=$PATH:$HOME/ns-allinone-2.29/tcl8.4.11/unix
export PATH
PATH=$PATH:$HOME/ns-allinone-2.29/tk8.4.11/unix
export PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/sn68/ns-allinone-2.29/otcl-1.11
export LD_LIBRARY_PATH
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/sn68/ns-allinone-2.29/lib
export LD_LIBRARY_PATH
TCL_LIBRARY=$TCL_LIBRARY:/home/sn68/ns-allinone-2.29/tcl8.4.11/library
export TCL_LIBRARY




Thank youuuuuuuu so much it works perfectly now...


All times are GMT -5. The time now is 06:51 AM.