LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-11-2011, 12:09 PM   #1
tootz
Member
 
Registered: Feb 2011
Posts: 47

Rep: Reputation: 1
ns2.34 validate error


validate overall report: all portable tests passed but
some non-portable tests failed:
./test-all-srm ./test-all-smac-multihop ./test-all-hier-routing ./test-all-algo-routing ./test-all-mcast ./test-all-vc ./test-all-session ./test-all-mixmode ./test-all-webcache ./test-all-mcache ./test-all-plm ./test-all-wireless-tdma
to re-run a specific test, cd tcl/test; ./test-all-TEST-NAME


i followed http://www.linuxquestions.org/questi...-remix-829082/

what have i done wrong?

Last edited by tootz; 02-11-2011 at 12:25 PM.
 
Old 02-11-2011, 01:34 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,167

Rep: Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533
Code:
validate overall report: all portable tests passed but
some non-portable tests failed:
     ./test-all-srm ./test-all-smac-multihop ./test-all-hier-routing ./test-all-algo-routing ./test-all-mcast ./test-all-vc ./test-all-session ./test-all-mixmode ./test-all-webcache ./test-all-mcache ./test-all-plm ./test-all-wireless-tdma
to re-run a specific test, cd tcl/test; ./test-all-TEST-NAME

Note that the non-portable test list includes files that
are known to pass on Linux x86 machines but that are known
to have some portability problems to other platforms or
operating systems.   Failure of one of these tests does not
necessarily mean that one will encounter a problem in your
simulations, but that one must be careful of using that
specific model on the system on which the validate was run.
knudfl@knudfl-desktop:~/tmp/ns-allinone-2.34/ns-2.34$
Seems to be the result on Ubuntu 10.04 Lucid, 64bits.
( Please read the 'Note ..' carefully.)

..
 
Old 02-12-2011, 12:10 PM   #3
tootz
Member
 
Registered: Feb 2011
Posts: 47

Original Poster
Rep: Reputation: 1
i read it carefully already, but still can?
can anyone help please?
 
Old 02-12-2011, 12:55 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,167

Rep: Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533
The 'validate' test shows no errors on a 32bits Ubuntu 10.04.
Only on the 64bits version, which I assume, you have.

The command : 'uname -a' will show.

And when you have the "x86_64 version" : There's nothing to do.

"" Failure of one of these tests does not
necessarily mean that one will encounter a problem in your
simulations, but that one must be careful of using that
specific model on the system on which the validate was run.""

May be you will never have to use one of the critical objects ?

..
 
1 members found this post helpful.
Old 03-15-2011, 11:28 AM   #5
sept02
LQ Newbie
 
Registered: Mar 2011
Posts: 4

Rep: Reputation: 0
Hi,
I have the same problem. I m using ubuntu 10.04 (64 bits)
and I have the same result of "./validate"

but with the command ns:
Quote:
ns: Command not found.
what i have to do please

thanks
 
Old 03-15-2011, 12:14 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2018 CentOS6.10 CentOS7.5 + 50+ other Linux OS, for test only.
Posts: 17,167

Rep: Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533Reputation: 3533
@ sept02 , post #5 : Welcome to LQ. .. .. ..

'ns' : cd ns-allinone-2.34/ns-2.34/ && sudo make install
( Will copy ns to /usr/local/bin/ ).

'nam' : sudo apt-get install nam

..
 
1 members found this post helpful.
Old 03-16-2011, 07:47 AM   #7
sept02
LQ Newbie
 
Registered: Mar 2011
Posts: 4

Rep: Reputation: 0
@ knudfl: thanks a lot !!!!
it works
 
  


Reply

Tags
ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
i am using ubuntu as os. for NS2 to implement a routing protocol in ns2. sujovasu Programming 1 07-27-2010 01:44 AM
NS2 Installation Error ajkannan83 Linux - General 2 01-01-2010 03:35 AM
ns2 error prashantpanse Linux - Newbie 0 09-26-2008 09:13 AM
NS2 Error ajkannan83 Linux - Software 1 02-10-2008 11:33 PM
Error: Could not find the GPG Key necessary to validate pkg pbd22 Linux - Kernel 3 07-29-2006 02:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration