LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   ns2.30: “LMS_SETUP” instead of “UM_Data, AM_Data, etc (https://www.linuxquestions.org/questions/linux-software-2/ns2-30-%93lms_setup%94-instead-of-%93um_data-am_data-etc-869957/)

unodior 03-21-2011 07:58 AM

ns2.30: “LMS_SETUP” instead of “UM_Data, AM_Data, etc
 
I've installed eurane in ns2.30. I'm trying to simulate how one mobile and five mobiles operate in UTRAN (UMTS). It executes without errors and makes the trace. But when I open the trace.tr files to see the results, I find "LMS_SETUP" messages instead of "UM_Data, AM_Data...". It is supposed to be an error related to a bad instalation of eurane and it is solved doing again:

$ cd ns-allinone-2.30/ns-2.30/
$ make clean
$ make depend
$ make
I've tried it, but it gives no error. The simulation doesn't give me an error, but the traces are incorrect. The file .tcl for one mobile and five mobiles where made by another person and they work.
Can you give me any clue of what is happening?

Thanks

Kind Regards,
Stella

knudfl 03-21-2011 08:37 AM

Please attach "file.tcl".

( The "paper clip button" in the Advanced Editor.)

EDIT : Probably one of the tcl scripts here ?
http://eurane.ti-wmc.nl/eurane/

..

unodior 03-21-2011 08:55 AM

No, it's not from that page. My teacher gave them to me.
Sorry, I didn't read the valid extensions. They are tcl files, could I send them by mail? I don't want to disturb

knudfl 03-21-2011 09:00 AM

Quote:

I think I've attached them
1) Browse > select file.txt ( Only suffix .txt will do.)
2) Upload

But a link is better.

unodior 03-21-2011 09:03 AM

2 Attachment(s)
Ok, I only had to write .txt extension at the end of the name. Sorry
Comments inside the file are in Spanish, sorry. But I don't think you need them
Thank you

knudfl 03-21-2011 11:50 AM

Spanish : Don't worry, I have "diccionario de dudas y dificultades de la
lengua española", etc. etc. on the shelf.

Worse is : The files don't work ? Or ? ./ns umts_am5mobiles.tcl.txt ( both ) :
Ejecutandose la Simulación....
Simulación Terminada.
... Not Fedora 14, I will try with that ... later.


P.S. : ./ns test_udp_dch.tcl works, when ns-2.33 is compiled with g++34.
( http://eurane.ti-wmc.nl/eurane/test_udp_dch.tcl )

...

unodior 03-21-2011 12:23 PM

The answer I get is this:
" Simulation is running ... please wait ...
Simulation ended."
And then I open out.trc and it isn't ok. My teacher says it works in her pc, but I've tried it several times and it doesn't work for me.

Thank you very much for trying.

PS: I've checked my version of gcc:gcc versión 4.5.1 20100924 (Red Hat 4.5.1-4) (GCC)
I'm trying to downgrade my version of gcc to 3.4.4

knudfl 03-21-2011 02:04 PM

2 Attachment(s)
export CC=gcc34 CXX=g++34 &&
cd ns-allinone-2.30/tk-8.4.11/ && patch -p0 < tk-8.4-lastevent.patch &&
cd ../ns-2.30/ && zcat ns-eurane-111.diff.gz | patch -p1 && cd .. && ./install
&& cd ns-2.30/ && ./ns umts_am1movil.tcl >>> traza_am1.tr : 127 kB ;
./ns umts_am5mobiles.tcl >>> traza_am1.tr : 27-29 MB.
→ → I found the files ( CentOS55), difficult to spot with the unusual name.
Same result on CentOS 5.5, PCLinuxOS2010, Fedora 14 :
The first 51 (am1) / 55 (am5) lines of each "traza_am1.tr" are attached.

( It is a wonder, if you compiled everything with gcc/g++-4.5.1.
But gcc34, g++34 seem to do the trick.)
..

unodior 03-21-2011 05:03 PM

Sorry, I didn't understood what the first line meant.
I've followed the instructions, but when I get to ./install it says: command not found
I've changed to ns-allinone-2.30/ns-2.30
and tried make clean, and it says I have to re-run configure. so I do it. Then I try make clean and this is what I get:

rm -f *.a *.o libtcl* core errs *~ \#* TAGS *.E a.out \
errors tclsh tcltest lib.exp Tcl
cd dltest ; make clean
make[1]: se ingresa al directorio `/home/Stella/ns-allinone-2.30/ns-2.30/dltest'
rm -f *.o config.cache config.log config.status
rm -f lib.exp ../dltest.marker

Then I try make-depend and I get:
make: *** [depend] Error 127

What is wrong?
rm -f *.so

knudfl 03-21-2011 09:37 PM

Sometimes it is a better solution to start from scratch,
when things have gone wrong. I.e. delete everything.

The order of the commands are not important :
When all the patching has been done, you can also do :
1) exit ; 2) cd ns-allinone-2.30/ ; 3) export CC=gcc34 CXX=g++34
4) ./install

'export' http://www.linuxquestions.org/questi...30-a-866370/#6 post #6.

P.S. : 'cd ..' means the same as 'cd ../' , and you can constantly check
your location with the 'pwd' command.

Good luck ! .. .. :)

..

unodior 03-22-2011 05:01 AM

Ok. I'll start from the beginning.
I tried to install fedora 12 in my desk-pc. Windows XP works perfectly. When I inserted the fedora 12 in the screen appeared this message: frequency not supported. I thought it was a good moment to stop. But I haven't given up!
Thank you very much for all your help.

knudfl 03-22-2011 09:36 AM

No difference really between Fedora 14 and Fedora 12, as long as you do
the right commands. It is the same "export CC=gcc34 CXX=g++34" on Fedora 12.

The old Fedora 12 is obsoleted. The 'Long Term Supported' version of Fedora 12:
Scientific Linux SL 6 https://www.scientificlinux.org/ . It's equal to RHEL 6.

Where is it that it says "frequency not supported" ? At install begin ?
Or is it at GUI ( X ) login ?

..

unodior 03-23-2011 06:22 AM

New problems and more fun
 
Sorry to answer your question now.

On fedora 12, I've tried it this morning and it doesn't give me that error again. Yesterday I tried to install fedora 14, but it says the kernel is too old. I haven't continued yet. I have to do a new partition because it has no free-space. I think fedora 12 can't use the partition windows xp is using, is that right?
I'm downloading the 'Long Term Supported' 6.0, from the page you told me. Thank you.

I've tried to install again eurane in fedora 14 on my laptop . I've followed this steps, as you told me:
export CC=gcc34CXX=g++34
cd ns-allinone-2.30/tk8.4.13
patch -p0 < tk-8.4-lastevent.patch
cd../ns-2.30

Before installing eurane, I tried:

make clean
make depend
make
(it gives me an error with make)

I tried to follow:
zcat ns-eurane-1.12diff.gz|patch -p1

It seemed to work. BUT when I try
./install

It gave me this error:

.gnu.linkonce.t._ZN11taskPending10taskStatusEh' referenced in section `.rodata' of wpan/p802_15_4mac.o: defined in discarded section `.gnu.linkonce.t._ZN11taskPending10taskStatusEh' of wpan/p802_15_4mac.o
collect2: ld devolvió el estado de salida 1
make: *** [ns] Error 1
Ns make failed!

I'm not sure about what I'm doing bad. T
I can't understand it.

I've changed nam 1.12 for the one you gave me: nam-1.14. Still the same error

Kind regards,
Stella

knudfl 03-23-2011 08:07 AM

Be aware that the command 'export CC=gcc34 CXX=g++34' is temporary.
Will reset to g++ ( g++-4.5.1 ) if you exit the terminal.

Please have a look into the Makefile. Must say : CC = gcc34 , CPP = g++34.


By the way : 'make depend' is not required. I have never used it in ns2.

..

unodior 03-23-2011 08:19 AM

Thanks :)
Yes, I understood it was temporary. But I haven't exit the terminal during installation. I've done it twice following your steps.
I'm gonna have a look at make file.

About make depend, my teacher told me to use it. I didn't know if it was necessary. Sorry

My makefile:

# The following will be redefined under Windows (see WIN32 lable below)
CC = gcc34
CPP = g++34
LINK = $(CPP)
MKDEP = ./conf/mkdep
TCLSH = /home/Stella/ns-allinone-2.30/bin/tclsh8.4
TCL2C = ../tclcl-1.18/tcl2c++
AR = ar rc $(BLANK)

RANLIB = ranlib
INSTALL = /usr/bin/install -c
LN = ln
TEST = test
RM = rm -f
MV = mv
PERL = /usr/bin/perl

During installation process I've seen it uses g++34.

I've asked my teacher, but she doesn't know what to do.
I've tried to start from the scratch twice, but both times I get the same error.
I don't know what else to do.
What do you recommend? Start from the scratch again? Perhaps the third is the good one ..


All times are GMT -5. The time now is 09:44 PM.