-   Linux - Software (
-   -   ns-2 CRCN patch. Testing examples problem (

cosdag 02-04-2013 04:01 PM

ns-2 CRCN patch. Testing examples problem
Hello everyone.
This is my first and I'm guessing not last post. I have installed ns-2 and CRCN patch using information from here:

everything went smoothly. Ns-2, CRCN from terminal and CRCN GUI seem to work ok.
At the webpage below are presented the simulation results (throughput) of tcl scripts test4maccon, test4mcng, test4macng for 2 & 5 channels.

running the test4maccon.tcl I get the exact same graph which is correct because the topology and mobility are defined, BUT when I run the test4macng scripts I get different throughput results which make no sense at all! has anyone ever tested these scripts? can somebody please give it a go so I can tell whether it's an installation fault or not? any suggestions? (I have installed Ubuntu 10.04 on VMWare by the way)

Thank you in advance

knudfl 02-05-2013 06:01 AM

Welcome to LQ.

Not quite clear what you mean.
Results can be different each time you run the same simulation.
( Haven't checked if that's the case with the test4macng*.tcl files.)

I made a test with a 2 year old "ns -crcn" executable.
All six simulations seem OK.
The result, crcn-test-all-tcl.tar.bz2 (1.8 MB) can be downloaded from ..
.. Please read the included file 'README-test-ns-crcn'.

CRCN info : LQ Search → → Tag = crcn


cosdag 02-05-2013 07:09 AM

Thank you for the reply

Perhaps I wasn't clear enough. I have no problems running the scripts. I get no errors. The problem is calculating throughput either using GUI or terminal. The resulting graph should be exactly the same, as there is no random motion of the nodes. The topology and mobility of nodes are strictly defined through topology files random.tcl and topo4.tcl.
As I said, the throughput graph of script test4maccon.tcl is exactly the same as the one presented on their webpage, but that's not the case for the rest of the scripts.
I could upload my results compared with the given ones, but I don't think it would help in any way, as the problem is that there shouldn't be any difference at all...

marwa88 12-06-2015 06:23 PM

Hi knudfl,
please did you get idea about this problem?
i have the same problem above. when i try to get the throughput results, about maccon (test4maccon.tcl+topo4.tcl) i get the same result in the link below, but when i try Macng (test4macng.tcl+topo4.tcl) my result are diffrent to results affered in this link.
have you idea please?

Thank you.

knudfl 12-06-2015 11:10 PM

Re #4.

? May be you are using the wrong "Linux OS" ?

The link to Tricia_Chigan in post #4 : Not a valid link.

marwa88 12-07-2015 05:04 AM

2 Attachment(s)
I use fedora 12 ( i think that it support the CRCN patch).

About the link, i did a screenshot to explain what I mean exactly,see them please.
Attachment 20235 : this is was ok, i get the same.
Attachment 20236 : i get a difrent one.

if you have any suggestion, tell me please.
Thank you.

marwa88 12-09-2015 09:07 PM

Hi knudfl,

I try to simulate macng of the CRCN, but the problem: when i use channel number = 1,2,3,4; the throughput is the same and don't change. Throughput change only when channel=5 (with 6 channel i get the same result as 5 channel).
Have you idea please about my problem please?

thank you

All times are GMT -5. The time now is 07:55 AM.