LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-19-2015, 02:23 PM   #16
kingsfischer
LQ Newbie
 
Registered: Jul 2015
Posts: 3

Rep: Reputation: Disabled
deepin too


I'm not a Hulu subscriber, just watch the free stuff, but having the exact same problem. Running completely up-to-date deepin distro with Chromium. Also, as others have been reporting, no dice with Firefox either.

Thanks for taking the trouble to gather information about this.
 
Old 08-19-2015, 03:11 PM   #17
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 19
Posts: 6,371
Blog Entries: 21

Rep: Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210Reputation: 3210
No, I won't fix my computer for your site.

Good luck with the paid subscriptions. I left Hulu behind after they dropped support for the Linux Hulu.Desktop application that worked on Debian.

http://antix.freeforums.org/hulu-tv-...box-t3475.html

Seemed since they dropped support for that. I figured they were going to be customer unfriendly after that and moved on to Miro instead.

http://www.howtogeek.com/80046/weeke...s-with-miro-2/

I do not have it installed yet on this netbook. But I bet I have the room.
So I might as well.

Code:
$ df -h --total
Filesystem      Size  Used Avail Use Mounted on
/dev/sda1        15G  5.4G  8.3G  40% /
udev             10M     0   10M   0% /dev
tmpfs           202M  504K  201M   1% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           1.2G  4.0K  1.2G   1% /run/shm
/dev/sda5        37G  4.5G   31G  13% /media/_data
total            53G  9.8G   40G  20%
Just a dry run

Code:
harry@antix1:~
$ apt-cache policy miro
miro:
  Installed: (none)
  Candidate: 6.0-1+b1
  Version table:
     6.0-1+b1 0
        500 http://ftp.us.debian.org/debian/ testing/main i386 Packages
harry@antix1:~
$ sudo apt-get -s install miro
[sudo] password for harry: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libpostproc52 libupower-glib3
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gstreamer0.10-gconf gstreamer0.10-plugins-bad gstreamer0.10-plugins-base
  gstreamer0.10-plugins-good gstreamer0.10-x libaa1 libboost-python1.55.0
  libcdaudio1 libfftw3-double3 libgstreamer-plugins-bad0.10-0
  libjavascriptcoregtk-1.0-0 libkate1 libmimic0 libofa0 libshout3 libslv2-9
  libsoundtouch0 libspandsp2 libtorrent-rasterbar7 libvisual-0.4-0
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwildmidi-config libwildmidi1
  libzbar0 miro-data python-gst0.10 python-libtorrent python-mutagen
  python-pysqlite2 python-webkit
Suggested packages:
  frei0r-plugins libfftw3-bin libfftw3-dev slv2-jack libtorrent-rasterbar-dbg
  ttf-dejavu gstreamer0.10-ffmpeg gstreamer0.10-plugins-ugly
  libavahi-compat-libdnssd1 ffmpeg2theora python-gst0.10-dev
  python-gst0.10-dbg python-mutagen-doc python-pysqlite2-doc
  python-pysqlite2-dbg
Recommended packages:
  libvisual-0.4-plugins gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  geoclue-2.0 freepats
The following NEW packages will be installed:
  gstreamer0.10-gconf gstreamer0.10-plugins-bad gstreamer0.10-plugins-base
  gstreamer0.10-plugins-good gstreamer0.10-x libaa1 libboost-python1.55.0
  libcdaudio1 libfftw3-double3 libgstreamer-plugins-bad0.10-0
  libjavascriptcoregtk-1.0-0 libkate1 libmimic0 libofa0 libshout3 libslv2-9
  libsoundtouch0 libspandsp2 libtorrent-rasterbar7 libvisual-0.4-0
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwildmidi-config libwildmidi1
  libzbar0 miro miro-data python-gst0.10 python-libtorrent python-mutagen
  python-pysqlite2 python-webkit
0 upgraded, 32 newly installed, 0 to remove and 4 not upgraded.
Inst libaa1 (1.4p5-43 Debian:testing [i386])
Inst libfftw3-double3 (3.3.4-2 Debian:testing [i386])
Inst libshout3 (2.3.1-3 Debian:testing [i386])
Inst libslv2-9 (0.6.6+dfsg1-3 Debian:testing [i386])
Inst libtorrent-rasterbar7 (0.16.18-1 Debian:testing [i386])
Inst libvisual-0.4-0 (0.4.0-6 Debian:testing [i386])
Inst libboost-python1.55.0 (1.55.0+dfsg-4 Debian:testing [i386])
Inst python-libtorrent (0.16.18-1 Debian:testing [i386])
Inst gstreamer0.10-gconf (0.10.31-3+nmu4+b1 Debian:testing [i386])
Inst gstreamer0.10-plugins-base (0.10.36-2 Debian:testing [i386])
Inst gstreamer0.10-plugins-good (0.10.31-3+nmu4+b1 Debian:testing [i386])
Inst gstreamer0.10-x (0.10.36-2 Debian:testing [i386])
Inst libcdaudio1 (0.99.12p2-13+b1 Debian:testing [i386])
Inst libjavascriptcoregtk-1.0-0 (2.4.9-2 Debian:testing [i386])
Inst libkate1 (0.4.1-4 Debian:testing [i386])
Inst libmimic0 (1.0.4-2.2 Debian:testing [i386])
Inst libofa0 (0.9.3-7 Debian:testing [i386])
Inst libsoundtouch0 (1.9.0-1 Debian:testing [i386])
Inst libspandsp2 (0.0.6-2.1 Debian:testing [i386])
Inst libwebkitgtk-1.0-common (2.4.9-2 Debian:testing [all])
Inst libwebkitgtk-1.0-0 (2.4.9-2 Debian:testing [i386])
Inst libwildmidi-config (0.3.8-2 Debian:testing [all])
Inst libwildmidi1 (0.3.8-2 Debian:testing [i386])
Inst libzbar0 (0.10+doc-10 Debian:testing [i386])
Inst python-gst0.10 (0.10.22-3 Debian:testing [i386])
Inst python-mutagen (1.29-1 Debian:testing [all])
Inst python-pysqlite2 (2.6.3-4 Debian:testing [i386])
Inst python-webkit (1.1.8-3 Debian:testing [i386])
Inst libgstreamer-plugins-bad0.10-0 (0.10.23-8.1 Debian:testing [i386])
Inst gstreamer0.10-plugins-bad (0.10.23-8.1 Debian:testing [i386])
Inst miro-data (6.0-1 Debian:testing [all])
Inst miro (6.0-1+b1 Debian:testing [i386])
Conf libaa1 (1.4p5-43 Debian:testing [i386])
Conf libfftw3-double3 (3.3.4-2 Debian:testing [i386])
Conf libshout3 (2.3.1-3 Debian:testing [i386])
Conf libslv2-9 (0.6.6+dfsg1-3 Debian:testing [i386])
Conf libtorrent-rasterbar7 (0.16.18-1 Debian:testing [i386])
Conf libvisual-0.4-0 (0.4.0-6 Debian:testing [i386])
Conf libboost-python1.55.0 (1.55.0+dfsg-4 Debian:testing [i386])
Conf python-libtorrent (0.16.18-1 Debian:testing [i386])
Conf gstreamer0.10-gconf (0.10.31-3+nmu4+b1 Debian:testing [i386])
Conf gstreamer0.10-plugins-base (0.10.36-2 Debian:testing [i386])
Conf gstreamer0.10-plugins-good (0.10.31-3+nmu4+b1 Debian:testing [i386])
Conf gstreamer0.10-x (0.10.36-2 Debian:testing [i386])
Conf libcdaudio1 (0.99.12p2-13+b1 Debian:testing [i386])
Conf libjavascriptcoregtk-1.0-0 (2.4.9-2 Debian:testing [i386])
Conf libkate1 (0.4.1-4 Debian:testing [i386])
Conf libmimic0 (1.0.4-2.2 Debian:testing [i386])
Conf libofa0 (0.9.3-7 Debian:testing [i386])
Conf libsoundtouch0 (1.9.0-1 Debian:testing [i386])
Conf libspandsp2 (0.0.6-2.1 Debian:testing [i386])
Conf libwebkitgtk-1.0-common (2.4.9-2 Debian:testing [all])
Conf libwebkitgtk-1.0-0 (2.4.9-2 Debian:testing [i386])
Conf libwildmidi-config (0.3.8-2 Debian:testing [all])
Conf libwildmidi1 (0.3.8-2 Debian:testing [i386])
Conf libzbar0 (0.10+doc-10 Debian:testing [i386])
Conf python-gst0.10 (0.10.22-3 Debian:testing [i386])
Conf python-mutagen (1.29-1 Debian:testing [all])
Conf python-pysqlite2 (2.6.3-4 Debian:testing [i386])
Conf python-webkit (1.1.8-3 Debian:testing [i386])
Conf libgstreamer-plugins-bad0.10-0 (0.10.23-8.1 Debian:testing [i386])
Conf gstreamer0.10-plugins-bad (0.10.23-8.1 Debian:testing [i386])
Conf miro-data (6.0-1 Debian:testing [all])
Conf miro (6.0-1+b1 Debian:testing [i386])
Looks like certain powers are trying to corner us in.
Looks to be getting harder and harder for us red headed step children.
To watch shows legally on our operating systems.

Iceweasel 40 in Debian plays only commercials in my free account at Hulu. They want me to try the free trial for a week to view any thing else. Even trailers. Fool me once. Shame on you. Fool me twice. Shame on me.

I better do a apt-get update && apt-get dist-upgrade before proceeding I guess. Just to be on the safe side.

Edit: Done

Code:
harry@antix1:~
$ apt-cache policy miro
miro:
  Installed: 6.0-1+b1
  Candidate: 6.0-1+b1
  Version table:
 *** 6.0-1+b1 0
        500 http://ftp.us.debian.org/debian/ testing/main i386 Packages
        100 /var/lib/dpkg/status
harry@antix1:~
Hulu site is in miro also.

Last edited by rokytnji; 08-19-2015 at 04:28 PM.
 
Old 08-20-2015, 07:00 PM   #18
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Original Poster
Rep: Reputation: 157Reputation: 157
Quote:
Originally Posted by rokytnji View Post
Good luck with the paid subscriptions. I left Hulu behind after they dropped support for the Linux Hulu.Desktop application that worked on Debian...

I do not have it installed yet on this netbook. But I bet I have the room.
So I might as well...

Looks like certain powers are trying to corner us in.
Looks to be getting harder and harder for us red headed step children.
To watch shows legally on our operating systems.

...
Thanks, rokytnji,...

The information is helpful. YES,... I also believe this is an attack on our OSOS (Open Source Operating Systems) choices... Veiled,... most likely... I believe that Google needs to be called out, THE MOST, in this...

Why?!?! They have spearheaded OSOS (Open Source Operating Systems), and then,... the only solutions involve use of their closed source Chrome or Android, solutions?!?! They are spending quite a lot to separate themselves from MS or Apple or Oracle,... Yet they leave us to the wolves!?!?!?

If we had their Pepper Flash player,... This could all be over...
 
Old 08-21-2015, 12:07 AM   #19
Pseudoman
LQ Newbie
 
Registered: Aug 2015
Location: Planet Earth
Distribution: Debian
Posts: 5

Rep: Reputation: Disabled
Hey, I just created an account here to share a workaround that I found for playing Hulu videos on Chrome for Linux!
Steps:
1. Visit page for Hulu video you want to watch.
2. View page source.
3. Find <meta property="og:video" content="URL"> in the <head> section.
4. Visit URL in above tag.
5. Watch some video from Hulu!
This will open some sort of embedded player thing, maybe an older-version player, but it worked for me on the latest stable release (as of 8/20/15).

Last edited by Pseudoman; 08-21-2015 at 02:44 PM. Reason: Correction in meta tag, from name to property
 
Old 08-21-2015, 01:12 AM   #20
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,585

Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
Quote:
Originally Posted by JaseP View Post
If we had their Pepper Flash player,... This could all be over...
You can use Pepper Flash in the open source Chromium -- in debian the package is pepperflashplugin-nonfree. If Mozilla wanted they could also implement Pepper Flash in Firefox but they chose not to. So there isn't all that much reason to blame Google (beleive me I'm no fan though).
As things stand Flash is on its way out anyhow so it is only the likes of the MP Ass of America and other morons who think it's a viable solution.
 
Old 08-21-2015, 03:05 PM   #21
Pseudoman
LQ Newbie
 
Registered: Aug 2015
Location: Planet Earth
Distribution: Debian
Posts: 5

Rep: Reputation: Disabled
Cool Bookmarklet/Javascript to access with workaround

Hey everybody, I used the workaround I discovered to create a bookmarklet to automate the steps using the <link> tag instead of the <meta> tag:
Code:
javascript:function getURL() { var links = document.getElementsByTagName("link"); for (var i=0; i < links.length; i++) { if (links[i].getAttribute("rel") == "media:video") { return links[i].getAttribute("href"); } } return ""; } function main() { window.open(getURL()); } main();
Plus, it works on FireFox without HAL.

Last edited by Pseudoman; 08-21-2015 at 06:54 PM. Reason: Code corrections
 
Old 08-22-2015, 02:39 AM   #22
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 18.04-14.04, Scientific Linux 6.3-6.4, Android-x86, Pretty much all distros at one point...
Posts: 1,802

Original Poster
Rep: Reputation: 157Reputation: 157
Quote:
Originally Posted by Pseudoman View Post
Hey, I just created an account here to share a workaround that I found for playing Hulu videos on Chrome for Linux!
Steps:
1. Visit page for Hulu video you want to watch.
2. View page source.
3. Find <meta property="og:video" content="URL"> in the <head> section.
4. Visit URL in above tag.
5. Watch some video from Hulu!
This will open some sort of embedded player thing, maybe an older-version player, but it worked for me on the latest stable release (as of 8/20/15).
Very nice,... It raises the possibility of creating a Chrome plug-in to bypass the error... It's a little too cumbersome to use on a practical level, though...
 
Old 08-25-2015, 09:45 AM   #23
Pseudoman
LQ Newbie
 
Registered: Aug 2015
Location: Planet Earth
Distribution: Debian
Posts: 5

Rep: Reputation: Disabled
Looks like Hulu took care of that workaround that I found... started receiving the same 3336 error from the embeded page today
 
Old 08-25-2015, 11:39 AM   #24
MasterDak
LQ Newbie
 
Registered: Aug 2015
Posts: 3

Rep: Reputation: Disabled
I'm starting to think that they don't like us anymore...
 
Old 08-26-2015, 02:04 AM   #25
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Quote:
Originally Posted by MasterDak View Post
I'm starting to think that they don't like us anymore...
They don't like being in business. It's a shame that all those shows effectively got canceled.
 
Old 08-26-2015, 04:41 AM   #26
MasterDak
LQ Newbie
 
Registered: Aug 2015
Posts: 3

Rep: Reputation: Disabled
Yep, I already canceled my subscription for the time being.
 
Old 08-27-2015, 06:38 PM   #27
sfulysses
LQ Newbie
 
Registered: Dec 2001
Distribution: Arch
Posts: 10

Rep: Reputation: 0
Response from Hulu

I wrote to hulu complaining about this and they said it is a known issue and they're working on it. I'll give the benefit of the doubt on that, I guess we'll see.

Last edited by sfulysses; 08-27-2015 at 06:41 PM.
 
Old 08-28-2015, 02:01 AM   #28
ardvark71
LQ Veteran
 
Registered: Feb 2015
Location: USA
Distribution: Lubuntu 14.04, Windows Vista
Posts: 6,277
Blog Entries: 3

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Quote:
Originally Posted by sfulysses View Post
I wrote to hulu complaining about this and they said it is a known issue and they're working on it. I'll give the benefit of the doubt on that, I guess we'll see.
Hi all...

As of this moment, I receive an "Error Code: 3336" in Chrome and "Error Code: 2203" in Firefox.

UPDATE: I installed HAL and while that enabled me to see the ads, attempting to view the regular content produced the same error message in Firefox.

Regards...

Last edited by ardvark71; 08-28-2015 at 02:34 AM. Reason: Added Information.
 
Old 10-24-2015, 10:39 PM   #29
joshuasulwer
LQ Newbie
 
Registered: Oct 2015
Posts: 1

Rep: Reputation: Disabled
tried and did not work- and am wary of what I even installed on my test system because it was 130 something mb! - " Use something like this: https://github.com/i-rinat/freshplayerplugin" (NO CHANGE)
tried and didnt work- the view source and copy the embeded link from page two of this post, it almost worked, but same error popped up 3336. cancelling hulu its been a couple weeks, plus I don't like the control freaks of DMR that fund hulu. amazon prime, netflix, and youtube still work. Using ubuntu 14.04LTS having trouble with windows 7 too, in that case the CPUs's max out at 100% when using anything flash in chrome or firefox.
 
Old 11-04-2015, 10:25 AM   #30
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
I did manage to get libhal.so to work for hulu in debian jessie. The ubuntu option has a ppa for it.

https://launchpad.net/~mjblenner/+ar...untu/hal-flash
https://code.launchpad.net/~mjblenner/+junk/hal-flash

Code:
$ mkdir hal_2015
$ cd hal_2015/
$ bzr branch lp:~mjblenner/+junk/hal-flash
$ cd hal-flash
(build stuff / not sure what I did, but building the package failed, building the .so worked)
And installed manually:
Code:
# cp ./src/.libs/libhal.so.1.0.0 /usr/lib/libhal.so.1.0.0
# cd /usr/lib/
# ln -s libhal.so.1.0.0 libhal.so.1.0
# ln -s libhal.so.1.0.0 libhal.so.1
# ln -s libhal.so.1.0.0 libhal.so
# ldconfig
Caveats, requires the adobe's flash for linux. So firefox, not chrome.

Last edited by Shadow_7; 11-04-2015 at 10:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Youtube: Choppy playback with Google Chrome lems Slackware 16 11-02-2013 02:08 PM
Audio no longer working in Chrome and Opera Rundi Linux - Software 3 02-25-2013 08:33 PM
hulu desktop sound not working baronobeefdip Linux - Software 0 02-23-2011 05:27 PM
[SOLVED] Hulu stopped working DonnieP Slackware 5 10-23-2010 07:04 AM
HELP - Hulu problem: suddenly can't play Hulu episodes, just happened in past few day Lynnbro51 Linux - Newbie 15 01-23-2010 07:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration