LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-26-2017, 09:31 AM   #1
Herve5
Member
 
Registered: Oct 2016
Location: Europe
Distribution: Debian & Ubuntu Mate
Posts: 85

Rep: Reputation: Disabled
Unhappy non-QWERTY keyboard unrecognized at login (Ubuntu Mate 16.04)


Hello all,

I happen to have two different U-Mate laptops, which were preloaded with the very same version 16.04LTS by the hardware supplier some months ago. The difference is, one was with a 'regional' keyboard (french keymap), the other kept a standard QWERTY one. I did start them almost alike, we used them alike too, and now my hardware supplier did receive the french keyboard for the second laptop, and sent it to us.

After the delicate operation that a laptop keyboard switch does represent for me, I discover that when logged, I can set the keyboard to whichever mapping I want in (surprisingly) two separate ways : one via Control Center > keyboard, and an apparently entierely independent thing in the general menu, called iBus. But well, when both are set to french, the french keyboad actually works, including for entering password if I lock the screen.

Now, things begin to be interesting when I reboot : at that moment, the keyboard is still considered a standard QWERTY one. This whatever I do in Control Center and iBus. (I went up to delete completely the QWERTY alternatives there, rebooted etc.)

This situation is all the more bothering me, that on the other laptop -the one that came factory-mounted with a french keyboard, the login password definitely respects the french mapping.

From reading contributions here on this topic I discover that apparently what happens at boot time highly depends on distributions : all I read concerned others, which setting files visibly are NOT located at the same place as on Ubuntu... so I feel quite beyond my area of competence here ;-)

And of course, mind you : the faulty machine is that for my S. O. :-)
 
Old 07-26-2017, 10:40 AM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 9,356
Blog Entries: 13

Rep: Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411
I was wondering if this is a BIOS setting.

It makes me think that the system detects the French keyboard at time of install. Therefore grub may have been installed with an assumption for a U.S. QWERTY keyboard layout versus the French one. Perhaps try:
Code:
sudo update-grub
with the French keyboard plugged in?
 
1 members found this post helpful.
Old 07-26-2017, 10:58 AM   #3
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,790

Rep: Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153
This nothing to do with BIOS or Grub. BIOS has nothing to do with the keyboard. The Linux boot routine only checks for the presence of a keyboard and its hardware type: PC, Mac, Sun, etc. QWERTY and AZERTY keyboards of the same type generate the same codes.

The choice of keyboard driver is made after you log in. The desktop checks which language you want and compiles a driver by combining the source code from the hardware and language files. So, what's happening is that the record default keyboard is being lost every time you shut down. That's a new one on me! I'm no expert on Ubuntu, but you might check the locate setting by using the command locale. If the first line looks like
LANG="EN.UTF-8"
that'll be the trouble. If so, make sure you actually have a French locale available with the command
locale -a | grep -i fr
and then use a command like
update-locale LANG=FR.UTF-8
 
1 members found this post helpful.
Old 07-26-2017, 01:49 PM   #4
Herve5
Member
 
Registered: Oct 2016
Location: Europe
Distribution: Debian & Ubuntu Mate
Posts: 85

Original Poster
Rep: Reputation: Disabled
Many thanks for this help : without you I'd be plain unable to understand where I am...
Alas, I still have trouble... Following your advice here is what I do:

~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:en_US:en <--THIS is different from the 'good' machine, where I only have 'LANGUAGE=fr_FR'
LC_CTYPE="fr_FR.UTF-8"
(etc. with everything else properly set to FR.UTF-8) LC_ALL=


I check the french locale does exist indeed :


~$ locale -a | grep -i fr
fr_BE.utf8
fr_CA.utf8
fr_CH.utf8
fr_FR.utf8
fr_LU.utf8


(the above is the same as on the 'good' machine)

I have a failure with

sudo update-locale LANG=FR.UTF-8
[sudo] Mot de passe de f... :
*** update-locale: Error: invalid locale settings: LC_MONETARY="fr_FR.UTF-8" LC_IDENTIFICATION="fr_FR.UTF-8" LC_NAME="fr_FR.UTF-8" LC_TELEPHONE="fr_FR.UTF-8" LANG=FR.UTF-8 LC_NUMERIC="fr_FR.UTF-8" LC_MEASUREMENT="fr_FR.UTF-8" LC_TIME="fr_FR.UTF-8" LANGUAGE="fr_FR:en_US:en" LC_ADDRESS="fr_FR.UTF-8" LC_PAPER="fr_FR.UTF-8"


Then I tried with 'fr_FR' instead of just FR :


~$ sudo update-locale LANG=fr_FR.UTF-8
[sudo] Mot de passe de f... :

(no negative message)

~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:en_US:en <-- no better :-( :-(
LC_CTYPE="fr_FR.UTF-8"
(etc.)

~$ sudo update-grub <-- will not work either:
[sudo] Mot de passe de frederique :
Création du fichier de configuration GRUB…
Attention : Définir GRUB_TIMEOUT à une valeur non nulle si GRUB_HIDDEN_TIMEOUT est définie n’est plus possible.
Image Linux trouvée : /boot/vmlinuz-4.11.1-041101-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.11.1-041101-generic
Adding boot menu entry for EFI firmware configuration
fait
~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:en_US:en <-- no better either
LC_CTYPE="fr_FR.UTF-8"
(...)
 
Old 07-26-2017, 02:53 PM   #5
jefro
Moderator
 
Registered: Mar 2008
Posts: 20,988

Rep: Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406
Let's check that you can use the keyboard correctly in bios just to see.
Then we can move on to next.

Might be that booting to a fully localized distro where you select choices at boot may help understand what is going on.

I've seen bad keyboards too.

Last edited by jefro; 07-26-2017 at 04:31 PM.
 
Old 07-26-2017, 03:32 PM   #6
Herve5
Member
 
Registered: Oct 2016
Location: Europe
Distribution: Debian & Ubuntu Mate
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jefro View Post
Let's check that you can use the keyboard correctly in bios just to see.
Then we can move on to next.
Thanks Jefro.
How do I do this?
 
Old 07-26-2017, 04:31 PM   #7
jefro
Moderator
 
Registered: Mar 2008
Posts: 20,988

Rep: Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406Reputation: 3406
Boot to bios usually and see if you can use keyboard shortcuts and such.

It is possible that I don't fully understand the issue.

In my mind, while the two laptops may have similar OS's on them from factory, they may not be exactly the same. If the OEM did provide it in working order then we should assume that it can work. When you install a distro they usually ask for local by some means. Either an automated installer or by install program. You can usually re-start than installer to correct issues and may work. You can also sometimes set grub to correct the keyboard or other boot time options. You may be able to change fully the keyboard in a setting or more.

In worse case, I suppose you could clone the working system over.

Last edited by jefro; 07-26-2017 at 04:36 PM.
 
Old 07-27-2017, 01:19 AM   #8
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010Reputation: 1010
I had a system with a GB_en keyboard set. Some of the keys are switched around from an US_en keyboard. I finally solved the problem by setting the keyboard region in gnome-control-center.
 
Old 07-27-2017, 05:45 AM   #9
Herve5
Member
 
Registered: Oct 2016
Location: Europe
Distribution: Debian & Ubuntu Mate
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by AwesomeMachine View Post
I had a system with a GB_en keyboard set. Some of the keys are switched around from an US_en keyboard. I finally solved the problem by setting the keyboard region in gnome-control-center.
Alas, this does not work. I still have the mangle 'locale' announcing a mix of qwerty qnd french keyboards, and I don't know where this is coming from...
Jefro I didn't try the BIOS boot yet, which is something a bit terrifying for my level, but I'll do
 
Old 07-27-2017, 06:26 AM   #10
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 9,356
Blog Entries: 13

Rep: Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411
Quote:
Originally Posted by Herve5 View Post
Alas, this does not work. I still have the mangle 'locale' announcing a mix of qwerty qnd french keyboards, and I don't know where this is coming from...
Jefro I didn't try the BIOS boot yet, which is something a bit terrifying for my level, but I'll do
This would be the computer BIOS, meaning the SETUP screen. Something which has been with computers for many years, even if perhaps you have little experience with it. For the model of computer you have there should be a key to press right after you turn it on, to cause it to enter the BIOS, or SETUP menu. Once in there, the screens are fairly brief, they are how you can do things like perform hardware diagnosis, or extra setup of your computer.

Earlier you wrote "U-Mate" and said they are laptops, but I did not find an exact match. Closest I see are some from Huawei. Can you please give the manufacturer name and model of the laptop? It should be on a sticker on the bottom.

From there we can give you more specific instructions, such as what key to press to cause it to enter the BIOS menu during boot, and then also perhaps some recommendations what BIOS menus to look at to see how it detects your keyboard.
 
Old 07-27-2017, 09:59 AM   #11
Herve5
Member
 
Registered: Oct 2016
Location: Europe
Distribution: Debian & Ubuntu Mate
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rtmistler View Post
Earlier you wrote "U-Mate" and said they are laptops, but I did not find an exact match. Closest I see are some from Huawei. Can you please give the manufacturer name and model of the laptop? It should be on a sticker on the bottom.
By U-Mate I meant Ubuntu Mate, sorry. The laptops are Tuxedo ones, both from this year.
 
Old 07-27-2017, 10:56 AM   #12
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: PCLinuxOS, Debian
Posts: 5,790

Rep: Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153Reputation: 2153
Quote:
Originally Posted by Herve5 View Post
~$ locale
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR:en_US:en
That doesn't look good!

Quote:
sudo update-locale LANG=FR.UTF-8
[sudo] Mot de passe de f... :
*** update-locale: Error: invalid locale settings
You'll have to do this the old fashioned way. Launch your text editor from the terminal using sudo and edit the file /etc/default/locale. Just remove the "en_US:en" part. After you've saved, set the keyboard again and then reboot and see if it stays set.
 
1 members found this post helpful.
Old 07-27-2017, 11:04 AM   #13
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 9,356
Blog Entries: 13

Rep: Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411Reputation: 4411
Quote:
Originally Posted by Herve5 View Post
By U-Mate I meant Ubuntu Mate, sorry. The laptops are Tuxedo ones, both from this year.
From here? https://www.tuxedocomputers.com/Tuxe...-Hardware.geek

Well there are a number of models, a quick web search for tuxedo computer bios key shows German documents or references citing F7, F10, or F11 as the key to press to get into BIOS "depending on the model"
 
1 members found this post helpful.
Old 07-31-2017, 06:24 AM   #14
Herve5
Member
 
Registered: Oct 2016
Location: Europe
Distribution: Debian & Ubuntu Mate
Posts: 85

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by DavidMcCann View Post
You'll have to do this the old fashioned way. Launch your text editor from the terminal using sudo and edit the file /etc/default/locale. Just remove the "en_US:en" part. After you've saved, set the keyboard again and then reboot and see if it stays set.
I just did this, and now am terrified at the fact that, being on holidays, we don't have any usb external keyboard to try to login if something failed :-D
But, I'm going to attempt -just when she's done working!
Quote:
Originally Posted by rtmistler View Post
From here? https://www.tuxedocomputers.com/Tuxe...-Hardware.geek
Well there are a number of models, a quick web search for tuxedo computer bios key shows German documents or references citing F7, F10, or F11 as the key to press to get into BIOS "depending on the model"
Indeed -in fact my main issue is I have little knowledge of what to do when on the BIOS. Shall I assume it's something like a simplified Terminal interaction?

Many thanks to both of you!!
H.

Last edited by Herve5; 07-31-2017 at 06:26 AM.
 
  


Reply

Tags
boot issues, keyboard layout, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oldtime machine was like a printer with a QWERTY keyboard etech3 General 1 11-22-2012 07:41 AM
[SOLVED] Strange QWERTY keyboard layout: which one is it? kikinovak Slackware 6 10-01-2012 09:38 AM
Windowmaker: bound keyboard commands use qwerty keyboard but within apps, dvorak. daweefolk Linux - General 2 09-01-2012 05:21 PM
How To Type German Using Qwerty Keyboard? lazylogic Linux - General 7 12-29-2007 06:15 PM
Special Characters with qwerty keyboard fabre Linux - General 1 05-02-2006 08:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration