-   Linux - Software (
-   -   NOMACHINE: NX client error: 'connection timeout' (

cucolin@ 12-03-2008 01:31 PM

NOMACHINE: NX client error: 'connection timeout'
i was able to connect the first time following the instructions here:

1. first time i was able to connect i used the nx client for Mac OS X. I logged off.
2. then i decided to test this using Windows nx client and i got:
NX> 203 NXSSH running with pid: 604
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 280 Exiting on signal: 15

and a NOMACHINE popup window saying: 'connection timeout'

3. came back to my mac os x machine i tried connecting again. i got the same error as indicated in #2.
4. went to my linux machine i tried connecting. i got the same error as indicated in #2.

Now i'm not able to connect from anywhere! help is appreciated! thanks

haertig 12-04-2008 09:43 PM

See if you have a /var/log/nxserver.log file available. Locations may be different on different distros, but /var/log is usually where this stuff goes. Also check /var/log/messages, /var/log/syslog, /var/log/auth and other logfiles that appear relavent for something that might contain a clue.

Can you ssh into the target box OK? (not NX, just plain old ssh)

Are these three computers all on your LAN? Any possible router or firewall changes you might have made that may be interfering?

Try using the ssh key you have for your NX client to go directly to your target via ssh (not NX). e.g.,

ssh -vv -i the_key_file_name nx@target.domain

[edit]The option above is "dash vee vee", not "dash double-you" (sometimes that is hard to tell depending on your font in use)[/edit]

If this fails, and the -vv (verbose) output from ssh on your client side doesn't tell you what's going on, look for details of the session on the target in /var/log/auth.log (or syslog, or messages, or whatever other file your distro may be putting these in).

Note: ssh will mysteriously fail on you, and not tell you why, if you have too loose permissions on the target server. Your (actually the nx login's) $HOME directory on the target should be mode 755, under that .ssh should be 755, (better yet, 700), and your authorized_keys and/or authorized_keys2 file should be 600. Usually permissions problems give you a blatant failure, not a timeout, though.

cucolin@ 12-05-2008 11:59 AM

hi, I'm using centos 5:

1. file /var/log/nxserver.log is empty
2. file /var/log/messages displays logs about pure-ftp
3. file /var/log/syslog does NOT exist
4. file /var/log/auth does NOT exist
5. I CAN SSH to the target box
6. 2 computers are in the same LAN (Mac OS X & Linux) 1 (Windows vista) at another location. NO firewall/router changes
7. ssh -vv -i the_key_file_name nx@target.domain. i'm not sure how to do this,but i copy/paste the NX client key into a file in my local computer and then tried your command and i was able to login into the remote server.
8. i also did: /sbin/service freenx-server restart it went OK and still not able to connect.

thanks for the help

cucolin@ 12-06-2008 08:24 PM

hi, i decided to remove freenx-server and download/install the rpm from the nomachine website(i read that this should 'fix' things) now i get this error:
The NX service is not available or the NX access was disabled on host

not sure what to do anymore...thanks

haertig 12-07-2008 12:10 AM

I have only used the FreeNX server, not the NoMachine one.

Did you run "sudo /etc/init.d/nxserver start" or some similar command? Under FreeNX, there is no server per se, what the start/stop commands do is rename the authorized_keys2 file between normal and "authorized_keys2.disabled" (or something like that). I do not know what is required for the NoMachine server, not how it operates.

cucolin@ 12-08-2008 11:01 AM

first time i install it i got it using:
yum install freenx-server nx

it worked only the first time then i got the problem indicated above. now i tried installing it from here:
which is the free version too. are they different? it also says that i need to install the client as well at the server, did you do this as well?

when i do sudo /etc/init.d/nxserver start
i get:
Service already running.


haertig 12-08-2008 01:37 PM

They are different.

NoMachine came up with the NX server and made their source code available. FreeNX then made a GPL free version of the server. The function of the two servers is the same (although the NoMachine has a few extra features). Then later, NoMachine decided to make their server free for Linux (where before you have to pay for this). The NoMachine server uses libraries that come with their client (which has always been free) so that's why they tell you to also install the client. FreeNX does not have their own client, they've always just said "download the free NoMachine one". The FreeNX server is mostly written in shell. I imagine the NoMachine one is a binary executable. Since I am using FreeNX, I did not install any client software, because you don't need to with FreeNX. You only have to do that with NoMachine NX. And the NoMachine NX server setup may be different than the FreeNX setup. Never having used the NoMachine variety, I wouldn't know.

cam34 12-08-2008 02:53 PM

Are you running SSH on port 22 or have you changed this?
As for the installation of NoMachine NX, download the RPMs of the Client, the Node and the Server. Install the client first (rpm -i) then the node, then the server.


tail -f /var/log/messages
and try log in from another computer, post back the messages from the log file.


haertig 12-08-2008 04:07 PM


NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
NX> 280 Exiting on signal: 15
Your error here seems to say that you are failing basic ssh authentication. You haven't even gotten to the NX part yet. That's how I read it.

You are sure that you can ssh into this computer using the "nx" login?

cucolin@ 12-08-2008 04:25 PM

thanks haertig.
1. i did those steps in order and no luck.
2. i get error message from client: 'DSA key is corrupted or has been protected with a passphrase' this i not sure how to do, because when i created the user cocotuc i got:
sudo /usr/NX/bin/nxserver --useradd cocotuc
NX> 900 Setting password for user: cocotuc.
NX> 102 Password:
NX> 102 Confirm password:
NX> 110 Password for user: cocotuc added to the NX password DB.
NX> 900 Adding public key for user: cocotuc to the authorized keys file.
NX> 900 Verifying public key authentication for NX user: cocotuc.
NX> 900 Public key authentication succeeded.
NX> 301 User: cocotuc enabled in the NX user DB.
NX> 999 Bye.

does this means i have to copy/paste the public key in /home/cocotuc/.ssh/? I did that and got the above error msg.

3. output of tail -f /var/log/messages:
Dec 8 16:31:48 c693d85 NXSERVER-3.3.0-8[26046]: Cannot read from stdin: NX client disconnected before the 'bye' message: exiting cleanly 'NXShell::handleExitRequests'
Dec 8 16:47:22 c693d85 NXSERVER-3.3.0-8[28955]: Added password for user: cocotuc to the NX password DB. NXShell::handler_user_set_password NXShell 373
Dec 8 16:47:22 c693d85 NXSERVER-3.3.0-8[28955]: User 'cocotuc' logged in from ''. 'NXLogin::set'
Dec 8 16:47:24 c693d85 NXSERVER-3.3.0-8[28955]: User 'cocotuc' from '' logged out. 'NXLogin::reset'


cam34 12-09-2008 06:36 PM

How i do it is:
I setup NX to autenticate via system users instead of using NX Database.
I add:

AllowUsers nx myusername to: /etc/ssh/sshd_config
I then modify /usr/NX/etc/server.cfg
and set:
EnablePasswordDB = "0"
EnableUserDB = "0"

Then restart nxserver

Also is SSH running on port 22 or has this been changed?

cucolin@ 12-09-2008 08:49 PM

i removed nxserver, nx and the nxclient and will try again following these instructions:

they are supposed to work. i will follow your suggestions cam34 as well and keep you updated about this issue. its really painful installing/configuring nxserver! i would like to write a simple tutorial after i'm done with this.....thanks guys!

cucolin@ 12-10-2008 11:06 AM

SUCCESS! Those instructions work 100%!!!

thanks guys!

jefro 06-18-2011 02:32 PM

Which instructions worded?? I have only been lurking and wanted to know.

TLuck 06-06-2013 06:37 PM

I had the same problem.
And just added for iptables rule:

iptables -A INPUT-i lo-j ACCEPT
iptables -A OUTPUT-o lo-j ACCEPT

All times are GMT -5. The time now is 06:33 AM.