-   Linux - Software (
-   -   No text in framebuffer console (

TarrasQ 03-14-2004 07:26 PM

No text in framebuffer console
I recompiled my 2.6.4 kernel with console framebuffer support, installed id properly and modified grub.conf to add vga=791 as a parameter.

The problem is I see a 640x480 or something screen with the tux and a cursor moving as text should be running to the screen. I don't see any text, though.

I also tried with optional font support and a the first two fonts compiled inside the kernel. No change there.

Also after logging in, starting X and shutting X down the console is totally garbled with reddish nonsense (not even ASCII-garble).

I've got a GeForce 4 MX 440 and I've used the riva fb module. (Actually not as module but in the kernel.)

Any ideas how to at least see something more than a happy penguing in the console?

Pwnz3r 03-14-2004 09:23 PM

I think they wanted to confuse us, because you need the VESA VGA framebuffer driver instead of the Riva driver. Don't ask me why, but it works for me. As for no text, you did include the "append="splash=verbose"" line (if using LILO), right?

TarrasQ 03-15-2004 04:01 AM

Thanks, really! That worked for these and even a boot-time hardware-related problem I'm having... Didn't even have to try verbosing.

An other issue came up:
Now the screen won't print out the way it should. All modes end up showing the upper side of each row - four times! The lower sides must have gone too close to /dev/null or something. Plus 640 & 800 modes have a misplacement (either left or right) for every row (and the 4 x multiplications).

I've tried all the reso-color combinations from 640x480x8b to 1024x768x24b and turning some BIOS AGP options off.

All times are GMT -5. The time now is 10:15 AM.