Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-11-2005, 01:31 PM   #1
Registered: Mar 2005
Distribution: Gentoo
Posts: 232

Rep: Reputation: 30
No system sounds in KDE, but sound from amaroK

Hi, I have an annoying problem where I cannot get any sound out of KDE, I don't get any errors when I restart KDE's sound system (in the Control Center), but clicking 'Test Sound' gives nothing, and I have no system sounds (even though they're enabled). I do however get sound from amaroK (which I think is using the GStreamer plugin), so I know my sound system is configure properly. I think this issue maybe to do with aRTs, but I'm not sure.

If anyone has and ideas how to get sound from KDE, please speak up ()

Thanks in advance, Buck
Old 09-11-2005, 02:00 PM   #2
Registered: Dec 2004
Location: Atlanta
Distribution: Gentoo 2005.1, Ubuntu 5.10
Posts: 267

Rep: Reputation: 30
What engine is your amaroK using. It's my understanding that the GStreamer framework allows amarok to output directy to the kernel level alsa drivers, without needing to go through aRts first. You might also want to check set your audio output in the aRts control panel to the proper sound system, instead of autodetect.

Also, make sure that arts is actually running. If ps -A | grep artsd gives output it probably is.

Last edited by Valhalla; 09-11-2005 at 02:01 PM.
Old 09-11-2005, 02:32 PM   #3
Registered: Sep 2005
Location: So. Calif. USA
Distribution: F10 x64 & FC7
Posts: 64

Rep: Reputation: 15
Yep, I've found since moving from RH9 to FC4 I've had similar issues. Typically I'd get an error on boot up stating "invalid argument - sound being set to null".

I was able to get my sound working by:
-> I tried all the "audio devices" under control center>sound system>hardware. And found that "autodect" worked the best, [your setting may be different?].

-> I unchecked "Auto-Suspend" at the bottom of "General" and all my system notice sounds came up.

-> I ran kmixer" and made sure that "external amp" was enabled. One issue I had was after enabling the volume control [under "kmix configure>settings"], it disappear when I closed the program.
I found instead of closing the program, I right-clicked on the speaker icon and selected "hide mixer" and it's worked ever since. I wasn't able to find this info in Help so I just experimented.

-> I verified the settings mentioned above in "alsamixer" [run in terninal]. Tab to "all", arrow to output, and select "m" to mute or unmute.

-> Checked my "Blacklist" file [under /etc/hotplug/], and removed the driver for my soundcard. Use this with caution, there may be a binding issue, but have to say my sound works now.

-> Lastly I noticed in Linux, that the actual sound volume is between 85-100%, the sliders offer very little resolution. Many have found just turning them all the way up gave them sound...
Good Luck..

Last edited by Lnx805; 09-11-2005 at 02:36 PM.
Old 09-11-2005, 03:49 PM   #4
Registered: Mar 2005
Distribution: Gentoo
Posts: 232

Original Poster
Rep: Reputation: 30
Im not sure where to pipe my audio out to, I changed the audio device from auto detect to alsa, but still nothing...


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Have system sounds but no cd music sound cwhh Debian 2 11-24-2005 05:54 AM
Have system sounds but no cd music sound cwhh Linux - Newbie 2 11-24-2005 05:53 AM
Have system sounds but no cd music sound cwhh Linux - General 1 11-23-2005 11:13 PM
kde system sounds don't work RoaCh Of DisCor Linux - Software 0 12-11-2004 01:49 AM
KDE system sounds won't play gbj Linux - Software 4 10-28-2004 07:12 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:42 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration