LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-27-2004, 09:32 PM   #1
coyote399
Member
 
Registered: Feb 2004
Distribution: Debian Sarge
Posts: 30

Rep: Reputation: 15
No sound, using ADI AD1980 audio


I recently Installed Debian Sarge, and the sound is not working. The user guide to my motherboard (asus k8v deluxe) says it has "ADI AD1980 SoundMax 6-channel audio codec"

Since I am still very new to Linux, I don't really know how to get started fixing this.

Here are some outputs/configurations that may help (on another page, they are pretty long)

http://www.geocities.com/sadadwe22/asadld.txt

I would appreciate any help you guys can give me.
 
Old 02-29-2004, 12:17 PM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
What would be more useful, actually, is if you posted the results of typing "dmesg" in a terminal. That will show all the boot messages, so we can see if the sound module is actually loading, since modules.conf does appear to think that one exists.

Secondly, when you say "sound is not working", what do you mean? Does XMMS crash? Does KDE give an error message on start saying that the sound server could not be started? Or do sound apps appear to work properly, but you don't hear anything?

If the last-- which is a very common problem-- there is nothing wrong with your sound card, it is the mixer (which controls volume) that is misconfigured. Most distirbutions, for some unknown reason, default all the mixer channels to "Mute".

If this is your problem, open a terminal and type "aumix". Adjust the sound levels to something above 0 for all channels (especially PCM), save the changes and try again.

If this doesn't help, post back and we'll work on the next possibility (which would be installing the ALSA drivers, if you're curious ).

Hope this helps.
 
Old 02-29-2004, 08:47 PM   #3
coyote399
Member
 
Registered: Feb 2004
Distribution: Debian Sarge
Posts: 30

Original Poster
Rep: Reputation: 15
starhost:/home/jth# dmesg
Linux version 2.4.22-1-386 (herbert@gondolin) (gcc version 3.3.2 20030908 (Debian prerelease)) #9 Sat Oct 4 14:30:39 EST 2003
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000e4000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000001ff30000 (usable)
BIOS-e820: 000000001ff30000 - 000000001ff40000 (ACPI data)
BIOS-e820: 000000001ff40000 - 000000001fff0000 (ACPI NVS)
BIOS-e820: 000000001fff0000 - 0000000020000000 (reserved)
BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
511MB LOWMEM available.
ACPI: have wakeup address 0xc0001000
On node 0 totalpages: 130864
zone(0): 4096 pages.
zone(1): 126768 pages.
zone(2): 0 pages.
Kernel command line: BOOT_IMAGE=Debian_Linux root=303
Initializing CPU#0
Detected 2002.606 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 3997.69 BogoMIPS
Memory: 512428k/523456k available (1031k kernel code, 10640k reserved, 442k data, 76k init, 0k highmem)
Dentry cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode cache hash table entries: 32768 (order: 6, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer cache hash table entries: 32768 (order: 5, 131072 bytes)
Page-cache hash table entries: 131072 (order: 7, 524288 bytes)
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
CPU: L2 Cache: 1024K (64 bytes/line)
CPU: After generic, caps: 078bfbff e1d3fbff 00000000 00000000
CPU: Common caps: 078bfbff e1d3fbff 00000000 00000000
CPU: AMD Athlon(tm) 64 Processor 3200+ stepping 08
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
ACPI: Subsystem revision 20030813
ACPI: Interpreter disabled.
PCI: PCI BIOS revision 2.10 entry at 0xf0031, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: ACPI tables contain no PCI IRQ routing entries
PCI: Probing PCI hardware (bus 00)
PCI: Using IRQ router default [1106/3227] at 00:11.0
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
pty: 256 Unix98 ptys configured
Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
Linux IP multicast router 0.06 plus PIM-SM
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 3180 blocks [1 disk] into ram disk... done.
Freeing initrd memory: 3180k freed
VFS: Mounted root (cramfs filesystem).
Freeing unused kernel memory: 76k freed
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide: late registration of driver.
VP_IDE: IDE controller at PCI slot 00:0f.1
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: VIA vt8237 (rev 00) IDE UDMA133 controller on pci00:0f.1
ide0: BM-DMA at 0xfc00-0xfc07, BIOS settings: hdaMA, hdbio
ide1: BM-DMA at 0xfc08-0xfc0f, BIOS settings: hdcMA, hddio
hda: WDC WD1200JB-00EVA0, ATA DISK drive
blk: queue e0823dc0, I/O limit 4095Mb (mask 0xffffffff)
hdc: CW099D ATAPI CD-R/RW, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=14593/255/63, UDMA(100)
Partition check:
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4
Journalled Block Device driver loaded
hda: attached ide-disk driver.
hda: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=14593/255/63, UDMA(100)
/dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4
VFS: Can't find ext3 filesystem on dev ide0(3,3).
VFS: Can't find ext2 filesystem on dev ide0(3,3).
Unable to identify CD-ROM format.
reiserfs: found format "3.6" with standard journal
reiserfs: checking transaction log (device ide0(3,3)) ...
for (ide0(3,3))
ide0(3,3):Using r5 hash to sort names
Adding Swap: 1261092k swap-space (priority -1)
Real Time Clock Driver v1.10e
hdc: attached ide-cdrom driver.
hdc: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,2), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
parport0: PC-style at 0x378 [PCSPP]
parport0: Printer, HEWLETT-PACKARD DESKJET 3820
lp0: using parport0 (polling).
spurious 8259A interrupt: IRQ7.
dmfe: Davicom DM9xxx net driver, version 1.36.4 (2002-01-17)
eth0: Davicom DM9009 at pci00:0e.0, 00:01:53:82:0a:e3, irq 5.
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Via 686a/8233/8235 audio driver 1.9.1-ac3
via82cxxx: Six channel audio available
PCI: Setting latency timer of device 00:11.5 to 64
via82cxxx: timeout while reading AC97 codec (0xAA0000)
ac97_codec: AC97 Audio codec, id: ADS112 (Unknown)
via82cxxx: board #1 at 0xC800, IRQ 5
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 19:14:42 Sep 27 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: USB UHCI at I/O 0xc400, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xc000, IRQ 10
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xb800, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 3
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: USB UHCI at I/O 0xb400, IRQ 11
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 4
hub.c: USB hub found
hub.c: 2 ports detected
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
hub.c: new USB device 00:10.0-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x50d/0x805) is not claimed by any active driver.Linux Kernel Card Services 3.1.22
options: [pci] [cardbus] [pm]
ds: no socket drivers loaded!
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)

As for the symptoms,

xmms says "couldn't open audio...please check: your soundcard is configured properly, you have the correct audio plugin selected, no other program is blocking the soundcard"

looking at a flash movie that I know has sound is silent.

Also, watching a video in mplayer had not sound.


The only thing with the "mute button" check in my volume control is the mic. The command "aumix" dosen't work.

Last edited by coyote399; 02-29-2004 at 08:49 PM.
 
Old 03-01-2004, 01:06 AM   #4
eaglegst
Member
 
Registered: Dec 2003
Location: Australia
Distribution: Woody, Sarge, Sid
Posts: 83

Rep: Reputation: 15
Seems your sound card is well detected by the kernel and functioning.

Since you are on Sarge, I assume that you are using GNOME. When you click on the speaker icon on the right-top panel, what does it say? Is it something like "Couldn't open mixer device /dev/sound/mixer"?

If it is, you need to add your user account into group "audio" by editing /etc/group, relogin, and adjust the mixer by right&left-clicking that speaker icon afterwards.

By the way, did you connect your speaker to an onboard sound card, which is what the kernel detects and loads a driver for?
I do not really know if your ADI card is built-in or not as I have very little idea about hardwares

Last edited by eaglegst; 03-01-2004 at 01:14 AM.
 
Old 03-01-2004, 09:29 AM   #5
coyote399
Member
 
Registered: Feb 2004
Distribution: Debian Sarge
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
Since you are on Sarge, I assume that you are using GNOME. When you click on the speaker icon on the right-top panel, what does it say? Is it something like "Couldn't open mixer device /dev/sound/mixer"?
Well, that happened before I started this thread. While I was trying to fix it myself, I did "apt-get install alsa" and it went away.


Quote:
f it is, you need to add your user account into group "audio" by editing /etc/group, relogin, and adjust the mixer by right&left-clicking that speaker icon afterwards.
I have never edited this before
these two lines look like what I want.

audio:x:29:
jth:x:1000:

what should I do with them?

Quote:
By the way, did you connect your speaker to an onboard sound card, which is what the kernel detects and loads a driver for?
I do not really know if your ADI card is built-in or not as I have very little idea about hardwares
I am pretty sure it is plugged into the round light green hole on the side (if you really want, I can pull the case out and check, but that would take a bit of work). It works in windows, so I'm pretty sure thats not the problem

http://www.users-side.co.jp/images/p...d/asus_k8v.jpg

Last edited by coyote399; 03-01-2004 at 09:31 AM.
 
Old 03-01-2004, 09:47 AM   #6
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Quote:
xmms says "couldn't open audio...please check: your soundcard is configured properly, you have the correct audio plugin selected, no other program is blocking the soundcard"
This usually means that XMMS is using the wrong I/O plugin. Open XMMS, right-click on a titlebar and choose Options=>Preferences. Change the Output plugin to whatever it is not: if it's currently ALSA (but doesn't work), then change it to OSS, if it's OSS (but doesn't work), then change it to ALSA. If neither of them works, and you are using GNOME, and esd is running (you can check that by right-clicking any System Monitor on your panel and choosing "Open System Monitor" or choosing System Monitor from wherever it might be in the menu, then looking for "esd"), then change the plugin to eSound.

Quote:
looking at a flash movie that I know has sound is silent.

Also, watching a video in mplayer had not sound.

The only thing with the "mute button" check in my volume control is the mic. The command "aumix" dosen't work.
This is definitely a mixer problem. And if you have installed ALSA, then you're trying to unmute the wrong mixer. Type 'alsamixer' into a terminal and raise the volume levels for everything. You can also use the 'alsactl store' command after that to save the mixer settings, but you have to su to root before that command will work-- and the only real benefit of it is getting rid of a boot message that the saved config file is not present (the settings are stored anyway somehow).
 
Old 03-01-2004, 11:23 AM   #7
coyote399
Member
 
Registered: Feb 2004
Distribution: Debian Sarge
Posts: 30

Original Poster
Rep: Reputation: 15
Quote:
This usually means that XMMS is using the wrong I/O plugin. Open XMMS, right-click on a titlebar and choose Options=>Preferences. Change the Output plugin to whatever it is not: if it's currently ALSA (but doesn't work), then change it to OSS, if it's OSS (but doesn't work), then change it to ALSA. If neither of them works, and you are using GNOME, and esd is running (you can check that by right-clicking any System Monitor on your panel and choosing "Open System Monitor" or choosing System Monitor from wherever it might be in the menu, then looking for "esd"), then change the plugin to eSound.
I just tried all 3 plugins, none of them fix the error


Quote:
This is definitely a mixer problem. And if you have installed ALSA, then you're trying to unmute the wrong mixer. Type 'alsamixer' into a terminal and raise the volume levels for everything. You can also use the 'alsactl store' command after that to save the mixer settings, but you have to su to root before that command will work-- and the only real benefit of it is getting rid of a boot message that the saved config file is not present (the settings are stored anyway somehow).
starhost:/home/jth# alsamixer

alsamixer: function snd_ctl_open failed for default: No such device
 
Old 03-02-2004, 06:15 PM   #8
coyote399
Member
 
Registered: Feb 2004
Distribution: Debian Sarge
Posts: 30

Original Poster
Rep: Reputation: 15
anymore ideas?
 
Old 03-05-2004, 11:29 PM   #9
coyote399
Member
 
Registered: Feb 2004
Distribution: Debian Sarge
Posts: 30

Original Poster
Rep: Reputation: 15
one last bump....
 
Old 04-06-2004, 01:52 AM   #10
FunBox
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Hey coyote399, I've solved this problem. I'm also using Debian Sarge on a K8V Deluxe. I installed kernel-image-2.6.4 and the sound would not work. Linux 2.6.4 comes with ALSA 1.0.2c. I noticed in the changelog for ALSA 1.0.3 (announced on 2004-02-29) the following line:
Quote:
- fixed the dxs support of ASUS K8V.
In order to get ALSA 1.0.3, I compiled my own kernel. Here's a rough sketch of the steps:[list=1][*]apt-get install kernel-source-2.6.4 alsa-source[*]cd /usr/src[*]tar xfj kernel-source-2.6.4.tar.bz2[*]tar xfj alsa-driver.tar.bz2[*]Configure kernel to turn off ALSA support but leave on general sound support.[*]make-kpkg --initrd kernel_image modules[*]dpkg -i kernel-image-2.6.4_10.00.Custom_i386.deb alsa-modules-2.6.4_1.0.3-1+10.00.Custom_i386.deb[*]update-grub[*]reboot[/list=1]
That was enough to fix it for me. Good luck and welcome to Linux.

Zack
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound with ADI AD1980 integrated sound card Comptalk Red Hat 2 02-07-2005 05:08 AM
No sound, using ADI AD 1980 audio cquedugdylp Linux - Software 0 12-06-2004 08:21 AM
Strange problems with ADI AD1980 Soundcard Dipp Linux - Hardware 3 03-07-2004 03:55 PM
ADI AD1980 Sound not working Mandrake 9.0 Relja Linux - Hardware 22 02-28-2004 08:48 AM
ADI AD1980 driver for Mandrake? sengler Mandriva 1 08-28-2003 08:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration