LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   No sound until I mixer/volume control (https://www.linuxquestions.org/questions/linux-software-2/no-sound-until-i-mixer-volume-control-88552/)

jimdaworm 09-02-2003 04:12 PM

No sound until I mixer/volume control
 
I dont have any sound until I load mixer. I dont need to change any of the volumes or anything but the sound just comes on as soon as I load up the mixer.

Any Ideas?
Adam

MasterC 09-02-2003 09:20 PM

Which mixer? Might be that you aren't loading a sound server? Which distro?

Are you using ALSA?

If nothing else, maybe by sticking:
/path/to/sound/server
In your /etc/rc.local (does RH still have that?)

So that during boot up, the server is started.

Just an idea...

Cool

jimdaworm 09-03-2003 12:49 PM

Hey C I am using Red Hat 9 Kernal 2.4.20-9 (its under my dist info) I dont know anything about what sound server I am using or anything, just the standard stuff that came with my dist... what can I type to give you more info on this?

I am guessing the below is not really the actually literally what i am supposed to put in my In your /etc/rc.local (which RH still has). I dont know where my sound server is and even what one I am using!

/path/to/sound/server
:cry:
Adam

MasterC 09-03-2003 09:32 PM

Hmm... Probably easier to tell by which mixer. However, if this is ANY mixer, then maybe it's simply ANY server you need to start...

Code:

bash-2.05a$ whereis esd
esd: /usr/bin/esd /usr/etc/esd.conf /usr/include/esd.h /usr/man/man1/esd.1.gz /usr/share/man/man1/esd.1.gz

That's the ESound server daemon, then you have:
Code:

bash-2.05a$ whereis artsd
artsd: /opt/kde/bin/artsd

Which is KDE's sound server.

HTH

Although, maybe (and probably actually) you'll have better luck at trying ALSA and getting that going for your card.

Cool

geethtk 09-03-2003 10:55 PM

:Pengy: I too have the same problem with my Mandrake Linux 9.1.The srats server does not start logining onto KDE it says some permission error.I can get it working only after again setting the driver for sound as root.It needs to be repeated all the time I login to KDE .Please some one help me with it.

Geeth:cry:

jimdaworm 09-04-2003 04:26 PM

I have installed ALSA
 
I have installed ALSA ummm when I type out those commands I get very similar results from yours... what does that tell me? What would be the command line command to set the volumes etc.... I hope there I wont have caused any trouble just installed ALSA when what ever it was before installed was there.

Thanks
Adam


All times are GMT -5. The time now is 01:26 AM.