LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-26-2004, 01:29 PM   #1
The Karl
LQ Newbie
 
Registered: Sep 2004
Location: Sweden
Distribution: Fedora 11
Posts: 26

Rep: Reputation: 15
Unhappy no sound playing mp3 with xmms


Hi guys!

A few days ago I found a thread about my problem, I thought. but it didn't quite help me...

When I play mp3's with xmms I get no sound even if the player is playing. (I have installed the mp3-package). Thers's nothing wrong with my sondcard because I get sounds while playing games etc. In the thread I found (above) some guys said that the volume bars sometimes where at the bottom, but I have gone through all the bars in the volume control so that can't be the problem.
The strange part of my problem is that when I play mp3's in xmms as root everything is working normally. I've got no idea how to solve this.

btw. I get no sound playing audio-cd's either...
 
Old 09-26-2004, 01:37 PM   #2
masand
LQ Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there


try this also
get the latest xmms package fro xmms.org

and install that by --force option like this

rpm -ivh --force xmms-1.2.10-i386.rpm

regards
 
Old 09-26-2004, 03:47 PM   #3
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
This sounds like a permissions problem. Add your user account to the "audio" group
 
Old 09-27-2004, 12:14 PM   #4
The Karl
LQ Newbie
 
Registered: Sep 2004
Location: Sweden
Distribution: Fedora 11
Posts: 26

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by vectordrake
This sounds like a permissions problem. Add your user account to the "audio" group
This sounds promising... but how do I add my account to the audio group??
 
Old 09-27-2004, 03:26 PM   #5
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
If FC has a control panel of any sort, it may be as simple as accessing the "users" dialogue as root and checking a box under the user you need to add to a certain group. "man adduser" and "man useradd" should bring this answer to light for you (good idea to read it, even though I'm gonna show you:
Code:
adduser <your username> audio
or you may have to
Code:
useradd -G audio <your username>
or edit /etc/group and add your username to the line which denotes the owners of the audio group.
 
Old 09-28-2004, 03:20 AM   #6
The Karl
LQ Newbie
 
Registered: Sep 2004
Location: Sweden
Distribution: Fedora 11
Posts: 26

Original Poster
Rep: Reputation: 15
I've tried everything you've said but when I run the terminal commands I get a message "unknown group audio"... I can't find audio in etc/group and it's not in the users and groups dialogue either... strange...
 
Old 09-28-2004, 09:32 PM   #7
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Confusing. This thread suggests that this may be something to do with the sound server of the window manager interfering. See if killing that off restores your sound.
 
Old 09-29-2004, 04:29 PM   #8
The Karl
LQ Newbie
 
Registered: Sep 2004
Location: Sweden
Distribution: Fedora 11
Posts: 26

Original Poster
Rep: Reputation: 15
no... it doesn't help... My problem seems to be specific for xmms... I can play mp3s and watch movies with mplayer without a problem... I don't like mplayer very much though...
 
Old 09-29-2004, 04:43 PM   #9
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
You might want to play with juk, rhapsody, or amorok. They're nice jukeboxes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
xmms playing cds but no sound anindyanuri Linux - Software 4 05-07-2005 11:45 PM
fast forward mp3 playing in xmms for fedora core 1 like_gobeawan Linux - Newbie 3 10-18-2004 09:51 AM
Spikes, but no sound playing MP3 in XMMS mike270 Fedora 13 08-09-2004 08:03 AM
XMMS is playing but no sound is produced Spasmolytic Linux - Hardware 6 03-08-2004 10:07 AM
xmms player playing mp3 too fast vpitroda Linux - Newbie 3 02-14-2002 11:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration