-   Linux - Software (
-   -   No sound on Ubuntu 6.06 - one for the GURU's!! (

3saul 06-09-2006 05:11 AM

No sound on Ubuntu 6.06 - one for the GURU's!!
I have an Echoaudio darla20 card which worked fine in Breezy...but not in dapper.

Here is the output of lsmod | grep snd
snd_seq_dummy 3972 0
snd_seq_oss 39136 0
snd_seq_midi 9248 0
snd_rawmidi 27072 1 snd_seq_midi
snd_seq_midi_event 7520 2 snd_seq_oss,snd_seq_midi
snd_seq 58704 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_seq_device 9452 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_darla20 24580 0
snd_pcm_oss 45888 0
snd_mixer_oss 20160 1 snd_pcm_oss
snd_pcm 96420 2 snd_darla20,snd_pcm_oss
snd_timer 27044 2 snd_seq,snd_pcm
snd 60388 10 snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_seq_device,snd_darla20,snd_pcm_oss,snd_mixer_oss,s nd_pcm,snd_timer
soundcore 10784 1 snd
snd_page_alloc 11336 2 snd_darla20,snd_pcm

As you can see it has in fact loaded the driver. But when I do a cat /proc/asound/cards I get:
No soundcard. Also, trying to run echomixer says that it can't find an echo card. HAL can see it:

udi = '/org/freedesktop/Hal/devices/pci_1057_1801'
info.udi = '/org/freedesktop/Hal/devices/pci_1057_1801' (string)
linux.subsystem = 'pci' (string)
linux.hotplug_type = 1 (0x1) (int)
pci.subsys_product = 'Darla' (string)
pci.subsys_vendor = 'Echo Digital Audio Corporation' (string)
info.product = 'DSP56301 Digital Signal Processor' (string)
pci.product = 'DSP56301 Digital Signal Processor' (string)
info.vendor = 'Motorola' (string)
pci.vendor = 'Motorola' (string)
pci.device_protocol = 0 (0x0) (int)
pci.device_subclass = 128 (0x80) (int)
pci.device_class = 4 (0x4) (int)
pci.subsys_vendor_id = 60608 (0xecc0) (int)
pci.subsys_product_id = 16 (0x10) (int)
pci.vendor_id = 4183 (0x1057) (int)
pci.product_id = 6145 (0x1801) (int)
pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0e.0/0000:02:06.0' (string)
info.parent = '/org/freedesktop/Hal/devices/pci_10de_ed' (string)
info.bus = 'pci' (string)
linux.sysfs_path_device = '/sys/devices/pci0000:00/0000:00:0e.0/0000:02:06.0' (string)
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:0e.0/0000:02:06.0' (string)

Any other idea's?

Tuttle 06-10-2006 03:17 PM

hi, did alsaconf find a card?

It's entry should appear in /sys/bus/pci/drivers at least

3saul 06-11-2006 04:12 AM

well alsaconf doesn't seemt to exist anymore....but yes
:/sys/bus/pci/drivers/Echoaudio Darla20$

...does exist!!! What should I do now?

Tuttle 06-11-2006 09:23 AM

Well, in alsa the numbering system is card 1 = hw0,0 card 2 = hw0,1 and so on. Usually you can send stuff to /dev/dsp but if that doesn't exist you will need to send stuff to /dev/snd/[name of device] or, more likely, /dev/sound/[name of device] usually named "audio" or "mixer" or similar, you just need to work out where to send the sound to! I wish I could help further, please look at the devices II mentioned and see if you can get any sound mixing frontends to use them (eg. alsamixer or gnome-volume-control or kmixer or whatever). Post back if you get stuck.

3saul 06-11-2006 09:54 PM

It seems that the problem is that alsa hasn't configured the card correctly..

alsamixer: function snd_ctl_open failed for default: No such device
- using device default
- using device default
ALSA lib pcm_hw.c:1355:(_snd_pcm_hw_open) Invalid value for card
ALSA lib pcm_dmix.c:862:(snd_pcm_dmix_open) unable to open slave
/proc/asound$ ls
card1 cards devices modules oss pcm seq timers UART version
saul@saul-desktop:/proc/asound$ cat cards
1 [UART ]: MPU-401 UART - MPU-401 UART
MPU-401 UART at 0x330, irq 5
:/dev/snd$ ls
controlC1 midiC1D0 seq timer

My card is not listed here as you can see...and it should be if it has been correctly configure/recognized/installed. Also note that /proc/asound/card1 is the MPU401...

drspock 06-11-2006 10:46 PM

I had the same problem a few weeks ago, I did an upgrade from breezy. I pulled out all the stops, no sound so I re-installed breezy then 6.06 final came out I upgraded and the sound worked fine, go figure.

3saul 06-12-2006 02:21 AM

Unfortunately I'm not so recommendation for people wanting to try out Dapper....wait until they fix the sound issues because I'm not the only one. Canonical better give this some attention or they'll start to lose some users to other distros.....and I myself will only wait so long with no music until I install FC5.

Tuttle 06-12-2006 04:59 AM

That's a shame, I heard they really did a good job of it. Do you have a development env.? You could try dl'ing the alsa driver, utils and libs, compile it and see if that fixes things?!
Remove the originals first, or better still, use checkinstall to make your own .debs

3saul 06-12-2006 11:01 PM

Ok all is finally working. The problem was that the firmware-helper could not load the firmware for my card correctly (looking in the wrong location). Thanks for all your help.

BTW...I take back what I said about Ubuntu :)

Yellius 07-18-2006 03:52 AM

Darla20 problems
Hi all,

My Echo Darla 20 doesn't seem to work in 6.06 either. Only in my case the driver is not even loaded.

lsmod | grep snd:
snd_mpu401 8968 0
snd_mpu401_uart 9792 1 snd_mpu401
snd_rawmidi 31072 1 snd_mpu401_uart
snd_seq_device 10704 1 snd_rawmidi
snd_intel8x0 37864 2
snd_ac97_codec 109820 1 snd_intel8x0
snd_ac97_bus 3456 1 snd_ac97_codec
snd_pcm_oss 58784 0
snd_mixer_oss 19968 1 snd_pcm_oss
snd_pcm 104008 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 28424 1 snd_pcm
snd 68000 14 snd_mpu401,snd_mpu401_uart,snd_rawmidi,snd_seq_device,snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mi xer_oss,snd_pcm,snd_timer
soundcore 12640 1 snd
snd_page_alloc 13328 2 snd_intel8x0,snd_pcm

It is there however:
lspci | grep Motorola
0000:05:08.0 Multimedia controller: Motorola DSP56301 Digital Signal Processor (rev 02)

The strange thing is that I can't find the module snd-darla20 anywhere on my harddisk either. I'm running the K8 SMP kernel and the required kernel modules for any of the echo cards are not to be found in the /lib/modules dir.

Does anyone have an idea on how to fix this? The only thing I can come up with is recompiling alsa from source. reinstalling the packages doesn't work and I can remove it either since it then wants to remove ubuntu-minimal and -base as well.

3saul 07-18-2006 07:40 PM

Ok I got mine working. The first thing you need to do is install alsa by compiling source. You'll need to install the driver/firmware at minimum. What you may then find, as I did, is that it can't load the firmware file (you'll see an error on startup indicating that it can't find the file to load). All you need to do is move the .fw file to the correct location and all should be fine.

Yellius 07-19-2006 03:09 AM

mine works too
Hi 3saul,

Thanks! I already did the same you suggest, following this guide:
<sorry for some stupid reason I'm not allowed to post a link. Go the the ubuntuforums dot org site, video&sound, "comprehensive sound problem solutions guide", thread 205449>
and choosing the second option "Using drivers from alsa-project".

In case anyone else runs into trouble, don't forget to install the alsa-firmware from the alsa-project website first!

Finally I had to do a reboot after the driver make/make install, both a modprobe and a depmod had the darla20 kernel object complaining about version mismatches.


Tuttle 07-19-2006 08:28 AM

Hi Yellius, you will be able to post as many links as you like after you've done a few more posts! This is done to stop spammers I think.
Oh, and well done all!

All times are GMT -5. The time now is 10:49 AM.