-   Linux - Software (
-   -   No sound in video recorded with mencoder (

sammckee 05-24-2007 05:47 PM

No sound in video recorded with mencoder
Like the thread title says. :)

I'm using a Hauppauge WinTV with the audio out wired into the audio in of the sound card. I'm trying to record a VHS tape.

I do hear sound when I watch it with tvtime. I use this command to record a clip:

mencoder tv:// -tv driver=v4l2:norm=ntsc:input=0:width=640:height=480 -of avi -ovc lavc -lavcopts vcodec=mpeg2video:vbitrate=4000 -lavcopts acodec=mp2:abitrate=96 -oac lavc -o record.avi -endpos 0:15

I even hear the sound while mencoder is recording my clip, but when I play the resultant .avi file it's a silent movie. I have confirmed that I can hear sound in other .avi files played with mplayer.

jschiwal 05-24-2007 06:17 PM

I wonder if the order of the arguments is important.
-oac lavc -lavcopts acodec=mp2:abitrate=96

Try giving the lavcopts after selecting the lavc codec.

sammckee 05-24-2007 06:27 PM

Didn't help.

This is what it says at the end of recording, btw:

Audio stream: 96.000 kbit/s (11999 B/s) size: 179931 bytes 14.994 secs
v4l2: 453 frames successfully processed, 0 frames dropped.

I'm mystified. It says it recorded sound. I can actually hear the sound while it's recording (sound stops when mencoder exits), but I get a silent movie.

lpn1160 05-24-2007 08:10 PM

Have you tried extracting the audio and looking at it in audacity. Could it be very low volume that needs to be normalized??
I have the same card & heres the command line I use:

mencoder -tv norm=NTSC:driver=v4l2:width=352:height=480:input=2:fps=30000/1001 tv:// -oac lavc -ovc lavc -of mpeg -mpegopts format=dvd -vf harddup -srate 48000 -af lavcresample=48000 -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=6000:vbitrate=4000:keyint=15:acodec=mp2:abitrate=192 :aspect=4/3 -o capture.mpg

sammckee 05-25-2007 09:41 PM

Here's what it looks like when I import the file into audacity.

When I play it in audacity I can hear some faint, intermittent squeaking sounds.

sammckee 05-26-2007 06:15 PM

Okay, I'm a 'tard. My mixer settings were bad.

However. ever with the input settings correct and set to max volume, I now get a video with very, very quiet sound.

All times are GMT -5. The time now is 08:23 AM.