LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-29-2008, 08:12 PM   #1
gilbertt
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Ubuntu 6. 06.2 LTS 'Dapper'
Posts: 23

Rep: Reputation: 15
No sound from mplayer or realplayer when playing audiio streams


Hi all,

Ever since logging in this evening I've had the following sound issues:

-on trying to open a BBC stream from Firefox, got the message: 'Could not find an appropriate hxplay or realplay in the system path to use as an embedded player'. Did 'aboutlugins' in Firefox which showed that 'Helix DNA Plugin: RealPlayer G2 Plug-In Compatible' is installed.

-saved the bbc .ram file and tried to open it with RealPlayer. The buffer loads and the timer starts running, so I presume its processing the stream, but no sound. In the past the radio 4 stream would just automatically open in standalone RealPlayer

-tried running mplayer to play some other radio streams from the command line with an alias command like I usually do. But again no sound, though mplayer appears to be processing the stream as it fires up normally and the timer, cache indicator etc are active.

-tried to play the saved .ram file with Amarok, but got the message 'There is no available decoder'

-with mp3 playback on Amarok sound output is fine.

The KDE kicker bar disappeared as well. Fixed that but no idea why any of this is happening...

Help much appreciated
 
Old 01-30-2008, 01:36 PM   #2
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31
Have you tried VLC ?

David
 
Old 01-31-2008, 05:41 AM   #3
gilbertt
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Ubuntu 6. 06.2 LTS 'Dapper'
Posts: 23

Original Poster
Rep: Reputation: 15
Libraries?

Hi David,

Thanks for the tip. It worked a treat - I installed vlc and now mplayer and realplayer work fine! Is it because all three share the libraries that came with vlc?

libdc1394-13
libdvbpsi4
libdvdnav4
libgsm1
libtar
libwxgtk2.6-0
libxosd2

Really curious as to why it stopped in the first place, and which libraries are reponsible so I can uninstall vlc and keep what I need.

Gilbert
 
Old 01-31-2008, 08:42 AM   #4
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31
I don't know about how an uninstall would work, it's not a large program, disk space wise. They do pack every codec under the sun in though, so you have the best chance of whatever media you are hoping to play, actually play.

The others do probably do use the libs that vlc had the courage to include.

Good luck....

David
 
Old 02-05-2008, 07:05 AM   #5
gilbertt
LQ Newbie
 
Registered: Apr 2004
Location: London, UK
Distribution: Ubuntu 6. 06.2 LTS 'Dapper'
Posts: 23

Original Poster
Rep: Reputation: 15
Problem solved

Hey bud,

Thanks for replying.

The problem resurfaced. Found out eventually that the KDE sound server system was hogging audio resources and had to be turned off from system preferences.

Viva Linux!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Realplayer misery - won't uninstall; Realplayer streams trying to play in Kaffeine brianeanna Linux - Desktop 1 02-16-2007 05:01 PM
Audio streams? NPR? Helix? MPlayer? RealPlayer? sofasurfer Linux - Software 3 04-05-2006 05:29 PM
Buzzy Sound when Playing MGEG's in MPlayer 1.0pre5 in SuSE 9.1 nocturne SUSE / openSUSE 2 10-17-2004 09:39 AM
MPlayer playing mov: Audio no sound jpbarto Linux - Software 1 05-07-2003 10:22 PM
Capturing Realplayer Streams (rtsp) Help gbrad Linux - Software 1 04-07-2003 08:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration