-   Linux - Software (
-   -   No Real Player Sound after Flash Player (

hroit 01-07-2007 11:03 AM

No Real Player Sound after Flash Player
I use Real Player and Firefox and what I think is its Flash module on Ubuntu.

Each one of the above, Real, Firefox and Flash, works a treat on its own.

When I try to play an audio segment after having played a Flash segment (on youtube, say), the player will launch, will seem to play, but will give no sound.

In order to play Real clips after Flash, I therefore have to restart the Gnome Desktop Manager.

I have installed alsa-oss, and have set the Firefox configuration from FIREFOX_DSP="none"
to FIREFOX_DSP="aoss".

What can I do?



teckk 01-08-2007 07:18 AM

Sounds like flash or mplayer browser plugin is holding onto your sound device. I've seen this happen on Linux many times.

You can wait for a few min for the process to die or kill the process manually. Closing the browser window may also kill it. Run "top" and see if there is an instance of mplayer or flash running, then use kill to kill the process ID.

Also look at pkill

Usually it is mplayer plugin that holds onto the sound device.

Sometimes Firefox is bad about that too. Close the browser.

Greenfuse 01-08-2007 07:31 AM

Until you get a proper answer you might find it quicker to run alsaconf from the command line, rather than restart the desktop. With Ubuntu the command is probably

sudo alsaconf
This usually sorts out sound problems.

Edit - Sorry teckk, I was slow answering and missed your post

hroit 01-15-2007 11:57 AM

no such luck
Thanks a bunch, Teckk and Greenfuse.

I've tried the suggested fixes and, I'm sorry to say, to no avail.

There seems to be no 'alsaconf' in Ubuntu.

When I 'top' to find the process concerned, I can't see anything called 'flash', so I can't 'kill' any process.

I should finally add that, strangely, the other user account on my system does not suffer from the same problem...

Greenfuse 01-16-2007 02:05 PM

I am surprised you can't find alsaconf, it is standard on any Distro I have tried.
On my Gentoo I find it in /usr/sbin/alsaconf Try looking for it

sudo updatedb
locate alsaconf
It is part of the alsa-utils package - check if it is installed. Search for alsa-utils in Synaptic.

All times are GMT -5. The time now is 12:27 AM.