LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   no python module base.g? (https://www.linuxquestions.org/questions/linux-software-2/no-python-module-base-g-278118/)

hcgernhardt 01-15-2005 12:16 PM

no python module base.g?
 
Folks---

I have compiled and installed hplip 0.8.4, and am slightly frustrated by the following when I try to open the toolbox:

Traceback (most recent call last):
File "/usr/hplip/toolbox", line 32, in ?
from base.g import *
ImportError: No module named base.g

Any ideas as to what I am missing?

Thanks,

Henry C. Gernhardt, III
hcgernhardt@hotmail.com

coniptor 04-23-2018 12:40 AM

Cause and Solution
 
I was having trouble printing and hadn't dug deeper into it until today.
I searched and turned up this link: https://www.finninday.net/wiki/index.php/Cups_printing
The issue at stated at the link was the hplip was not installed. It had been.
I had hplip-libs and hplip-common when I checked, and I didn't recall uninstalling hplip my self so I'm guessing a previous rpm script did for some reason.
Anyway, installed hplip hplip-gui which also pulled in python-reportlab and restarted cups and I was able to print a test page across the network to my network printer.
Try re-installing hplip.

teckk 04-24-2018 09:03 AM

Why did you compile that from source. Not in your repo?
Code:

pacman -Si hplip
Repository      : extra
Name            : hplip
Version        : 3.17.11-1
Description    : Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and
                  some LaserJet
Architecture    : x86_64
URL            : http://hplipopensource.com
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : python-dbus  ghostscript  net-snmp  foomatic-db-engine
Optional Deps  : cups: for printing support
                  sane: for scanner support
                  xsane: sane scanner frontend
                  python-pillow: for commandline scanning support
                  python-reportlab: for pdf output in hp-scan
                  rpcbind: for network support
                  python-pyqt5: for running GUI and hp-toolbox
                  python-gobject: for running hp-toolbox
                  libusb: for advanced usb support
                  wget: for network support
Conflicts With  : None
Replaces        : None

https://developers.hp.com/hp-linux-i...nting/gethplip
Version on hp website is 3.18, and you compiled .8, why?
Quote:

Any ideas as to what I am missing?
Yes, line 32 of /usr/hplip/toolbox is "load everything from a module named base.g" You don't have that installed.

I advise you to take your email address off of the forum unless you want to get spammed by who knows what.

Edit: Oh Shoot, Old thread, didn't see that.


All times are GMT -5. The time now is 10:49 AM.