LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-22-2004, 12:49 PM   #1
drowstar
Member
 
Registered: Apr 2004
Location: Germany
Distribution: Slackware, Gentoo, Fedora
Posts: 205

Rep: Reputation: 30
No icons in kde after uninstalling default icon set


Hello everyone,
I have just gotten myself into a real mess and I hope someone can help me get out.

Here's what I did:
I noticed that I had some icon themes installed that I did not want (they seem to be installed with a standard kde installation). So, I uninstalled them. It wouldnt work as normal user, so I did "kdesu kcontrol" and removed them as root. Plus, I installed Crystal SVG 1.0 as root also AND removed beta1, which was the selected theme as a normal user AND root at the time (I guess this is, where everything started).
When I went back to chose an icon set as normal user, the new Crystal SVG did not show up (it turns out, root removed the previous version from the system directory (/usr/kde/3.2/share/icons/), but installed the new one into root's home directory). I was afraid to loose all my icons, so I did what seemed logical to me: installed Crystal as normal user. It worked, too, but when I applied the changes, all icons indeed disappeared.

I did some digging. Here is what I found:
1) root installs in his home directory (yes, I mentioned that before)
2) the default.kde link pointed to a non existing theme (I had just removed that), pointing it to an existing one didn't change a thing.
3) re-installing the theme does not work (neither as normal nor as root user)
4) root does not have icons either
5) the preference dialog is able to show previews (this is important! I looked into the index.desktop file and found that there are values in there that instruct the dialog which ones to show as previews. It is called "Example=". I conclude that the configuration program finds the icon set, however KIconLoader does not. I can't think, why it wouldnt, though.
6) there is another entry in index.desktop that made me think: Inherits=hicolor What is up with that? I do have the hicolor theme installed. There is a strange link to crystal in hicolor (it pointed to itself, I tried changing it to point at the installation of crystal. No effect)
7) /var/log/kdm.log: kdecore (KIconLoader): ERROR: Error: standard icon theme "crystalsvg" not found! (all the more strange is that the icon folder is called "crystal" not "crystalsvg". Maybe this is an entry from the previous install. I dont know if the folder was called "crystalsvg" then.)

If someone can provide a solution for this problem, I would greatly appreciate it.
However there are other pieces of information that might be of help:
1) Does anybody have Crystal SVG beta installed? If so, what is the installation directory called?
2) Does anybody have an idea of what configuration file sets the icon theme?

Thank you for all information you can give me,
- drowstar
 
Old 05-22-2004, 12:55 PM   #2
drowstar
Member
 
Registered: Apr 2004
Location: Germany
Distribution: Slackware, Gentoo, Fedora
Posts: 205

Original Poster
Rep: Reputation: 30
Hi again,
I am sorry to have bothered you with this problem. I have found a temporary solution. I hope this will still serve some users as help when they run into a similar problem. It really was a hard one.

Here's a work around:
Make a symlink called crystalsvg to crystal in your personal icons folder (~/.kde3.2/share/icons/) and crystal will be recognized as the old theme and used correctly.
It is a dirty hack, so dont do it, except if really necessary.

I am off to find what really caused it and to file some bug reports.

Thanks everybody,
- drowstar
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make a Icon set for KDE... agentdunken Linux - General 1 09-25-2005 07:32 PM
Change the KDE default ICON !? memo007 Linux - Software 2 09-08-2005 07:50 PM
Icons disappeared in KDE (RH9) after installing icon scheme Googelybear Red Hat 1 02-20-2004 05:52 AM
Default KDE Icon Directory rkid Linux - Software 2 10-06-2003 10:03 PM
changing kde default icons sandman Linux - General 3 11-03-2002 03:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration