LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-12-2004, 05:43 PM   #1
kupek85
LQ Newbie
 
Registered: Aug 2004
Location: West Lafayette, IN
Distribution: Slackware 10.1
Posts: 22

Rep: Reputation: 15
no glx extension


I recently tried to play tuxracer for the first time, but instead of getting the game, got this:

Xlib: extension "GLX" mission on display ":0.0"
***tuxracer error: Couldn't initialize video: Couldn't find matching GLX visual (Success)

I've emerged version 1.0.6111 of nvidia-glx and nvidia-kernel, and when I run "modprobe nvidia," it shows up in lsmod. The next step, from what I've gathered, is to change my xorg.conf file to read

Driver "nvidia"

Under the device section, but if when I try this and exit from X, I can't get back into X. The xorg.conf file also has "glx" uncommented and "dri" commented, like it's supposed to be. Also, I've recompiled my kernel and rebooted, so that can't be it.

Thanks in advance!
 
Old 08-12-2004, 05:46 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
First check your X log file. It's called /var/log/X[version].0.log and contains lots of useful information for troubleshooting. Look for lines starting with (EE), indicating errors.


Håkan
 
Old 08-12-2004, 07:17 PM   #3
kupek85
LQ Newbie
 
Registered: Aug 2004
Location: West Lafayette, IN
Distribution: Slackware 10.1
Posts: 22

Original Poster
Rep: Reputation: 15
The file /var/log/Xorg.0.log has this important line:

(EE) Failed to initalize GLX extension (NVIDIA X driver not found)

This still doesn't make much sense to me, as the driver shows up under lsmod.
 
Old 08-12-2004, 07:50 PM   #4
kupek85
LQ Newbie
 
Registered: Aug 2004
Location: West Lafayette, IN
Distribution: Slackware 10.1
Posts: 22

Original Poster
Rep: Reputation: 15
One other thing worth mentioning: my card is a Radeon 9600 Pro. Hope that helps.
 
Old 08-13-2004, 04:49 PM   #5
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Try opengl-update nvidia to change the GL libraries to nvidia's GLX.


Håkan
 
Old 08-28-2004, 12:51 PM   #6
IQTech
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
I also had that error message on my NVidia card.
Then, I tried this command:

sh ./NVIDIA-Linux-x86-1.0-6111-pkg1.run --opengl-headers

That fixed it.
 
Old 09-05-2004, 02:02 AM   #7
W@cked0ut
LQ Newbie
 
Registered: Sep 2004
Distribution: Fedora Core
Posts: 1

Rep: Reputation: 0
Try this it will more than likely work, though funny thing that you'd use a windows fix in windows but bare with me:

1) uninstall the nvidia driver (pretty easy just run the installer script with --uninstall)
2) re-install (using --opengl-headers)
3) change xorg.conf appropriately (as noted in Nvidia's readme file)
4a) xorg.conf, make sure nothing repeats as I have found that under the "screen" section there were some repeat values
4b) look for other duplicate values, like anything relating to DRI (comment it out) , as I have commented it out, and wine thought it was smart and added it back in for me and it has come back right next to the where I previously commented it out, how nice!
5) Go back into X, problem should be solved
 
Old 09-23-2004, 02:19 PM   #8
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Quote:
Originally posted by kupek85
One other thing worth mentioning: my card is a Radeon 9600 Pro. Hope that helps.
Since your card is made by ATI, perhaps you should immediately get rid of the Nvidia drivers you are using and install the ones for ATI. I believe that they are available in portage. If not, you should be able to get them from the ATI site. Follow their directions carefully. Be sure to enable "DRI" and "glx" in your xorg.conf and make sure that there is a
Code:
Section "DRI"
    Mode 0666
 EndSection
as well to give users permission to use the 3d accelleration. Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no glx extension??? i need linux gaming RacerD Linux - Hardware 8 04-16-2004 09:14 AM
Nvidia GLX Extension Issue jeffkjo Linux - Hardware 5 10-29-2003 10:08 PM
OpenGL GLX extension not supported by display: :0.0 kranthi Linux - Newbie 3 10-23-2003 12:29 AM
extension glx missing contrasutra Linux - Software 2 04-01-2003 11:05 PM
(II) [GLX]: Initializing GLX extension - X wont go hydro Linux - Software 3 02-20-2003 07:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration