-   Linux - Software (
-   -   nm-applet disappears from GNOME - partial fix (

xtiansimon 02-18-2010 11:02 PM

nm-applet disappears from GNOME - partial fix
I've been experiencing problems with the Network Manager applet. I've posted around and no easy answers. I was unable to find any answers, and by accident found a work around.

Briefly the trouble is the applet does not appear when the desktop is started in my normal/main user. I've tried to start it manually, and tried reinstalling network manager. It appears in the root account when I start up GNOME desktop. But it only works with the one user. Bugzilla discussed a similar bug and there the fix was related to SELinux. I have set SEL to permissive, so this does not apply.

Long story shorter, my temporary fix is to plug an ethernet cable in when the desktop starts and then pull it to use wifi.

I am hope this workaround gives someone an idea of a fix.


indienick 02-19-2010 04:41 PM

What groups, in /etc/group, does your user belong to?

$ grep -i $USER /etc/group

xtiansimon 02-21-2010 01:42 PM

The user belongs to its own group, Xtian, and the root account.

xtiansimon 02-26-2010 07:32 PM

workaround broke
workaround not working after slow internet connection and halt.

Today I was visiting a web site with lots of artistic reference photos. The site became bogged and slow by a incessant javascript. I tried to restart. I started clicking and everything became bogged down and unresponsive. The logout window popped up about six menus! I canceled these and opened up a terminal window--I got two of these--and typed the halt command. Thats it.

When I tried my workaround on the next login, no nm-applet as before. I had to log-in with root to get the wifi to connect and send this email. Hoping a solution or troubleshooting procedures will be posted soon.

indienick 02-27-2010 11:57 PM

Try adding your user to the plugdev and netdev (or network) groups. If there's a NetworkManager group, add your user there, too.

xtiansimon 03-09-2010 01:59 PM

Groups was the answer! Thanks.

indienick 03-10-2010 10:46 AM

No problem. :)
Glad I could help.

All times are GMT -5. The time now is 04:16 PM.