LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-26-2014, 08:27 AM   #31
kirejak
LQ Newbie
 
Registered: Feb 2014
Posts: 15

Rep: Reputation: Disabled

I can give you file with ns-2.29 or ns-2.33 installed in linux in vmware. You will just need vmware on your windows xp to open this simulator. Write me on kire_jakimoski@yahoo.com for details and the transfer of the file.
 
Old 02-18-2015, 10:18 PM   #32
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
knudfl : hi i have absent for necessary things .
i installed VMware and ubuntu 10.10
and i try to install ns2.29 .....
when i type sudo apt-get install <package>
i have this :
Reading package lists ...Done
Building dependency tree
Reading state information...Done
E:Unable to locate package <package>


?????
 
Old 02-19-2015, 04:58 AM   #33
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← ref post #32, @hibaa.

Ubuntu 10.10 Maverick is an old OS, was moved to the Ubuntu Museum long time ago.

You can however still use 10.10 (unsafe?) ...
→ Please replace /etc/apt/sources.list with this text ...
Code:
deb http://old-releases.ubuntu.com/ubuntu/ maverick main restricted
deb http://old-releases.ubuntu.com/ubuntu/ maverick multiverse universe
deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ maverick-updates multiverse universe
deb http://old-releases.ubuntu.com/ubuntu/ maverick-backports main restricted
deb http://old-releases.ubuntu.com/ubuntu/ maverick-backports multiverse universe
deb http://old-releases.ubuntu.com/ubuntu/ maverick-security main restricted
deb http://old-releases.ubuntu.com/ubuntu/ maverick-security multiverse universe
And then run $ sudo apt-get update && sudo apt-get install \
g++ automake make patch libtool libxmu-dev xgraph


-
 
Old 02-20-2015, 02:31 PM   #34
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
Question

I want to ask u which version of Ubuntu u advice me to install ... I want to work with mobility and ns2.29

Q2: i can't replace /etc/apt/sources.list in any text , and can't edit in it , it is "Read only"

Last edited by hibaa; 02-20-2015 at 03:43 PM.
 
Old 02-20-2015, 06:53 PM   #35
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← ref. #34.

Ubuntu 10.10 - 32bits is perfect for ns2.
? Recommed a later Ubuntu version : None are recommended for ns2.
But most versions are OK with the most protocols.
Depends what you want to do with ns229. nist? wimax?


How to edit a text file : $ sudo gedit /etc/apt/sources.list


-
 
Old 02-21-2015, 01:17 AM   #36
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
I want to simulate VH handover between wimax and wifi using MIH . So I will use nist and wimax
 
Old 02-22-2015, 06:50 AM   #37
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
after i edit etc/apt/sources.list i still have error when run :
sudo apt-get update .... error as in photo .. why ??

i install successfully g++ automake make patch libtool libxmu-dev xgraph

Now ,how can i install ns2.29 and nist mobility package in Ubuntu 10.10 ?
thanks knudfl
Attached Thumbnails
Click image for larger version

Name:	Ubuntu-2015-02-22-17-09-45.png
Views:	13
Size:	211.2 KB
ID:	17637  

Last edited by hibaa; 02-22-2015 at 07:40 AM.
 
Old 02-22-2015, 07:49 AM   #38
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← ref. #37.

I guess you can ignore the "Packages.gz : Not found".
Why the errors : Don't know. Seems to be present ...
http://old-releases.ubuntu.com/ubunt...n/binary-i386/


How to build ns-2.29 + nist-mob : Probably read post #7 in this very thread.


All nist-mob INFO at LQ :
http://www.linuxquestions.org/questions/tags/nist-mob/
+ http://www.linuxquestions.org/questi...gs/wimax-nist/
The Google//ns-users Forum :
https://groups.google.com/forum/?fro...nist|sort:date


-

Last edited by knudfl; 02-22-2015 at 07:52 AM.
 
Old 02-23-2015, 01:47 PM   #39
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
when i try to install ns2.29 i have error as in photo ..


gcc version 4.4.5
should i make any change in "makefile.in" in otcl-1.11 ?
Attached Thumbnails
Click image for larger version

Name:	Ubuntu-2015-02-23-14-18-39.png
Views:	12
Size:	203.7 KB
ID:	17647  

Last edited by hibaa; 02-23-2015 at 01:57 PM.
 
Old 02-23-2015, 03:06 PM   #40
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← ref. #39.

No more black images, please. Difficult to read.
And the text cannot be copied or quoted.
* I guess you know how to copy/paste a text ?

? Have you read the text in the post #9 image ?
There is nothing about otcl-1.11. It's tcl8.4.11 .
Error : Permission denied.

You will get "Permission denied" if you do :
$ sudo tar xvf ns-allinone-2.29.3.tar.gz .
Please make sure you have ns-allinone-2.29<version 3>.tar.gz .
And then unpack in /home/usee-name/ with :
$ tar xvf ns-allinone-2.29.3.tar.gz
* Using a Windows© tool for the unpack will also result in corrupt files.


Compiler :
ns-allinone-2.29.3 requires gcc-4.1.2, but nist-mob: -3.4.6. (On some OS.)
And no "nist-mob" seems to work on Ubuntu 10.10, sorry.
(Usually we can compile with g++34 and link with g++41, but not with Ubuntu 10.10.)

See post #7 : The CentOS 6.6 build example. And post #11.

-
 
Old 03-03-2015, 03:45 PM   #41
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
when i use Ubuntu 11.04 , should i have to make any change in etc/apt/sources.list ??
 
Old 03-03-2015, 04:08 PM   #42
hibaa
LQ Newbie
 
Registered: Feb 2014
Posts: 25

Original Poster
Rep: Reputation: Disabled
when i use Ubuntu 11.04 , should i have to make any change in etc/apt/sources.list ??
 
Old 03-03-2015, 04:44 PM   #43
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← ref. #41, #42.

Old version are moved to `old-releases´, the Ubuntu Museum.
Discontinued is also 13.10, see section "End of life" here ..
https://wiki.ubuntu.com/Releases
.. So your '11.04' is also on the list.

Please do : $ gedit /etc/apt/sources.list
... and replace all the text with :
Code:
deb http://old-releases.ubuntu.com/ubuntu/ natty main restricted
deb http://old-releases.ubuntu.com/ubuntu/ natty universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ natty-updates main restricted
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ natty-security main restricted 
deb http://old-releases.ubuntu.com/ubuntu/ natty-security universe multiverse

deb http://old-releases.ubuntu.com/ubuntu/ natty-backports main restricted
deb http://old-releases.ubuntu.com/ubuntu/ natty-backports universe multiverse
... and then : $ sudo apt-get update
→ → → you can now install packages.

-
 
  


Reply

Tags
nist-mob, ns2, wimax-nist


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Needed ns2.1b6 all-in-one package on ubuntu stud17 Linux - Newbie 3 12-09-2011 10:12 PM
Package invoking in NS2.34 version Gayathriharini Linux - Software 17 04-08-2011 12:41 AM
which package for download? notnor Fedora 6 06-02-2008 12:34 PM
download package chengjin Debian 6 04-11-2008 09:35 AM
Which package shall I download satimis Linux - Software 1 07-21-2007 09:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration