LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-13-2003, 12:02 AM   #1
biotek1
Member
 
Registered: Oct 2003
Location: L.A.
Distribution: SUSE 9, Fedora
Posts: 90

Rep: Reputation: 15
nicer fonts


High I have tried several methods to copy over the MS ttf fonts from my XP fonts over to Linux (redhat 9) and configure it to use them , but all have failed.

i have created a new folder, copied over all the fonts, added the folder to the etc/fonts/fonts.conf file and generally followed most of the articles about doing this out there on google, but none seem to work..

has anyone done it on redhat 9 and succeeded , if so could you let me know exactly how?

Thanks
 
Old 10-13-2003, 12:11 AM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well, fonts is more than just copying them over to your linux fonts directory. if you have access to your windows fonts, try using kde's control center as root to make fonts available to all users. on the left menu, there's a branch called System Administration. expand that and choose font installer. click that. if this is your first run, you'll be asked to configure the font installer. basically it's just setting the directory paths of different font types like TrueType, Type1, etc. basically you're only worried about TrueType (ttf ) fonts. set the path or keep the default path to where to install ttf fonts. i set my path to /usr/local/fonts/default/TrueType. i had to create that TrueType directory.

after done configuring the font installer, navigate to the fonts you want to install by clicking the Add button. you should start getting a scrolling list of your windows fonts. when it's done scrolling, click the apply button. it will copy those windows fonts to your ttf font path, create font metrics for the fonts, create the font.dir file, and edit your /etc/X11/XF86Config-4 file. i'm running rh 7.3 and after this is done, i don't have to restartX so i'm going to assume you won't either. but if you don't see the newly installed fonts, then try to restart x.
 
Old 10-13-2003, 12:34 AM   #3
biotek1
Member
 
Registered: Oct 2003
Location: L.A.
Distribution: SUSE 9, Fedora
Posts: 90

Original Poster
Rep: Reputation: 15
hi bare with me here as i recently switched over from windows so i a still getting the hang of this.

Ok so if i log in as root i can change all fonts and use the TTF ones from windows, but when i log in as user i dont see them listed to choose from. so how do i change the directory permission so a normal user can get access so i can change the fonts?
 
Old 10-13-2003, 12:43 AM   #4
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
well if you use the kde control center > system administration > font installer as root. that will let you install fonts into a directory where all users will have access to them. like i said above i set it up my true type fonts to be installed in /usr/share/fonts/default/TrueType. i had to create that TrueType directory first though. there is a default directory on set up, but for me, it made more sense to put it in /usr/share/fonts/default/TrueType because the directory is in /usr/share which makes think of things you want to share with all users.

anyway, open up a shell terminal and type this command:

"su -"
with no quotes.

then you can make that directory by using this command:

"mkdir /usr/share/fonts/default/TrueType"
with no quotes.

then use this command:
"kcontrol"

with no quotes. that will open up kde control center so you can install the fonts where all users can use them.
 
Old 10-13-2003, 12:48 AM   #5
biotek1
Member
 
Registered: Oct 2003
Location: L.A.
Distribution: SUSE 9, Fedora
Posts: 90

Original Poster
Rep: Reputation: 15
i am using KDE 3.1-12 red hat

when i open up the control panel and click the system administration tree these are my only options:

help index

image index

login manager

paths


there is no option for font installer.
 
Old 10-13-2003, 12:55 AM   #6
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
arghh.... i hate it when red hat does that.

are you in control center? control center is not the same as control panel in kde.

i'm trying to find the command that you can run in the mean time.
 
Old 10-13-2003, 12:56 AM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
So you've installed the fonts already and they are visible to root but not to normal users? That is probably a permissions problem. You can change the permissions like this:
chmod -R a+rx {directory where you installed the fonts}

You have to do the above as root. I think this'll fix it.
 
Old 10-13-2003, 12:57 AM   #8
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
okay found it.

open a shell terminal and type this command in. you don't need to "su -" for this command as it will prompt you for your root password.

"kdesu kcmshell kcmfontinst"

no quotation marks.
 
Old 10-13-2003, 01:01 AM   #9
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
Originally posted by quatsch
So you've installed the fonts already and they are visible to root but not to normal users? That is probably a permissions problem. You can change the permissions like this:
chmod -R a+rx {directory where you installed the fonts}

You have to do the above as root. I think this'll fix it.
i'm not sure, but isn't it more than that? i don't use rh 9 so yes it could be all there is to it, but for me, along with copying the fonts and creating a fonts directory, rh 7.3 requires that it create a fonts.dir file and corresponding *.afm font metric files for the ttf fonts.

if rh 9 is the same way, the run that command above to completely install your windows fonts. if not, then i hope running chmod is all you need to do.
 
Old 10-13-2003, 01:04 AM   #10
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
In the newer versions of X, all you really need to do is to throw the stuff in one of the font directories. It helps to do
fc-cache -vf
to make things faster (it's especially noticeable when you install tons of them; I once installed 300 fonts at once and after that it took almost 40sec to open konsole before I figured out to run fc-cache). Of course, the files need the right permissions.
 
Old 10-13-2003, 01:08 AM   #11
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
Originally posted by quatsch
In the newer versions of X, all you really need to do is to throw the stuff in one of the font directories. It helps to do
fc-cache -vf
to make things faster (it's especially noticeable when you install tons of them; I once installed 300 fonts at once and after that it took almost 40sec to open konsole before I figured out to run fc-cache). Of course, the files need the right permissions.
cool. good to know. i'm a font junkie myself. i got about 1500 fonts installed.
 
Old 10-13-2003, 01:14 AM   #12
biotek1
Member
 
Registered: Oct 2003
Location: L.A.
Distribution: SUSE 9, Fedora
Posts: 90

Original Poster
Rep: Reputation: 15
Ok thanks i think i got it now, thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
making debian looking nicer leotorjeman Debian 24 02-10-2005 07:24 AM
Linspire Kicker Icons Nicer oldstinkyfish Linux - Software 0 12-02-2004 12:25 AM
Forget it! I found a much nicer forum! acneil Debian 1 10-24-2004 05:49 PM
disabling anti-alias in firefox .9/selecting nicer font for mdk 10 webazoid Linux - Software 0 06-29-2004 05:30 PM
a nicer Slackware sigeberht Slackware 2 06-24-2004 08:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration