LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-09-2009, 12:37 PM   #1
matiasar
Member
 
Registered: Nov 2006
Location: Argentina
Distribution: Debian
Posts: 321
Blog Entries: 1

Rep: Reputation: 31
Newer VLC in Debian Lenny


I'd like to install a newer version of VLC rather than the version which is shipped with Debain Lenny official repos (v 0.9.6). I tried with Lenny Backports but version remained with 0.9.6 (am I doing something wrong?).

There would be another way to get binaries (.deb or similars) or I might comiple VLC from source?

Thanks,
Matías
 
Old 11-09-2009, 12:42 PM   #2
thorkelljarl
Senior Member
 
Registered: Jun 2008
Posts: 1,807

Rep: Reputation: 215Reputation: 215Reputation: 215
The newer...

There is this reference from vlc. The unstable version, Sid, might be what you want.

http://www.videolan.org/vlc/download-debian.html

Last edited by thorkelljarl; 11-09-2009 at 01:01 PM.
 
Old 11-09-2009, 12:46 PM   #3
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Buster
Posts: 1,508

Rep: Reputation: Disabled
You could create your own Backport using sources from Sid,here's a guide:

http://forums.debian.net/viewtopic.php?f=16&t=38976
 
Old 11-10-2009, 07:03 AM   #4
matiasar
Member
 
Registered: Nov 2006
Location: Argentina
Distribution: Debian
Posts: 321

Original Poster
Blog Entries: 1

Rep: Reputation: 31
Fellows, thanks for the tips.
I think I'll follow the Debian way, trying to build Vlc from Sid's sources. I think I'll have to use a Sid box as long as some dependencies seems to requiere newer versions than those shipped with Lenny.

Regards,
Matías
 
Old 11-10-2009, 08:42 AM   #5
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Buster
Posts: 1,508

Rep: Reputation: Disabled
Quote:
Originally Posted by matiasar View Post
Fellows, thanks for the tips.
I think I'll follow the Debian way, trying to build Vlc from Sid's sources. I think I'll have to use a Sid box as long as some dependencies seems to requiere newer versions than those shipped with Lenny.

Regards,
Matías
I think you misunderstand.
You only need a source entry for Sid in /etc/apt/sources.list,you don't need to upgrade to Sid to build the backport.
You need an entry similar to this:

Code:
deb-src http://ftp.uk.debian.org/debian/ unstable main contrib non-free
 
Old 11-11-2009, 08:06 AM   #6
matiasar
Member
 
Registered: Nov 2006
Location: Argentina
Distribution: Debian
Posts: 321

Original Poster
Blog Entries: 1

Rep: Reputation: 31
The Trooper,

In my Lenny Box I added the sid's sources entry to sources.list, this way:

Code:
deb-src http://ftp.us.debian.org/debian/ sid main contrib non-free
Then, apt-get update, apt-get source vlc (like normal user)... But by the time of doing apt-get build-dep vlc

Code:
matuxdesk:/home/matias/misc/build_vlc/vlc-1.0.3# apt-get build-dep vlc
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: The dependency Build-Depends in vlc can't be satisfied because there is no version of liblivemedia-dev that satisfies the requirements.
matuxdesk:/home/matias/misc/build_vlc/vlc-1.0.3#
(I'm translating the error message from spanish).


Code:
matias@matuxdesk:~/misc/build_vlc/vlc-1.0.3$ dpkg-buildpackage -rfakeroot -us -uc
dpkg-buildpackage: set CFLAGS to default value: -g -O2
dpkg-buildpackage: set CPPFLAGS to default value:
dpkg-buildpackage: set LDFLAGS to default value:
dpkg-buildpackage: set FFLAGS to default value: -g -O2
dpkg-buildpackage: set CXXFLAGS to default value: -g -O2
dpkg-buildpackage: source package vlc
dpkg-buildpackage: source version 1.0.3-1
dpkg-buildpackage: source changed by Christophe Mutricy <xtophe@videolan.org>
dpkg-buildpackage: host architecture i386
dpkg-checkbuilddeps: Unmet build dependencies: dh-buildinfo quilt nasm iceape-dev (>= 1.1.9-4) liba52-0.7.4-dev libaa1-dev libasound2-dev (>= 0.9.0beta10a) libavcodec-dev (>= 0.cvs20060823) libavformat-dev (>= 0.cvs20060823) libcaca-dev (>= 0.99.beta4) libcdio-dev libdca-dev libdvbpsi5-dev | libdvbpsi-dev libdvdnav-dev libdvdread-dev (>= 0.9.5) libfaad-dev libflac-dev (>= 1.1.2-3) libfribidi-dev libggi2-dev libhal-dev (>= 0.5.5.1-3) libid3tag0-dev libjack-dev liblircclient-dev liblivemedia-dev (>= 2008.07.24) liblua5.1-0-dev libmad0-dev libmatroska-dev (>= 0.8.0) libmodplug-dev libmpcdec-dev libmpeg2-4-dev libncursesw5-dev libnotify-dev libogg-dev libpostproc-dev (>= 0.cvs20060823) libpulse-dev libqt4-dev libschroedinger-dev (>= 1.0.7-1~) libsdl-image1.2-dev libsdl1.2-dev (>= 1.2.7+1.2.8cvs20041007-5.3) libshout3-dev libsmbclient-dev libspeex-dev libsvga1-dev libswscale-dev libsysfs-dev libtag1-dev libtar-dev libtheora-dev libtwolame-dev (>= 0.3.8) libudev-dev libupnp3-dev libv4l-dev libvcdinfo-dev libvorbis-dev libxml2-dev libxt-dev libxv-dev
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)
Regards,
Matías
 
Old 11-11-2009, 08:20 AM   #7
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Buster
Posts: 1,508

Rep: Reputation: Disabled
Have you tried installing liblivemedia-dev manually?.
It is available for Lenny:

http://packages.debian.org/lenny/liblivemedia-dev
 
Old 11-12-2009, 06:28 AM   #8
matiasar
Member
 
Registered: Nov 2006
Location: Argentina
Distribution: Debian
Posts: 321

Original Poster
Blog Entries: 1

Rep: Reputation: 31
Trooper,

Thanks for the tips. I installed the packages and I'm running apt-get build-dep vlc right now. I'll let you know the results later.

Regards,
Matías
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VLC not showing video. Debian Lenny 64. glore2002 Debian 8 10-08-2009 12:51 AM
I want the/a newer network manager on Debian Lenny Cyberman Linux - Networking 2 10-03-2009 11:38 AM
LXer: How-To: Compile and Install Latest VLC in Debian Lenny LXer Syndicated Linux News 0 08-12-2009 05:41 AM
LXer: How-To: Compile and Install VLC 0.9.8 in Debian Lenny LXer Syndicated Linux News 0 03-24-2009 05:00 PM
ASUS EEE901 + debian lenny + ALSA + VLC = silence BigglesPiP Linux - Software 1 12-16-2008 10:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration