LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-01-2011, 11:46 AM   #1
Greet
LQ Newbie
 
Registered: Jul 2011
Posts: 6

Rep: Reputation: Disabled
new laptop. Headphones doesnt mute internal speakers.


Hi. I'm having some trouble configuring my the sound on my laptop. I'm using Alsa.
The problem is as follows.
Playing sound is no problem, but when I plug my Koss headphones into the audio jack the laptop speakers continue playing and sound also comes out of my headphones. When I go to alsamixer from cli the sound card only shows 1 master channel so I can't mute the internal laptop speakers.

My specs are.
Lenovo Ideapad s205
Amd Fusion e-350
Crunchbang Statler openbox
Squeeze kernel
2.6.32-5-amd64

I would be okay with completely disabling the internal laptop speakers if that is the easiest solution.

/proc/asound/cards
Code:
 0 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xf0244000 irq 19
 1 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xf0240000 irq 16
/etc/modprobe.d/alsa-base.conf
Code:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
I don't know if these files are to any help but I'm not sure where to look.
 
Old 08-01-2011, 11:54 AM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
Hello,

Try adding the following to the very end of your alsa-base.conf file:
Code:
options snd-hda-intel model=auto
After that, run the following:
Code:
sudo alsa force-reload
Now besides trying to auto-detect your device, you can use the following two sites and try to match your device with the correct settings within the lists.
http://ubuntuforums.org/showthread.php?t=1043568
http://www.kernel.org/doc/Documentat...dio-Models.txt

Hope that helps man!

Cheers,

Josh
 
Old 08-01-2011, 02:54 PM   #3
Greet
LQ Newbie
 
Registered: Jul 2011
Posts: 6

Original Poster
Rep: Reputation: Disabled
Ahhh thank you very much!!
After many tries I finally come by this post in the thread you linked. post #131
http://ubuntuforums.org/showthread.p...043568&page=14

I downloaded hda-verb from ftp://ftp.suse.com/pub/people/tiwai/...erb-0.3.tar.gz.
Then did
Code:
sudo hda-verb /dev/snd/hwC1D0 0x1f 0x701 1
That turned of the internal speakers so that sound only comes out of the headphones.
Now I'm a happy man! I almost started to believe that I would have to go back to Windows.
 
Old 08-01-2011, 03:28 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005Reputation: 1005
Awesome, glad to hear you got it working. I was thinking about going that route, but I wasn't sure if that would do it for your system. Kudos on the find!

Cheers,

Josh

Edit - Should have added this before.... Since you have solved your problem, please mark your thread as solved and give reputation if you feel the need to. Thanks!

Last edited by corp769; 08-01-2011 at 03:30 PM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
plugging in headphones or speakers doesn't disable my laptop's built in speakers moljac024 Linux - Software 14 07-13-2017 09:01 AM
No audio from internal speakers but headphones work matt1123 Linux - Hardware 5 10-17-2010 03:38 PM
Sound Heard in external headphones but not in internal speakers of laptop @skm3nt Linux - Newbie 8 08-28-2010 08:26 PM
Fedora 12 on laptop - speakers wont mute when headphones plugged in jan1024188 Linux - Software 2 04-08-2010 12:34 AM
Audio from inbuilt monitor speakers does not mute on plugging in headphones aru11f11 Linux - Newbie 1 09-26-2008 06:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration