LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-10-2003, 11:29 PM   #1
blackatom
LQ Newbie
 
Registered: Sep 2003
Posts: 1

Rep: Reputation: 0
New ATI drivers and Mandrake 9.1


I have been waiting for some decent drivers from ATI for about a year now, and finally they released some that actually support the 9500 pro. I followed ATI's instructions word by word and had a fairly clean install. The problem is when I use the fglrxinfo command i see that my current drivers are MESA drivers, how do I delete all of the mesa libraries and have all Open GL apps switch over to the new ATI ones? Also I now when i type "startx" it says it cannot find AGP. Have I totally missed installing AGPGART? and how can I find out. I hate being a newbie to linux, but we have to start somewhere I suppose.
 
Old 09-11-2003, 01:07 AM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
To find out if you've got agpgart, as root, type lsmod...

That will list all the currently loaded modules.
If agpgart is one of them, then nah, that's not it.

If it's not in there, try the command:
modprobe agpgart

and see what you get.

Also, did you install the drivers with rpm?
Try uninstalling them, and then installing them with the force overwrite existing libraries function, don't remember which option that is. But it's a common problem switching from mesa to opengl.

HOpe this helps

-Shade
 
Old 09-11-2003, 09:36 AM   #3
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,042

Rep: Reputation: 54
As in the previous post, try "rpm -ihv --force <paket-name>". It should work

Hope it helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Install ATI Drivers in Mandrake 10 svoltmer Linux - Newbie 4 09-14-2004 12:58 AM
ATI drivers and Mandrake sherington Mandriva 3 10-17-2003 01:18 PM
ati drivers and mandrake 9.1..help wazungy Linux - Hardware 1 09-26-2003 02:22 AM
Mandrake 9.1 and ATI drivers :] szymon Linux - Hardware 2 05-21-2003 06:06 PM
Mandrake 9.0 and Ati Drivers neilh89 Linux - Hardware 5 04-09-2003 05:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration