-   Linux - Software (
-   -   Network slows down system (

davecs 07-10-2003 09:25 AM

Network slows down system
I know there is probably a simple solution but ...

Whenever I am downloading from the internet via my ethernet cable connection, the rest of the system slows down. The mouse movement jerks. If I am playing a game full screen when the computer decides to poll the net, the action freezes. I am using Shorewall firewall, from the shorewall site, not from the Mandrake disc.

I recently had to re-load due to a problem caused when I tried to get a Compact Flash card working, and this did not happen before. So there is obviously something I've done differently in the setup. Is there some kind of multi-task server that I haven't installed?


Asus A7N266VM Mobo
Athlon XP2200
512Mb RAM
2 Hard Drives, CD RW and DVD Rom
Kouwami Firewire Card
Kouwami Compact Flash Reader

Mandrake 9.1 with latest 2.4.21-0.18mdk kernel
Latest nForce drivers for Video, Network and Sound.


cnjohnson 07-10-2003 01:30 PM

Have you tried running top and see if there is something grabbing cpu/memory that should be?

Have you done a df to see about hard drive space? Is the system thrashing?


DrOzz 07-10-2003 01:50 PM

as root try this:
hdparm -c /dev/hdx where "x" is where is the letter you replace corresponding to your harddrive, most likely "a"..
check and see if you have 32bit support.
it will say something like:
IO_SUPPORT = 1 (32bit)
and then run the command:
hdparm -d /dev/hdx and see if its using dma
it will say something like:
using_dma = 1 (on)
post back telling if this is what they say, and if they dont' say this post what they do say when you issue these commands..
cause if your running at 16bit then this may be an issue..

davecs 07-10-2003 04:08 PM

Hi, problem solved.

I simply re-installed the original kernel. Clearly the newer kernel and the nVidia nForce drivers don't see eye to eye.

The nForce tar.gz relies on the kernel source being present in order to compile correctly, and the kernel source is not quite right for the later kernel, because KDE Control Centre won't display it.


davecs 07-10-2003 04:31 PM

Dr Ozz, I tried what you said about hdparm, out of interest, and both my hard drives were in 16-bit mode, though dma was enabled correctly. I did hdparm -c1 /dev/hdb and they did go into 32-bit mode but on restarting the computer they were back in 16-bit.

I don't think disc issues were the problem, I really think that for some reason the machine was not multitasking properly with the new kernel and nForce driver, and the on-board ethernet was stealing all the clock cycles. By running Mandrake Control Centre and disconnecting the internet, everthing started going smoothly...

Now I have reverted to the old kernel, I can play Pinball whilst downloading and everything is smooth!

Now what do I do to force my computer to fire up with the hard drives in 32-bit mode? They are reasonably modern Maxtors and I have no reason to think they are not capable.


DrOzz 07-10-2003 08:25 PM

it definetaly could very well be the problem, cause a guy i know had the exact same problem where all his shit was choppy, and once i told him to do that, his machine was running like a dream...
anyways, what we did if you want to enable 32bit is we threw the lines in his rc.local file..
/sbin/hdparm -c1 /dev/hda or hdb in your case.
we also added
/sbin/hdparm -d1 /dev/hdd
for the reason that dma was disabled by default and without it he had choppy dvd playback.
also you may be able to add something like:
options hdd-cd dma=1
in your modules.conf file for dma.

Electro 07-10-2003 10:04 PM

By now the kernel should optimize all storage devices. Some distributions might have it disabled.

To save your hdparm settings. Put the hdparm in rc.local at the last line. Every time LINUX boots up it will change the storage devices to whatever settings.

davecs 07-11-2003 03:09 PM

Thanks, all. I know rc.local . I thought there might have been a way of stopping the drives from starting in 16-bit mode in the first place.

I've added three lines:

hdparm -c1 /dev/hda(b,c)

to force my hard drives and dvd rom to start in 32-bit mode. They already default to dma.

My CD-RW uses ide-scsi. hdparm does not work with it. Do I need to do anything to ensure that it is running 32-bit/dma?


DrOzz 07-11-2003 03:15 PM

can you elaborate on your last problem....i don't get what your saying really....i also use scsi emulation for my cdrw cause its an ide device, so that can't be the problem for you...

Kernel command line: ro root=LABEL=/ hdd=ide-scsi
ide_setup: hdd=ide-scsi

[.:.root.:. .:.(~).:.]# hdparm -c /dev/hdd

IO_support = 1 (32-bit)
[.:.root.:. .:.(~).:.]# hdparm -d /dev/hdd

using_dma = 1 (on)

as you see there is no problems from my a little more detail, such as the command your using and the error your getting...and actually if your getting something like permission denied, look above what i said about the modules.conf file to deal with your cdrw...just add that line to your modules, and add the same line you added for others to your rc.local and it will work.

davecs 07-12-2003 11:33 AM

Silly me!

My CDRW uses IDE to read, but SCSI when recording, so I just need to add the same line as before to rc.local, but using /dev/hdd.

How thick!


davecs 07-13-2003 11:39 AM

Just as a matter of interest, I restored my backup taken with the updated kernel, guess what? The DMA flag was correct, and I changed the IO_SUPPORT mode to 32-bit. It made no difference. I also took a more critical look at when the computer slowed down and as far as I could see it was ONLY when internet activity took place.

Just thought I'd better check because one of my previous posts dealing with the suggestion earlier about the problem was a bit arrogant, sorry!!!

Before restoring that image, I backed up my current setup, so I restored that just now and all is again well. I still think the "build-18" kernel-source file is faulty, because KDE Control Centre will not load it, reports an error.


All times are GMT -5. The time now is 12:52 AM.