LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-22-2017, 06:32 PM   #1
dwburt
LQ Newbie
 
Registered: Nov 2012
Distribution: Ubuntu
Posts: 15

Rep: Reputation: Disabled
Network printer not published


I have 2 Linux systems and a network printer. One system is Mint 18. There I searched for the network printer and system-config-printer created a printer definition that works. The other system is Ubuntu Gnome 16.10. The same procedure with system-config-printer generated exactly the same Settings. URI dnssd://Canon%20MG5500%20series._ipp._tcp.local/?uuid=00000000-0000-1000-8000-F481391DCFEF
But when I print test page the state goes to Processing - Unable to locate printer "Canon-MG5500.local".
On the Gnome system Printer Properties Policies "Enabled", "Accepting jobs", "Shared" are all checked but there is also the message "Not published. See server settings"
Is this the key to what is wrong? Can somebody give me some background on what this is about and where to go?
 
Old 01-29-2017, 05:29 AM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: root
Distribution: Slackware & BSD
Posts: 1,669

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Try enable the CUPS in the web browser http://(IPAddressOfPrinter):631, and there configure the Canon printer.
 
Old 01-29-2017, 09:09 AM   #3
dwburt
LQ Newbie
 
Registered: Nov 2012
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: Disabled
Thanks for the pointer. But we've got to dig a little deeper. When I try your suggestion I get a 404 error. I can ping the printer IP address and nmap shows the port is open: "6312/tcp open ipp CUPS/1.4." It also reports "_http-title: 404 Not Found."
 
Old 02-01-2017, 08:10 PM   #4
dwburt
LQ Newbie
 
Registered: Nov 2012
Distribution: Ubuntu
Posts: 15

Original Poster
Rep: Reputation: Disabled
That "Not published" business has gone away but I'm still stuck on something wrong with the connection. How do you troubleshoot attached screenshot? Also, last entry in cups error log is "E [01/Feb/2017:19:56:30 -0600] [cups-deviced] PID 24796 (gutenprint52+usb) stopped with status 1!"
Attached Thumbnails
Click image for larger version

Name:	Screenshot Printer_Problem.png
Views:	78
Size:	122.3 KB
ID:	24100  
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] libreoffice cannot find network printer, offers only (non-existent) generic printer pierssnell Linux - Newbie 10 01-27-2020 11:05 AM
Brother HL2070N network printer installed, print jobs stuck in printer que jgz Linux - Networking 0 02-14-2008 10:54 PM
Installing Canon LBP USB Printer as network printer on a Fedora Core without XWindow boy3dfx2 Linux - Newbie 5 06-03-2006 01:23 PM
CUPS Network Printer/ server indicator blinks no printer output wine Linux - Networking 8 03-18-2006 10:20 PM
setup printer on client machine(slackware 8) to server (slackware7) network printer changwoo Slackware 9 05-02-2003 05:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration