-   Linux - Software (
-   -   Need to Know How to install a Sound Card Driver (

The_Bug 10-01-2003 11:04 AM

Need to Know How to install a Sound Card Driver
O.K. After having to find a decent graphics adapter I've finaly got Mandrake 9.1 on my system. Now all I need is to learn how to install drivers for the audio and I need to know how to get my Linux machine on my existing network so I can get to the internet and what-not. I'm running a Compaq Presario 4814 with on-board graphics and sound *but* I have a better (somewhat) Trident 3d 9750 (4mb ram) but I am using the existing on-board sound card and am having trouble figuring out why there is no sound or sound drivers. I've learned that Linux doesn't support the existing S3 Trio 3D graphics card could it not support the on-board sound as well? Also, I've been experienceing some application or features not running ... they crash. I had about 2 or 3 small errors on install but other than that everything went O.K. I tried the KDE desktop first but soon realised I prefer GNOME. (much more like old Macs of which I'm a huge fan) but besides that I've noticed that some KDE specific things won't run like the control center won't load up right. The interface does but none of the componants (or modules?) but with GNOME I'm able to configure my system decently. Any help for this Linux Newbie on all or any of these things would be greatly apreciated! Thanks ... I think I am in Love with Linux ... I can hardly stand using my Windows XP Pro machines now even though I know them inside and out. Thanks guys!


dbkluck 10-01-2003 11:51 AM

kde/gnome compatibility is a crap shoot. in theory, everything should run on either, but i've found that i practice, some stuff doesn't run properly. the system configuration tools i've found to be particularly problematic-- your best bet is to stick to configuring the system with whichever gui you're using. (or, even better, don't use a gui at all-- god made emacs and .conf files for a reason:) )

as for the sound issue. in all likelihood, that's a module problem. do you happen to know the chipset of the onboard sound card? you should be able to find it on compaq's website, or if you're stuck, try using intel 810, as that one's pretty common with onboards. to try it, type "modprobe i810_audio" at a command prompt and see what happens. if that works, you'll have to either edit your /etc/modules.conf file to load i810_audio at bootup, or ask a mandraker if there is a mandrake specific way of configuring modules. (i'm sure there is, i just don't know what it is).

if fixing the modules doesn't work, you may be having issues with your sound daemon. try turning it off and seeing whether you get sound. i've found that gnome's default sound daemon, esd, is a lot more trouble than its worth. (to turn it off in gnome, go to desktop preferences and make sure that "enable sound server on startup" is unchecked).

if none of that helps, write back with some more info and we'll re-evaluate.

hope this helps.

The_Bug 10-01-2003 12:54 PM

O.K. I turned off the daemon ... but one quick not ... the sound didn't work whether I was in KDE or GNOME. I would rather be more command line freindly but I'm not so for now I'm going to have to do my best with both the GUI and command line until I get more aquatined with it at least. I didn't get a chance to go to Compaq's web site for driver info, when I was building this thing it seems they weren't much help when I ran into the graphics card issue. I'll try when I get a chance. The only way I know to get any info on the chipset is either look up the box's model no. i.e. "4814" or take it down again and look for some numbers on the board. If so, what am I looking for on the board if anything? I am not happy with this hardware setup at all ... but considering it was a donation-to-the-cause the only money I shelled out was for my Sony monitor ($20 yard sale) and for my wireless mouse ($1 another yard sale) O.K. I am not sure I ran the command line correctly or not but I was able to turn off the audio server in GNOME.... I'll get more info and post later ... thanks a million !!!!!

mossy 10-01-2003 01:19 PM

"Linux doesn't support the existing S3 Trio 3D graphics card"

- are you SURE??? I believe I got this old card installed and working on Mandrake 9.0 - I can't be sure but I believe I put that card on that pc and it was working. I believe it will need to old XF86Config

I just ran a few quick searches for a linux driver and did nt find one - hmm maybe your right - however I found this, more closely
uid: archive

there is a binary of os2 but not linux - wondering if anyone can rewrite it - does'nt RH come with that driver - I really thought it was available.

I will look into it more when I get home - I am nearly certain I have it at home. I will let you know.

The_Bug 10-01-2003 01:43 PM

When it comes to Linux I am certain of nearly nothing. Yet according the research I've done it lends beleif that there are no drivers for this card. Seeing how it is an on-board thing I really don't think there is. I am not sure though as I've said ... thanks for all the help!!!

mossy 10-01-2003 02:26 PM

Also run a search for ALSA on this site - it is a better sound driver and is being shipped with the next round of most distros. Not too hard to install - there are plenty of threads on it in here.

dbkluck 10-01-2003 08:17 PM

oh, another thought, do you know if mandrake has a version of the program "sndconfig?" it was originally made by and for redhat, but a lot of distros have it now (there's a version for debian, which is about as far from redhat as you can get, so i imagine that there's a version for mandrake.) as root, type "sndconfig" at the command line and see if anything happens. if you're lucky, it'll go through an easy little automated program and find your chipset, load right modules, etc. it's worth a shot.

The_Bug 10-01-2003 08:39 PM

sorry .... I'm not that lucky ... when I installed Mandrake it had this nice feature before it installed the system where I could choose how/what the machine was going to be used. i.e. server/workstation/multimedia/gamer etc ... Since, I had a bear of a time configin' the hardware I thought it best just to run through the very minimal install. So, like I only hit one or two of the check boxes like workstation and multimedia... or something like that. Would this have anything to do with it not picking up my audio? I think not but I don't know much about Linux. Also seeing how I did go bare essencial is there a way I can go in from the install CD/CDs and add these features? Or perhaps the drivers I need? Also would Linux pick up another sound card if I were to drop on in? I've got about 6 PCI slots I'm not using. Any help on RAM optmising would be great too. I've only got 98 megs on the old thing with the intent on getting at minimum 256 when money and time allows. I need to know EVERYthing about Linux from a newbie standpoint so any advice for a newbie would also be greatly apreciated... also I'm having no luck getting in on my network... I've no clue where to even begin to ponder that one. I've got on NT 4.0 server/backoffice and at least three Win XP pro machine on my network at any given time. (if any of that helps) also running a MS Router (wired base station) and my two machines are hooked into it via a crossover connection to a router on my desk. O.K. thanks for all this help .... I really have the utmost respect for anyone as smooth with Linux as if it were a day in the park. I only hope to aspire to it one day myself.

The_Bug 10-01-2003 08:49 PM

lright I tried the sndconfig with no luck ... but on a whim I went to red hat's site and found the *.rpm but I've got no way of opening it or running it. How would I do this? Nautalus tells me "no viewer associated with this file" I've got no clue ... thanks a million!

mossy 10-01-2003 09:16 PM

hmm actually - if you have the Hd space - it would have been better as a beginner to have installed as much as you can - that way it will make things easier on you and you would have less to install - Also you would get a better taste of the linux flavour overall as you can test all the different software [there is tonnes of it]. Disregard the alsa suggestion - they don't have any driver for s3 -

Is the onboard card the S3 Trio 3D or your pci/agp card?

You can test if the driver is already installed by typing:
If you get reply reply reply your nic driver is prolly installed - if so hook it up ti the network and boot up to pull an ip from your router [if you have one].
If you do not get a reply -
What is the onboard nic make and model - you can find this by checking the oem's site or by calling their tech support.
When you know - then search for driver and install it according to it's instructions/README file.
then hook to your router and [as root] type:
ifdown eth0
ifup eth0
this will pull an ip from the router.
to see if you have an ip - if so - ping another computer on your network - if you get a response open up a browser and start surfing.

mossy 10-01-2003 09:19 PM

to install an rpm type:
rpm -Uvh your.package.what.ever

also to see what a command does check the man pages:
man rpm
in fact check man pages on everything you can - get a linux book for the easy stuff. It is well worth it.

mossy 10-01-2003 09:19 PM

always read the installation instructions or README files.

The_Bug 10-02-2003 07:41 AM

Thanks Mossey,

I'm game for a complete reinstall of Linux to get everything on it. I do beleive that I should do it now rather than later. I've got a 6 gig total hard drive space and I let Maandrake auto-partiotion it. (it knows best right? lol) So, I think all told I had like 1.5 gigs total by checking all possible. I haven't even browsed the CD-3 yet. Also, do I need to have the RPM in a special directory when I install it or specify where it is when I run the command? I forget what make model the network card is but when I had XP on there it used a generic Intel driver. Would that work as well on Linux or is it more precise than that? I don't have much time to spend with it today as I would like but tommorow I'm going to dive in this project fully. Thanks for all this help ... I never met such a brotherhood (and sisterhood) of poeple devoted to so much help. It not only makes me feel I'm getting more out of learning a new OS but I really feel as if I'm a part of the larger picture and that's what Linux is everyone working together to make life easer and fun! ... thanks again for all the help I can't thank y'all enough!

mossy 10-02-2003 01:01 PM

"need to have the RPM in a special directory"
no - it will install itself where it needs to. install it from wherever you download it [usually your home dir or wherever you keep your d/l's]

let me know what ping produced.

yeah I find the linux community are pretty cool.

The_Bug 10-02-2003 01:37 PM

it didn't give me anything - bug I did find that "lisia" is running and "eht0" shows up in the process list ... so I think I've got a network driver for the card but setting it up is where I went wrong or need help in.

All times are GMT -5. The time now is 07:36 PM.