LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-25-2014, 12:03 PM   #1
ousmanesi
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Rep: Reputation: Disabled
Need ns-2.34 package that installs correctly


Hi,
Please can someone point me to find package ns-Allione-2.34.tar.gz functioning properly because it (http://sourceforge.net/projects/nsna...e/ns-allinone- 2.34 /) does not install correctly
or send it to me on bodjat2@gmail.com
Thank you.
 
Old 12-25-2014, 12:44 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 26,926

Rep: Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016Reputation: 8016
Quote:
Originally Posted by ousmanesi View Post
Hi,
Please can someone point me to find package ns-Allione-2.34.tar.gz functioning properly because it (http://sourceforge.net/projects/nsna...e/ns-allinone- 2.34 /) does not install correctly
or send it to me on bodjat2@gmail.com
Thank you.
We will be glad to try to help, but you need to read the "Question Guidelines", the LQ Rules, and "How to ask a question the smart way". Just saying "does not install correctly", tell us ABSOLUTELY NOTHING that would let us try to help you. You don't tell us what version/distro of Linux you're using, what you did, what message(s)/error(s) you got, etc. Without details, we can't help.

Also, we are NOT going to email you things..either participate in the community and the forums, and share your solutions, or you need to come up with them on your own. We aren't going to provide you with free, personalized, one-on-one email tech support.
 
1 members found this post helpful.
Old 12-26-2014, 04:53 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Welcome to LQ.

`ns-allinone-2.34.tar.gz“ :
http://sourceforge.net/projects/nsna...allinone-2.34/
http://sourceforge.net/projects/nsna...ar.gz/download

* If the build of ns-allinone-2.34 fails :
Please show all your commands.

Specifying your OS :
a) The reply from the command $ uname -m
b) OS Name and version.

-
 
1 members found this post helpful.
Old 12-27-2014, 04:38 AM   #4
ousmanesi
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thank you all,
Also thank you for your advice.

I downloaded http://sourceforge.net/projects/nsna...ar.gz/download
I followed the steps for installing ns-allinone-2.34
1) sudo apt-get update
2) sudo apt-get upgrade
3) sudo apt-get install -f build-essential autoconf automake libxmu-dev
4) tar -zxvf ns-allinone-2.34.tar.gz
6) cd ns-allinone-2.34
7) ./install

and finally here is what I found
ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Error 1
otcl-1.13 make failed! Exiting ...
See http://www.isi.edu/nsnam/ns/ns-problems.html for problems

My OS Name and version are
Linux version 3.13.0-43-generic (buildd@akateko) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) )

Thanks.
 
Old 12-27-2014, 02:45 PM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,519

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
← #4 .
Quote:
I followed the steps for installing ns-allinone-2.34
* This is how it should be done ...
* Ubuntu : $ sudo apt-get install \
g++ g++-4.4 autoconf automake libtool patch libxmu-dev xgraph

$ tar xvf ns-allinone-2.34.tar.gz
$ cd ns-allinone-2.34/
$ patch -p0 < otcl_ns234_gcc-4.4.patch
https://drive.google.com/file/d/0B7S...ew?usp=sharing
$ export CC=gcc-4.4 CXX=g++-4.4 && ./install
$ cd ns-2.34/ && sudo make install

Nam : Select a package for your OS here, post #2 ...
http://www.linuxquestions.org/questi...-4175524760/#2

Your version : Looks like a "12.04" version.
The real version information is found with 1) $ cat /etc/issue
.. and 2) $ uname -m
Please show the output from those two commands, if you want further answers.

-

Last edited by knudfl; 12-30-2014 at 01:00 PM.
 
1 members found this post helpful.
Old 12-30-2014, 12:51 PM   #6
ousmanesi
LQ Newbie
 
Registered: Apr 2014
Posts: 3

Original Poster
Rep: Reputation: Disabled
hello,
I installed ns2.34 successfully.
Thank you Mr knudfl.
My version is perfectly, 12.04
$ cat /etc/issue
Ubuntu 12.04.5 LTS \n \l
~$ uname -m
i686

Thank you again for your help
 
  


Reply

Tags
ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I broke my package manager / broken package blocks installs [Debian Wheezy] arthoc Linux - Software 4 06-20-2014 03:57 AM
[SOLVED] a package installs to / sycamorex Slackware 3 03-16-2010 03:31 PM
Need help with package installs Bodrey Linux - Newbie 3 12-19-2009 10:47 PM
Fedora 3 and 4 installs fine but doesnt boot correctly prob, no clue what to do vtecturbo13 Fedora 10 12-30-2005 09:36 AM
package installs... mathfeel Fedora 4 12-01-2003 05:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration