-   Linux - Software (
-   -   need help: yum broken after removing new kernel (

zogthegreat 08-09-2009 11:04 AM

need help: yum broken after removing new kernel
I seem to have broken something after removing a test kernel that I had installed. I removed the kernel with the following command:

rpm -e kernel-

The kernel was erased, but I received an error about "grubby", that I seem to have lost. When I run "yum xxx" this is what happens:

[root@gryphon ~]# yum -y update
Loaded plugins: auto-update-debuginfo, fastestmirror, presto, protectbase, refresh-packagekit, refresh-updatesd
Found 15 installed debuginfo package(s)
Enabling fedora-debuginfo: Fedora 11 - x86_64 - Debug
Loading mirror speeds from cached hostfile
fedora/metalink | 16 kB 00:00
updates/metalink | 12 kB 00:00
* fedora:
* fedora-debuginfo:
* livna:
* rpmfusion-free:
* rpmfusion-free-updates:
* rpmfusion-nonfree:
* rpmfusion-nonfree-updates:
* updates:
Reading repository metadata in from local files
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "/usr/share/yum-cli/", line 309, in user_main
errcode = main(args)
File "/usr/share/yum-cli/", line 178, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/", line 348, in doCommands
File "/usr/lib/python2.6/site-packages/yum/", line 101, in _getTs
File "/usr/lib/python2.6/site-packages/yum/", line 112, in _getTsInfo
pkgSack = self.pkgSack
File "/usr/lib/python2.6/site-packages/yum/", line 649, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.6/site-packages/yum/", line 491, in _getSacks
File "/usr/lib/python2.6/site-packages/yum/", line 232, in populateSack
File "/usr/lib/python2.6/site-packages/yum/", line 79, in doSetup'postreposetup')
File "/usr/lib/python2.6/site-packages/yum/", line 180, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/", line 51, in postreposetup_hook
File "/usr/lib/yum-plugins/", line 38, in enable_debuginfo_repos
File "/usr/share/yum-cli/", line 130, in doRepoSetup
File "/usr/lib/python2.6/site-packages/yum/", line 503, in _getSacks'exclude')
File "/usr/lib/python2.6/site-packages/yum/", line 180, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/", line 51, in exclude_hook
repo1pkgs = _pkglisttodict(conduit.getPackages(repo1))
File "/usr/lib/python2.6/site-packages/yum/", line 584, in getPackages
return self._base.pkgSack.returnPackages(arg)
File "/usr/lib/python2.6/site-packages/yum/", line 397, in returnPackages
return self.sacks[repoid].returnPackages(patterns=patterns,
KeyError: 'fedora'
[root@gryphon ~]#

I have tried to do the following:

package-cleanup --problems
yum clean all
yum clean metadata
yum clean packages
yum clean dbcache

Anyone have a suggestion?



lazlow 08-09-2009 01:37 PM

Purely guessing here.

If you ran a yum update with that kernel installed you may have drawn in some kernel dependent stuff. With the debug repo enabled this becomes even more likely. Whenever possible on RH based systems you want to avoid using the rpm command as much as possible(sometimes it cannot be avoided).

One thing you can try is to reinstall that kernel (via rpm obviously). If that clears up the issue, then remove the kernel with yum. That should take care of any dependency issues.

All times are GMT -5. The time now is 11:14 AM.